Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

There was an error while interacting with the Database. on UCCX Sub

After updating Platform and security passwords on my UCCX Pub and Sub now on the Sub only I get this error when trying to update an application.

 

There was an error while interacting with the Database. Tried rebooting still getting error.

Everyone's tags (2)
13 REPLIES

can you post the output of

can you post the output of below from your pub and sub:

utils dbreplication runtimestate

-Terry

Community Member

(No subject)

Ok here is your problem, you

Ok here is your problem, you have got bad replication. Use below commands on the SUB and PUB.

On your sub:

utils dbreplication stop

Then Go to PUB:

utils dbreplication reset SUBSERVER

 

Then keep checking by running utils dbreplication runtimestate (on pub) both should show a value of 2. It may take 30 mins or more to get back to normal.

 

-Terry

How did you go?

How did you go?

Community Member

Tried that still didn`t work.

Tried that still didn`t work.

can you post the output of

can you post the output of utils dbreplication runtimestate again? When you changed the security password, did you change on both servers and did you reboot the cluster after that?

-Terry

Community Member

Will post result when I get

Will post result when I get in office but pub has a 2 sub 3. I did reboot each pub and sub. And last night rebooted sub again.  

Did you manage to resolve

Did you manage to resolve this?
 

Community Member

No resolution, opened tac

No resolution, opened tac case, they had me to do another reboot after hours last night, did not resolve. I have tried dbreplication repair several times. Will follow up with them today. Currently it is only affecting Intelligent center reporting. We did take snapshots of the VM`s before changing the passwords and this happening, not sure how UCCX will respond if we restore those and start over. We do have two ntp servers defined on the Pub and the first one of those doesn`t exist anymore but tac says if we replace it we may run into having to upload a license file again. We didn`t think that is the issue because looking at logs it has been that way for awhile. Will address that later. Any more ideas? Thanks

Community Member

There is nothing wrong with

There is nothing wrong with the database replication shown in the pic.  The entries for both servers show a replication status of (2) at the end, which is healthy.  If he had made his CLI window a bit wider it would have been easier to read.

You guys seems to be confusing the replication ID's with the replication state.  It's normal for the ID's to be (2) for the Pub and (3) for the Sub.

Community Member

Resolved. Had to run the

Resolved. Had to run the utils uccx syncuser command.

Purple

Hi,just wanted to know :Did u

Hi,

just wanted to know :

Did u run this command on both UCCX servers?

 

after u did this , any restart of server was also required?

 

regds,

aman

ok cool - thanks for the

ok cool - thanks for the update.

-Terry

575
Views
0
Helpful
13
Replies
CreatePlease to create content