Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

UC520 and WAN/ data VLAN/ corporate LAN configuration

Hi

I've got our SPA525 phones working fine when connected via cable to the UC520 PoE ports.

I'm not sure however how to configure things so that I can connect PCs to the phones and still have normal network access.

Our configuration, from outside in:

1) ISP router

2) Cisco ASA5505 firewall

3) HP Switch connecting the whole network on 192.168.0.0/255.255.255.0, with some static IPs and the rest assigned by DHCP server.

Which port wouild I use to connect the UC520 to this network?

How do I configure the data VLAN (any any other required settings) so that it is connected to the main domain network?

Many thanks

Steven Segal

Johannesburg, South Africa

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Re: UC520 and WAN/ data VLAN/ corporate LAN configuration

Steven,

          Are you using 192.168.0.0/24 for your phones as well?  It sound like your HP switch is unmanaged and you are only using vlan 1, the ASA is your default gateway in the network i assume.  I think in this case you would only need to add an additional command to the ports the phones are connected to.  You need switchport voice vlan 1 command and switchport access vlan 1 command.  The connection between the UC520 and the HP switch only need to be an access switchport vlan 1 port.

phone port

interface FastEthernet0/1/1
switchport access vlan 1  ------------------> determins which vlan the pc goes on
switchport voice vlan 1 ------------------> determins which vlan the phone uses
macro description cisco-phone
auto qos voip trust
spanning-tree portfast

connection to HP

interface FastEthernet0/1/8
switchport access vlan 1
switchport mode access
macro description cisco-switch

By doing this you are in effect merging the two networks, you will need to take the DHCP pool for the phone off the UC520, so the phones will look for DHCP from the servers, then you need the option 150 in your dhcp server to point the phones to the UC520 for there config, so the UC520 which will need to be placed in vlan 1. So your command " interface vlan 1" on the UC520 should be given an ip in the 192.168.0.0/24 range and this ip should be set as reserved in your DHCP servers, this will also be the ip that is the option 150 in the dhcp servers.

Jason

2 REPLIES
Community Member

Re: UC520 and WAN/ data VLAN/ corporate LAN configuration

Steven,

          Are you using 192.168.0.0/24 for your phones as well?  It sound like your HP switch is unmanaged and you are only using vlan 1, the ASA is your default gateway in the network i assume.  I think in this case you would only need to add an additional command to the ports the phones are connected to.  You need switchport voice vlan 1 command and switchport access vlan 1 command.  The connection between the UC520 and the HP switch only need to be an access switchport vlan 1 port.

phone port

interface FastEthernet0/1/1
switchport access vlan 1  ------------------> determins which vlan the pc goes on
switchport voice vlan 1 ------------------> determins which vlan the phone uses
macro description cisco-phone
auto qos voip trust
spanning-tree portfast

connection to HP

interface FastEthernet0/1/8
switchport access vlan 1
switchport mode access
macro description cisco-switch

By doing this you are in effect merging the two networks, you will need to take the DHCP pool for the phone off the UC520, so the phones will look for DHCP from the servers, then you need the option 150 in your dhcp server to point the phones to the UC520 for there config, so the UC520 which will need to be placed in vlan 1. So your command " interface vlan 1" on the UC520 should be given an ip in the 192.168.0.0/24 range and this ip should be set as reserved in your DHCP servers, this will also be the ip that is the option 150 in the dhcp servers.

Jason

Community Member

Re: UC520 and WAN/ data VLAN/ corporate LAN configuration

Hi Jason

I get what you're saying, but managed to come right soon after the post.  The phones are on VLAN 100, the problem was just that I needed to set the smartport I'd used to connect the UC520 to the HP switch to switch mode for vlan 1, and then all came right.

Thanks

Steven

840
Views
0
Helpful
2
Replies
CreatePlease to create content