Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

** Ugrent --CUCM Upgrade 8.6 to 10.5 issue **

Hello all,

We have upgraded CUCM from 8.6 to 10.5 (direct upgrade).

After upgrade we cant make changes into CUCM Publisher. While adding phones or device profile we are facing following error:

Add failed. The Insert privilege is required for this operation.

Also, our Cisco Unified Attendant Console Enterprise Addition sync with CUCM is not successful.

CTI RoutePoint & CTI Ports are not registered gone into unknow state.

Attached are Attendant console enterprise CUCM sync reports screen shot.

DB Replication for whole cluster is good with value 2.

Need urgent help - our system is in production now & we dont have cisco support agreement at the moment.

Regards,

11 REPLIES
Cisco Employee

Try a Cluster reboot.

Try a Cluster reboot. Publisher followed by Subscribers. Install logs will tell you if there were any issues during upgrade or whether the upgrade completed successfully or not. A restart will most likely resolve the issue or upgrade to the latest Version/ES - For this you'll need a TAC case to get the image as I can see you are already on 10.5(1) which is the latest released version.

New Member

Here are the install logs

Here are the install logs:

admin:file view install system-history.log

=======================================
Product Name -    Cisco Unified Communications Manager
Product Version - 10.5.1.10000-7
Kernel Image -    2.6.32-431.3.1.el6.x86_64
=======================================
09/12/2014 22:16:31 | root: Install 10.5.1.10000-7 Start
09/12/2014 15:45:21 | root: Boot 10.5.1.10000-7 Start
09/13/2014 02:17:53 | root: Install 10.5.1.10000-7 Success
09/13/2014 02:17:54 | root: Boot 10.5.1.10000-7 Start
09/13/2014 02:41:59 | root: DRS Restore UCMVersion:10.5.1.10000-7 Start
09/13/2014 02:55:15 | root: DRS Restore UCMVersion:10.5.1.10000-7 Error
09/13/2014 03:06:55 | root: Boot 10.5.1.10000-7 Start
09/13/2014 03:16:24 | root: DRS Restore UCMVersion:10.5.1.10000-7 Start
09/13/2014 03:55:07 | root: DRS Restore UCMVersion:10.5.1.10000-7 Success
09/13/2014 03:59:19 | root: Boot 10.5.1.10000-7 Start
09/13/2014 06:16:40 | root: DRS Restore UCMVersion:10.5.1.10000-7 Start
09/13/2014 06:21:33 | root: DRS Restore UCMVersion:10.5.1.10000-7 Error
09/13/2014 09:31:10 | root: DRS Backup UCMVersion:10.5.1.10000-7 Start
09/13/2014 10:09:25 | root: DRS Backup UCMVersion:10.5.1.10000-7 Success
09/14/2014 12:38:48 | root: Restart 10.5.1.10000-7 Start

options: q=quit, n=next, p=prev, b=begin, e=end (lines 1 - 20 of 21) :
admin:
admin:

Cisco Employee

I don't see a Shutdown or a

I don't see a Shutdown or a Restart before 'Boot 10.5.1.10000-7 Start'. How was the server restarted? Looks like it was hard powered down. You need to use 'utils system restart' to restart the server or 'utils system shutdown' to shut down the server. If the procedure is not done correctly the file system can become corrupt. Like Manish suggested, run the recovery disk to check for file system corruptions. Use Option 'f' to correct it. Also console into the server (via vSphere Client) and check for any errors during CLI start up.

 

New Member

Gents,Thank you so much for

Gents,

Thank you so much for quick responce & help.

We some how managed to open case with Cisco & engineer found its bug

CSCug28446: Add Phones fails with error Insert privilege is reqd for this operation

And the fix is available in following version:

UCSInstall_UCOS_10.5.1.11007-1.sgn.iso

We upgrade all went normal include CTI ports & CTI Route Point.

Regards

Cisco Employee

Great, thanks for sharing the

Great, thanks for sharing the bug for the benefit of others.

Manish

VIP Purple

It seems that CSCug28446 Bug

It seems that CSCug28446 Bug is not available publicly.

[+5] to Manish , Anirudh and Coniesaga

regds,

aman

New Member

We are here to help each

We are here to help each other ..

Cheers !!!
 

Cisco Employee

Glad to hear the issue is

Glad to hear the issue is resolved. This is not a valid defect (not available publicly) and hence there is no fix in a higher version.

I checked the defect notes: When the pub is down, our database connector automatically falls back to the local database (ie. The subscriber you're on), which is why you can still successfully query/read all of the data.  However, the subscriber does not have any update/delete/insert privileges which is why we see the exception.

 

So it looks like you had a temporary connectivity issue with the Publisher's database. Maybe a permanent lose of connectivity... can't say for sure.... Might have resolved itself if you had waited for sometime... really can't say again...  A rebuild or an upgrade to any version will resolve the issue. A restart will help sometimes.

 

Cisco Employee

The error suggests that the

The error suggests that the server is most likely in Read Only mode and would require a recovery iso. Please check the following link for similar error

http://www.cisco.com/image/gif/paws/108928/CCM6_update_error.pdf

HTH

Manish

New Member

Manish,I have already tried

Manish,

I have already tried command mentioned in the pdf u shared but not luck

after enter command i tried relaod publisher only as well but it was same.

regards,

 

Cisco Employee

That command will not work in

That command will not work in cucm 10.x, you need to download the recovery iso for version 10.5 and boot from it to fix any file system errors.

Manish

546
Views
15
Helpful
11
Replies