Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unified Communications: CUP/CUPC Softphone problem

Hello all,

I am experiencing some problems with a new setup (CUCM 7.0.2 / CUPS 7.0.3).

On previous same setups (CUCM 7.0.2 & CUPS 7.0.2) everything went well. Desk phone & Soft phone service on UPC working without any problem. On this new setup we only manage to work Desk phone control. Unfortunately the Soft phone is not even shown on the phone mode list. When I try to troubleshoot the issue with Server Health tool I see that the Soft Phone is trying to connect using TCP and port 2748 instead of UDP 5060. The line ID is correct.

Is there a way that I can change this? I really need your help on this matter.

Is there any bug with CUPS 7.0.3?

Regards,

Elias

2 ACCEPTED SOLUTIONS

Accepted Solutions
Red

Re: Unified Communications: CUP/CUPC Softphone problem

May I ask what is the user ID? If there's any non-alphabet non-numeric characters in the user ID, you're hitting a bug on 7.0.3. CUPS 7.0.3 won't allow such a user ID to get SoftPhone. Please upgrade to 7.0.4.

Michael

Red

Re: Unified Communications: CUP/CUPC Softphone problem

Yes you can. Go to CUPS Admin > System > Topology. Change the server name there.

Michael

http://htluo.blogpsot.com

19 REPLIES
Red

Re: Unified Communications: CUP/CUPC Softphone problem

Could you go to "show server health", highlight "softphone" on the left, post a screenshot here?

What version is your CUPS? 7.0.3 or 7.0.4?

Make sure the DN configured on UPC device is the same as the "Primary Extension" on "User Management > End User".

Michael

http://htluo.blogspot.com

New Member

Re: Unified Communications: CUP/CUPC Softphone problem

Hi Michael,

Thank you very much for your quick reply.

I have just update my post above to be more specific.

For this setup I am using 7.0.3.

Previous setups was 7.0.2

Yes, the DN configuration is as you said.

Attached is the screenshot.

I read on one of your post that 7.0.3 has some bugs with the UserID. So I am now downloading 7.0.4...

Thanks

Red

Re: Unified Communications: CUP/CUPC Softphone problem

May I ask what is the user ID? If there's any non-alphabet non-numeric characters in the user ID, you're hitting a bug on 7.0.3. CUPS 7.0.3 won't allow such a user ID to get SoftPhone. Please upgrade to 7.0.4.

Michael

New Member

Re: Unified Communications: CUP/CUPC Softphone problem

Yes. UserID has dot (.) something like 'n.nick'. I read about this on your previous post.

Does this has to do with the use of TCP 2748 instead of UDP 5060 (SIP)?

Elias

Red

Re: Unified Communications: CUP/CUPC Softphone problem

It's irrelevant. As indicated on the screen, 2748 is for "Call Control", which means CTI control. It's listed there for informational purpose.

Michael

New Member

Re: Unified Communications: CUP/CUPC Softphone problem

Thank you.

I will update server soon and i will let you know.

Elias

New Member

Re: Unified Communications: CUP/CUPC Softphone problem

Hi Michael,

You are right. I have upgrade the server from 7.0.3 to 7.0.4 and now the SoftPhone is active.

Thank you very much.

I have one more question.

Is there a way to change the default login server on the CUPC login screen. For example the login server is “cups01”. Can I change it into “cups01.xx.xx”?

This is because some clients are not connected to the domain and cannot access the server without the “.xx.xx”.

Regards

Elias

Red

Re: Unified Communications: CUP/CUPC Softphone problem

Yes you can. Go to CUPS Admin > System > Topology. Change the server name there.

Michael

http://htluo.blogpsot.com

New Member

Re: Unified Communications: CUP/CUPC Softphone problem

Thank you again Michael. I didn't expect to be so simple.

I will let you know if I have any issue completing the installation.

I appreciate your help.

New Member

Re: Unified Communications: CUP/CUPC Softphone problem

Hi Michael again,

I have a final question - trouble with this setup.

On the previous setups we have CUPS and Unity Connection 7.

So the integration between them went well since the Unity Connection uses IMAP.

On this setup we have Unity 5 with exchange. I enable IMAP service and connect CUPC using SSL 993.

For some reason the TCP 143 was not working. I cannot even telnet using this port.

Now everything on the Show Server health is green (instead of secure messaging because we didn't configure it).

Now the problem is that after this integration, the Red Led (MWI) on the Phone (that indicates new voice mail) is not working.

The voice mail server used to sent the message to users email (on outlook) and the Led remains on if he/she didn't hear it.

Now the voice mail is sent to the outlook but the red led is always off on the phone.

The voice mail sent the message to CUPC after some minutes.

I really need your help on this. Is there a way to enable the MWI and at the same time use the CUPC?

Red

Re: Unified Communications: CUP/CUPC Softphone problem

If you're using Exchange 2007, IMAP over TCP (port 143) is disabled by default. You may enable it with Exchange Management Shell. For details, see http://www.lulu.com/content/5552336.

Regarding MWI, it should be on if there is news messages in voicemail. "New" means "unheard". If it's heard on phone or CUPC, the MWI would be off. Isn't that the case?

Michael

New Member

Re: Unified Communications: CUP/CUPC Softphone problem

Hi,

Thanks for your reply.

We are using exchange 2003. The IMAP service has been enabled and the unheard or heard voice mails are coming to the CUPC.

Is it a problem we are using SSL 993 instead of TCP 143?

The problem is that unheard voice mail are coming on the user's email but the led on the phone is now always off.

Previously, before we start the IMAP and integrate voice mail with UPC the unheard voice mails were sent on user's email and the red led was on until a use hear the message.

Red

Re: Unified Communications: CUP/CUPC Softphone problem

To isolate the problem, you may disable IMAP service on Exchange and see if the problem persists.

Michael

New Member

Re: Unified Communications: CUP/CUPC Softphone problem

Hi Michael,

Yes, what I said previously it is the case.

The IMAP now is off and the MWI working properly (also an email is sent on the Outlook).

Any suggestions?

Red

Re: Unified Communications: CUP/CUPC Softphone problem

Now we know IMAP has something to do with MWI.

The next step is to isolate CUPS/CUPC.

Can you have IMAP turned on but have the voicemail feature turned off from CUPS?

See if the problem persists?

Thanks!

Michael

New Member

Re: Unified Communications: CUP/CUPC Softphone problem

Did it.

IMAP is active. I just change the IP address for mailstore on the CUPS so the voice mail on show server health is "Server unreachable". The MWI is working properly.

New Member

Re: Unified Communications: CUP/CUPC Softphone problem

Hi,

I have CUPS/CUPC 6.0 and Unity 5.0 UM with Exchange 2003 (so, exchange server is not collocated with Unity). Which setting do I have to fill in the field Application/CUPC/Unity Server? There is no IMAP service on the unity itself.

Thank you.

Best regards,

Yorick

Red

Re: Unified Communications: CUP/CUPC Softphone problem

You should fill in the Exchange IP. And you should have IMAP running on your Exchange.

Michael

http://htluo.blogspot.com

New Member

Re: Unified Communications: CUP/CUPC Softphone problem

Hi Michael,

Thank you again for your great help.

Ok, I understand now that the Unity integration with CUPC is exclusively done with direct IMAP connection.

In our environment, Exchange servers have their IMAP services disabled for security reason, so CUPC users will not be able to listen their voicemail.

It does not matter because we are in UM mode...

Best regards,

Yorick

521
Views
5
Helpful
19
Replies