Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Unity 4.0.2 to Unity Connection 7 migration tool

Hello,

I was wondering if anyone has a little more insight into if the Migration Export tool is supported with Unity 4.0.2. I have contradicting documents on Cisco's site and ciscounitytools.com website.

Thanks,

George

Please rate useful posts.
23 REPLIES
Cisco Employee

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Please point me at these documents that contradict so they can be corrected.

The CSV based export/import tool is supported from 4.0(2). this is NOT the same tool as COBRAS - COBRAS gets considerably more data for more objects and requires 4.0(5) or later.

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Hi Jeff,

I am relieved now. Heres the document I was referring to.

http://www.cisco.com/en/US/docs/voice_ip_comm/connection/7x/upgrade/guide/7xcucrug022.html

So just to be very sure, will Unity 4.0.2 be supported with Migration Export tool?

Thanks,

George

Please rate useful posts.
Cisco Employee

Re: Unity 4.0.2 to Unity Connection 7 migration tool

actually messages may not be able to come out of 4.0(2)... I'll have to check tomorrow AM. the MAL interface changed in 4.0(3) rather significantly and the export tool is using the MAL interface to get the messages out.

Frankly, we highly recommend going to 4.0(5) and using COBRAS. QA doesn't even test this path any longer and we're dropping it entirely in 8.x just for the record. Is there some reason upgrading to 4.0(5) is not an option for you?

Cisco Employee

Re: Unity 4.0.2 to Unity Connection 7 migration tool

ah, someone in QA has pointed out that for the 7.x release of Connection they only tested back to 4.0(5) apparently - the code can handle directory information back to 4.0(1) and messages back to 4.0(3) but that's moot at this point since it was never qualified (hence not TAC or BU supported).

There's no cost to upgrade to 4.0(5) (minor version) from 4.0(2) - is it just the time involved that turns you away?

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Yep, just the time constraint. I am not looking to migrate messages, just subscriber data. Assuming 4.0(2) migration is not TAC supported I think I have to move to 4.0(5). I will have to talk to the customer on this. Also, I was watching the COBRAS videos and the Import video seems to be clipped off towards the end. :)

Please rate useful posts.
Cisco Employee

Re: Unity 4.0.2 to Unity Connection 7 migration tool

The video was 49 minutes and a couple seconds, right? Yeah, I'm just wrapping up there and the audio got clipped off. You didn't miss anything.

I need to redo all those videos for the 8.0 release - lots of new functionality and material to cover, I'll be using the updated version of Camtasia and they'll be much better quality this time around...

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Sounds good. Thanks Jeff for all your help and I appreciate you responding to my post.

Please rate useful posts.

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Hi Jeff,

Do you foresee any issues on rebuilting a server in VMware and restoring my 4.0.2 data to it, then upgrading it to 4.0.5 and running COBRAS on it.

Thanks

George

Please rate useful posts.
Cisco Employee

Re: Unity 4.0.2 to Unity Connection 7 migration tool

not sure how you're getting your 4.0(2) server into VMWare but on paper that's not a problem - we test with VMWare all the time with COBRAS...

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Hi Jeff,

We will install 4.0.2 on VMware and do a DiRT restore on to it. Upgrade to 4.0.5 and then run COBRAS.

How does that sound?

Thanks,

George

Please rate useful posts.
Cisco Employee

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Perfectly reasonable plan of action.

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Thanks again Jeff.

Please rate useful posts.

Re: Unity 4.0.2 to Unity Connection 7 migration tool

My next question will be, will the import into Unity Cxn be supported by TAC if something goes wrong?

Please rate useful posts.
Cisco Employee

Re: Unity 4.0.2 to Unity Connection 7 migration tool

it'll be supported by me insofar as I can and TAC escalates COBRAS issues to me.

If you want you can FTP the resulting COBRAS backup you do somewhere and I can do a debug import into a lab system here first. No messages please... just the directory backup MDB (the lawyers get on me about messages).

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Hi Jeff,

Thanks a lot for your help on this. I will let you know what I find out.

Thanks,

George

Please rate useful posts.

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Hi Jeff,

Is it possible to change the alternate contact fields prior to the migration? Please let me know.

Thanks,

George

Please rate useful posts.
Cisco Employee

Re: Unity 4.0.2 to Unity Connection 7 migration tool

No, you can change the alias and extensions for users but it doesn't let you go in and start messing around with more exotic data like the alternate contact numbers or one key rules and such. That'd be pretty complex to do cleanly...

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Hi Jeff,

thanks a lot for the confirmation. Also, I was wondering if you will be able to do a debug import into cxn next week for me?

Please rate useful posts.
Cisco Employee

Re: Unity 4.0.2 to Unity Connection 7 migration tool

sure - just make the directory backup MDB file available via FTP somewhere and I can import it onto any version of Connection 7.x no problem.

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Thanks a lot Jeff! I will email you the info.

Please rate useful posts.
New Member

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Hi Jeff,

could you tell me the difference between "Unity 4.x to Unity Connection2.x migration export tool" and "Unity to Connection migration tool"?

I found the first tool's description in the document [Reconfiguration and Upgrade Guide for Cisco Unity Connection Release 7.x], but the link is unaccessable.

And I only find the "Unity to Connection migration tool" in the http://www.ciscounitytools.com/ all downloads.
Does it means that "Unity to Connection migration tools" will replace the old "unity4.x to Unity connection2.x migration export tool"?
If so, unity4.0(1)-unity4.0(4) must be upgraded to uinty4.0(5) or later before using migration tools like COBRAS or "Unity to Connection migration tool"?

your regards,
sai

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Sai,

The best way to go here is to use the COBRAS migration tools, period.  The older CSV-based tool doesn't get as much data and will have limitations based on what can be pulled from older versions like 4.0(2) vs. a COBRAS-supported version like 4.0(5).  There are many changes in the DB and other interfaces between your version and 4.0(5).  So, COBRAS is the preferred migration tool.  So, in order to be as successful as possible and get as much data as possible migrated between systems you'll need to do a dual-upgrade by first upgrading your existing system to 4.0(5) and restoring via DiRT.  Once the system is online and healthy, you can use the COBRAS Export tools to grab all the data possible for migration.  On the CUC 7 system, you'll need to do some manual configurations before using the COBRAS Import tool.  Then once you are ready, import the data using the COBRAS Import tool for CUC 7x and, depending on your config, you may have a little manual work to do in clean-up after the fact.  All in all, I've used COBRAS a number of times now and it makes things much easier and less cumbersome for migrating between versions, platforms, etc.

Hailey

Please rate helpful posts!

Cisco Employee

Re: Unity 4.0.2 to Unity Connection 7 migration tool

Everything David said was spot on - just a bit of history to fill in here.

The CSV migration tool was what was released to handle migrations before COBRAS was "born".  Yes, it has more or less been retired since it doesn't provide any additional value and is considerably less robust (and QA hasn't tested it end to end in some time for that matter).  It was kept around since technically it _could_ support versions of Unity older than 4.0(5) - COBRAS can't go back earlier than that since the database views and procs it uses to do it's work were not fully fleshed out (or mostly fleshed out) till the 4.0(5) release.  However the CSV based tool was never updated to go back further and QA balked at testing versions older than 4.0(5) anyway so it was rendered moot.

I believe in the 8.5 version of the docs coming out later this year references to the CSV based tool will be dropped entirely.

491
Views
10
Helpful
23
Replies
СоздатьДля создания публикации, пожалуйста в систему