Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unity 4.0(4) to 5.0(1) Upgrade fails

HI there ... getting an error after running the Cisco unity setup part of the upgrade.

Everything appears to go well until right at the end when the follwoing error message screen appears.

Setup was unable to configure default settings on your system. To resolve, do the following.

1. Gather the following file from the server, where <account> is the account name of the user logged on to the server running the installation:

-\Document and Setting\<account>\Local Settings\Temp\tempu*.*

-\Document and Setting\<account>\Local Settings\Temp\SysCheck*.*

-\Document and Setting\<account>\Local Settings\Temp\AV*.*

-\Document and Setting\<account>\Local Settings\Temp\tempu*.*

-\Document and Setting\<account>\Local Settings\Temp\CommServer_*_*.*, including all subdirectories

-\CommServer\Logs\OsqlDump_*_*.txt

-\CommServer\Logs\Diag_Install_*_*.txt

-\CommServer\Logs\CfgCUApp_*_*.txt

2. Contact the Cisco Technical Assistance Center (TAC).

3. Wait for instructions from TAC before proceeding.

Am logging a TAC case but wondering if anyone else has had this and been able to fix?

Cheers,

Glenn

3 REPLIES
New Member

Re: Unity 4.0(4) to 5.0(1) Upgrade fails

I have tried the following work around as suggested by TAC but still got the error after re-running Unity setup.

--------------------------------------------

Complete these steps in order to fix this problem:

Delete the ReportDb.mdf and the ReportDb_log.ldf files located in Program Files\Microsoft SQL Server\MSSQL\Data.

From a command prompt, choose the Commserver > Reports > SQLScripts directory, and run this command in order to re-create the ReportDb:

osql -E -i ReportsSQLCreate.SQL Choose Start > Programs > Microsoft SQL Server > Enterprise Manager and verify if the new ReportDb is attached. Then run the Unity upgrade setup again.

Note: Do not delete the UnityDb instead of the ReportDb.

---------------------------------------------

Still waiting to hear back from TAC again.

Glenn

New Member

Re: Unity 4.0(4) to 5.0(1) Upgrade fails

After going through a 19-hour session of anguish in getting 4.0(5) upgraded to 5.0(1), I thought I'd share the particular solution in my case. After four failures - each occurring at the very end of the upgrade process, the TAC case was requeued to a very talented TAC engineer named Vladimir. After reviewing the log files I sent, via WebEx he went to Enterprise Manager - Management - SQL Server Agent - Jobs - and saw that SQLNightlyBackupJob showed a failed icon. Then he went to the Commserver directory and renamed UnityDb.bak (which had a Last Updated time stamp over three years old) to UnityDb.bak.old. Next he started SQLServerAgent service, and manually ran the SQLNightlyBackup job, which recreated a fresh UnityDb.bak. The upgrade was started via CUICA for the fifth time, and this time it worked.

Looking back now, knowing the source of the problem, I found clues in two places: In each failure the THIRD-to-the-last OqlDump file - NOT the last one - shows these messages:

The backup data in 'UnityDbDump' is incorrectly formatted. Backups

cannot be appended, but existing backup sets may still be usable.

Msg 3013, Level 16, State 1, Server zzzzzzz, Line 4

BACKUP DATABASE is terminating abnormally.

This particular OsqlDump log has "Running UnitydbEx.sql" as its first line.

Also, the Windows Application log has the following two entries:

3041 :BACKUP failed to complete the command

IF EXISTS(select * from master.dbo.sysdevices where name = 'UnityDbDump')

BEGIN

BACKUP DATABASE UnityDb TO UnityDbDump WITH DESCRIPTION='First Backup, UnityDb', INIT

END

Cisco Unity Setup encountered an error while running configuration SQL script 'C:\CommServer\Localize\DefaultConfiguration\ENU\UnityDbEx.sql' [Error 0x80004005]

Finally, for any Unity Product Manager reading this - - For a product so well documented and supported, these failures with a generic message are a real anomaly. The causes documented on NetPro could easily be overcome within the upgrade process via scripting.

Hall of Fame Super Red

Re: Unity 4.0(4) to 5.0(1) Upgrade fails

Hi Kelly,

I have been through many "all nighters" during upgrades on many products; Nortel, Cisco, Avaya .... the whole gamut, so I can empathize with you my friend ;-)

Thanks for posting back with your resolution to this issue. It is this type of kindness that will help us all moving forward. +5 points for this gesture of good will!

Cheers!

Rob

PS: At least you have this great sense of accomplishment now..... :)

244
Views
5
Helpful
3
Replies