Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

Unity 4.0(5) Failover setup error

Unity 4.0(5) offbox Exchange 2003

We have a primary Unity box installed and running just fine. We successfully ran the Failover Wizard on the primary, then moved over to the secondary. When running it there it gets to the "Waiting for SQL distribution agent to complete" and after sitting there for some time, returns:

The SQL distribution agent failed to start in a reasonable amount of time. As a result, Cisco Unity Failover will not work properly. Disable all Cisco Unity replication using the SQL Enterprise Manager and run this wizard again.

I'm not certain exactly how to disable replication. Is it done on the primary or secondary? I wanted to ask first to make sure I don't impact the primary server too much since it is live now.

After looking through the forums, I tried a few things including:

1. Removed drive mapping between the Unity servers (it failed before and after)

2. Even though I could resolve hostnames, I put an entry into hosts/lmhosts on both boxes, still same error.

3. Confirmed that MSSQLSERVER and the SQL agent service are both using a domain account (unityadmin)

4. Confirmed that the domain account (unityadmin) is in the local administrators group on both servers.

One thing that stuck out was a recurring error in the event log of the primary server:

SubSystem Message - Job 'WPK42-UnityDb-UnityDbPublication-WPK43-5' (0x8024C33366B2E84FA72014F9513A39F6), step 2 - Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'. The process could not connect to Subscriber 'WPK43'.

Where WPK42 represents the primary and WPK43 the secondary. It was listed under the SQL agent service.

Any suggestions would be greatly appreciated.

Thanks!

Jim

3 REPLIES
Cisco Employee

Re: Unity 4.0(5) Failover setup error

I've sent you a doc to break the replication.

As for the jobs, open Enterprise Manager and make sure that the owner is a domain account.

Bronze

Re: Unity 4.0(5) Failover setup error

Hinho,

Thank you for the documentation. We ran through that procedure, but we ran into the same problem when we re-ran the failover wizard on the secondary. Also, we checked the jobs in Enterprise Manager and verified that the owner was a domain account (unityadmin). Is there anything else we can try on this?

Thanks,

Jim

Cisco Employee

Re: Unity 4.0(5) Failover setup error

Do you have CSA or Antivirus active?

171
Views
0
Helpful
3
Replies