Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unity 4.0 - Not recording messages after CM upgrade

I have a Unity 4.0 that's presently connceted to a Call Manager 4.2. I recently upgraded the Call Manager from 4.0 to 4.2 and it's working fine. The problem is, ever since that was done, Unity doesn't seem to be recording messages when you hit someone's voice mailbox. What happens is the Unity will answer for the correct mailbox, but it won't record...it will act like it's recording, always for about 6 seconds then it will stop and play the greeting as if you were done recording and give you a few options like sending as a priority message, for example. Now that I think about it, it won't let me record my name or greeting in my mailbox either. SO for some strange reason, it just won't record at all. This system is not in production, so it's not critical, but I would like to find out what's going on with it and fix it.

Any ideas?

P.S. I also loaded the latest MS patches and so on that I found on Cisco's site for Unity 4.0 Not sure if anything in there caused this to happen. It's sort of a strange problem.

Here's a log from the port status monitor. Keep in mind my description of the problem when looking at this log:

"1","2006/12/13","10:10:41","Appl","AttemptForward"

"1","2006/12/13","10:10:41","Appl","PHTransfer"

"1","2006/12/13","10:10:41","Conv","State - PHTransfer LoadInfo"

"1","2006/12/13","10:10:41","Conv","Event is [TrueEvent]"

"1","2006/12/13","10:10:41","Appl","PHGreeting"

"1","2006/12/13","10:10:41","Conv","State - Play Greeting"

"1","2006/12/13","10:10:41","Conv","Call answered if needed"

"1","2006/12/13","10:10:41","Disp","Playing greeting for Subscriber: Jon M"

"1","2006/12/13","10:10:51","Conv","No DTMF received"

"1","2006/12/13","10:10:51","Disp","Taking message for Subscriber: Jon M"

"1","2006/12/13","10:10:51","Conv","Event is [RecordMsgEvent]"

"1","2006/12/13","10:10:51","Conv","State - Record Message"

"1","2006/12/13","10:10:56","Conv","Event NULL"

"1","2006/12/13","10:10:56","Conv","State - Run Edit Messsage Conversation"

"1","2006/12/13","10:10:56","Appl","-->MessageEditing"

"1","2006/12/13","10:10:56","Conv","State - Check Msg Edit is enabled"

"1","2006/12/13","10:10:56","Conv","Event is [UrgentEditMessageMenuEvent]"

"1","2006/12/13","10:10:56","Conv","State - Play Msg AskUrgent Edit Menu"

"1","2006/12/13","10:11:01","Conv","Event is [HangupEvent]"

"1","2006/12/13","10:11:01","Conv","State - Check Msg Length"

"1","2006/12/13","10:11:01","Conv","Event is [ZeroEvent]"

"1","2006/12/13","10:11:01","Appl","<--MessageEditing"

"1","2006/12/13","10:11:01","Conv","Event is [ZeroEvent]"

"1","2006/12/13","10:11:01","Conv","State - After Message State"

"1","2006/12/13","10:11:01","Conv","Event NULL"

"1","2006/12/13","10:11:01","Appl","Idle"

"1","2006/12/13","10:11:01","Conv","Idle"

"1","2006/12/13","10:11:01","Disp","Idle"

14 REPLIES
New Member

Re: Unity 4.0 - Not recording messages after CM upgrade

I think I found my problem. Codec issue of some sort. Doesn't seem to be any packets coming in for the codec it's looking for. I'll research that.

New Member

Re: Unity 4.0 - Not recording messages after CM upgrade

Ok I have it narrowed down a little more. Definitely something audio codec related. Not sure why though.

I can call Unity from the IP phone connected to the Call Manager. I hear the system prompts, but I cannot record new voice mail messages or record my name or greeting in my mailbox. It's as if I'm not speaking - it doesn't recognize me as if I am speaking.

So on the Avaya system I have linked to the Cisco Call Manager (via H.323 gateway link), I forced the Avaya to use only G.729. NOW the Unity acts like it's recording what I'm saying...but when I play the message back there's nothing there...just recorded silence. I don't even get that far if I don't force it to use G.729 on the Avaya side.

Now - If I call directly to Unity from the Cisco phone on the Call Manager, I get nowhere...no audio and it won't even try to record, like it doesn't know I'm speaking. Again I can hear the prompts properly, but I can never record any audio and I can't even get it to ACT like it's recording something (like I can by forcing the Avaya phone to use 729, even though it still doesn't actually record the sound).

Any ideas on what I should check? Again, all I did was upgrade Call Manager from 4.0 to 4.2. And I also updated the Microsft patches and so on for both the Call Manager and the Unity.

I'm stumped.

Re: Unity 4.0 - Not recording messages after CM upgrade

What version TSPs are you using? Sometimes if you have an older version the TSPs on Unity, you will get some strange errors. Update to the latest and greatest and check again.

New Member

Re: Unity 4.0 - Not recording messages after CM upgrade

Not sure...but since this isn't in production anyway, I went out and just did download the latest version and installed it...rebooting now. I'll see what happens :)

New Member

Re: Unity 4.0 - Not recording messages after CM upgrade

Ok, I updated that and still no luck.

Here's the software versions info -

TSP version 8.1(3)

Software Versions

Cisco Unity Version 4.0

Build Number 4.0(4)

Windows Server Version Microsoft Windows 2000 build 2195 (Service Pack 4)

System Administrator DLL 4.0.3.194

AVLOGMGRSVR 4.0.3.106

AVRESLOADERSVR 4.0.2.50

DOH 4.0.3.239

AvResMgr 4.0.3.46

AvMiuSvr 4.0.3.151

AVVIRTUALQUEUESVR 4.0.3.21

AVSASCHEDULERSVR 4.0.3.38

AvRulerSvr 4.0.3.86

AVARBITERSVR 4.0.3.207

AVCONVENGSVR 4.0.3.78

AvPhraseServerSvr 4.0.3.61

AVPAGERCONVSVR 4.0.3.99

AVFAILURECONVSVR 4.0.3.34

AVCONVMGRSVR 4.0.3.78

AVDOHMMSVR 4.0.3.1

AvStatMonSvr 4.0.2.104

AVTrapSVR 4.0.3.68

AVRSASVR 4.0.3.20

New Member

Re: Unity 4.0 - Not recording messages after CM upgrade

Here's another bit of info if it helps! I have a couple of old mailboxes on this system and the personal greetings and recorded name for those old/existing mailboxes DO play. I can log into an existing mailbox that had the greetins and name recorded before any updates were installed and those DO play correctly. I just can't get it to accept any new recordings - whether it be a recorded name for a mailbox or a voice mail message being left for a new mailbox. It's just like it's not hearing me speak and so it won't record anything.

Re: Unity 4.0 - Not recording messages after CM upgrade

So it sounds like you have a permissions problem , or a major database problem in SQL on Unity.

Unity stores all the recorded names and subscriber information in SQL. Old voicemails or new voicemails are stored in Exchange.

You may have to do a dbwalker to ensure the SQL database is correct.

Check the Event log for Unity errors on the Unity server. Since your old messages are playing, and old recorded names are playing, TSP is not at fault.

But it seems as if some attributes, or permissions are lost on the new accounts.

any errors?

New Member

Re: Unity 4.0 - Not recording messages after CM upgrade

I ran that DB Walker tool yesterday and it came up with no errors. I wonder if I should delete the mailbox I'm dealing with and create a new one? I'll give that a shot right now.

I've seen no other errors other than it just doesn't record names or voice mail messages. It won't record anything at all.

New Member

Re: Unity 4.0 - Not recording messages after CM upgrade

No luck :( I tried removing and re-creating a mailbox and I still cannot record any names, greetings or leave messages. All the system prompts can be heard, but it just won't recognize my voice. Anymore ideas?

Re: Unity 4.0 - Not recording messages after CM upgrade

Just curious here....

Assuming this is Voicemail Only....

- you are in Unity SA, you create a New Subscriber account. Unity will then generate a NEW AD account and Exchange mailbox. Correct? If this is the way you have been doing it, try it this way....

- go into your AD, create a new AD user in the "User" OU. Add an Exchange mailbox to this account.

- Log onto to this mailbox through OWA, just to make sure AD had created it correctly and Exchange has the mailbox working.

- In Unity, Log into SA, Add Subscriber, but Import from Exchange, and select this account.

Test again and see if this works.

If this works, then you know that Unity does not have permissions in AD to create or modify attributes in AD. So when it tries, you don't get notified of an error.. it just skips it.

see what you get and let us know.

New Member

Re: Unity 4.0 - Not recording messages after CM upgrade

All your assumptions were correct.

I created a new user account in AD as you described. I logged onto that account with OWA and that worked. I created a new user in Unity SA and imported the one I created in AD...that worked. But I still have the problem of no audio. It doesn't recognize me speaking.

Interesting note: when I delete a subsciber in Unity SA, it does not get automatically deleted from AD. I have to go and remove the AD account manually. Unity SA WILL create the AD account though.

More info - if I haven't said this before...when I go into the tools depot under audio management tools, I used the AudioStat tool as the information tells me to in the help section....but it appears to not be seeing any port in use at all when I make a call into a mailbox and start to leave a message. Under the Device tab of the audiostat tool, according to the user guide I should see a port in use and see which codec is being used, etc....but I see nothing...not on any port. However, if I use the Port Status Monitor under the switch integration tool area, I DO see port 1 in use and it shows me all the prompts that are playing, shows me what buttons I press when I press a key on the phone dialpad, etc. I stil think there's some goofy issue with audio codecs. I'm not sure what it is...but it sure points in that direction.

I have a case open with Cisco tech support but so far no resolution. We spent 45 minutes on the phone going over everything I already tried :( Adding new user, etc, etc.

New Member

Re: Unity 4.0 - Not recording messages after CM upgrade

Here's another interesting bit of info. All the tests I've been doing are a Cisco 7960 phone on the CallManager that the Unity is integrated with. NOW...I do have an H.323 gateway link to a Avaya system with IP phones. If I force that Avaya phone to use G.729 codec when calling the Cisco CallManager which then routes over to the Unity, it WILL act like it's recording. The message light even comes on after I hang up. But when I go to listen to the message, there is nothing but silence...BUT it's the CORRECT amount of silence - I.E. the duration of the recorded silence is the same as the duration of the call I made. So I know it thinks it's recording something...but it's not.

So this points me again to an issue with codecs. But for the life of me I can't figure out what the deal is. I can hear all the old voice mail messages from the old mailboxes, I can hear the system prompts correctly, I can hear my recorded name in my old mailbox correctly. But if I create a NEW mailbox...I get nothing. And of course I can't record any new messages in my old mailbox that once worked fine.

New Member

Re: Unity 4.0 - Not recording messages after CM upgrade

Are you still having issues with this? How many NIC's are in your Unity server? Are they both enabled?

New Member

Re: Unity 4.0 - Not recording messages after CM upgrade

Sorry for the delay...

It's fixed! You're not going to believe this...but apparently disabling the 2nd NIC that was not in use or even plugged in fixed it. I can now record my name, greeting and call in and leave a voice mail message :)

I did notice I got NO system prompts or anything at all after I disabled the 2nd NIC (which was worse than before), but once I stopped and restarted Unity, it started working.

179
Views
0
Helpful
14
Replies