Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unity 4.2 voice message broken issue

Hi, we have CUCM 7 and Unity 4.2 at central site and 3 remote sites (A, B &C) with voice GW. Now we are having a issue at remote site A, when outside customer called site A's external number and left the voice message, the user couldn't hear that message clearly since the voice was broken, but if I called internal number and left message, that's working fine. Site B & C don't have this issue. I did some tests, all is fine except I called site A external number to left voice message. I compared the router config between site A, B & C, it seems be OK. I checked with ISP and they said QoS has been enabled on the MPLS circuit. Anyone has any ideas how to troubleshoot this issue?

Thanks, Leo

Here is the voip config on site A,

----------------------------------------------------------------------------------------------------------------

AP822N0001#sh ver
Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(22)T, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Fri 10-Oct-08 00:05 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T11, RELEASE SOFTWARE (fc1)

AP822N0001 uptime is 2 weeks, 1 hour, 35 minutes
System returned to ROM by power-on
System restarted at 16:18:49 AUWST Mon Nov 8 2010
System image file is "flash:c2800nm-advipservicesk9-mz.124-22.T.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html you require further assistance please contact us by sending email to
export@cisco.com. 2811 (revision 53.51) with 239616K/22528K bytes of memory.
Processor board ID FTX1322A12X
2 FastEthernet interfaces
12 Serial interfaces
1 terminal line
2 Channelized/Clear E1/PRI ports
1 Virtual Private Network (VPN) Module
4 Voice FXS interfaces
1 cisco Integrated Service Engine(s)
   Cisco Wide Area Application Services Software 4.1.7 (b11 May 14 2010 16:02:59) in slot 1
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
255488K bytes of ATA CompactFlash (Read/Write)

If

Cisco

Configuration register is 0x2102

AP822N0001# sh run
Building configuration...

Current configuration : 7326 bytes
!
! Last configuration change at 12:16:26 AUWST Mon Nov 22 2010 by xul
!
version 12.4
service timestamps debug datetime msec localtime
service timestamps log datetime localtime
service password-encryption
!
hostname AP822N0001
!
boot-start-marker
boot system flash:c2800nm-advipservicesk9-mz.124-22.T.bin
boot-end-marker
!
card type e1 0 0
logging message-counter syslog
logging buffered 4096
no logging console
enable secret 5

!
aaa new-model
!
!
aaa authentication login default group tacacs+ line enable
aaa authorization exec default group tacacs+ local none
aaa authorization configuration default group tacacs+
aaa accounting send stop-record authentication failure
aaa accounting exec default
action-type start-stop
group tacacs+
!
aaa accounting commands 15 default
action-type start-stop
group tacacs+
!
!
!
aaa session-id common
network-clock-participate wic 0
network-clock-select 1 E1 0/0/1
!
dot11 syslog
ip source-route
ip wccp 61
ip wccp 62
!
!
ip cef
!
!
no ip domain lookup
ip domain name cmc.com
ip name-server 10.200.160.38
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
!
!
--More--                           !
!
!
!
!
!
!
!
!
!
!
!
!
voice translation-rule 1
rule 1 /6253\(....\)/ /253\1/
!
!
voice translation-profile indid
translate called 1
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
!
!
archive
log config
  hidekeys
!
--More--                           !
!
!
!
controller E1 0/0/0
framing NO-CRC4
channel-group 0 timeslots 1-16
!
controller E1 0/0/1
clock source line primary
pri-group timeslots 1-10,16 service mgcp
!
!
class-map match-all INTERACTIVE-VIDEO
match ip dscp af41
class-map match-all VOICE
match ip dscp ef
class-map match-all ROUTING
match ip dscp cs6
class-map match-any CALL-SIGNALING
match ip dscp af31
match ip dscp cs3
!
!
policy-map MPLS
class VOICE
    priority percent 20
  set ip precedence 5
class CALL-SIGNALING
  set ip precedence 5
    bandwidth percent 10
class ROUTING
    bandwidth percent 5
  set ip precedence 6
  class INTERACTIVE-VIDEO
    priority percent 10
  set ip precedence 5
class class-default
    bandwidth percent 55
     random-detect
  set ip precedence 0
!
!
!
!
!
interface Tunnel1
  ip address 10.211.1.44 255.255.255.254
keepalive 10 3
tunnel source 10.153.32.1
tunnel destination 10.150.32.3
!
interface FastEthernet0/0
ip address 10.153.32.1 255.255.255.0
ip wccp 61 redirect in
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:0
no ip address
encapsulation frame-relay IETF
load-interval 30
max-reserved-bandwidth 100
service-policy output MPLS
!
interface Serial0/0/0:0.100 point-to-point
ip address x.x.x.x 255.255.255.252
ip wccp 62 redirect in
ip flow ingress
ip flow egress
snmp trap link-status
frame-relay interface-dlci 251 IETF  
!
interface Serial0/0/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
interface Integrated-Service-Engine1/0
ip address x.x.x.x  255.255.255.252
ip wccp redirect exclude in
service-module ip address x.x.x.x 255.255.255.252
service-module ip default-gateway x.x.x.x

no keepalive
!
router bgp 65325
no synchronization
bgp log-neighbor-changes
network 10.153.32.0 mask 255.255.224.0
aggregate-address 10.153.32.0 255.255.224.0 summary-only
redistribute connected
redistribute static
neighbor 10.153.32.4 remote-as 65325
neighbor 10.153.32.4 soft-reconfiguration inbound
neighbor x.x.x.x remote-as 65000
neighbor x.x.x.x soft-reconfiguration inbound
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Tunnel1
no ip http server
ip http authentication aaa
no ip http secure-server
!
ip flow-export source Serial0/0/0:0.100
ip flow-export version 9
!
!
ip access-list extended MGCP
deny   ip 10.150.38.0 0.0.0.255 any
permit ip any any
ip access-list extended WCCP_ACL
deny   ip any host 10.254.3.10
permit ip any any
!
ip sla responder
logging trap warnings

!
!
!
!
!
!
!
control-plane
!
!
!
voice-port 0/1/0
description 2536460
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
voice-port 0/0/1:15
!
ccm-manager fallback-mgcp
ccm-manager redundant-host 10.150.38.100
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 10.150.38.100 10.150.38.101
!
--More--                           mgcp
mgcp call-agent 10.150.38.101 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
mgcp default-package fxr-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 ecm
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface FastEthernet0/0
mgcp bind media source-interface FastEthernet0/0
!
mgcp profile default
!
sccp local FastEthernet0/0
sccp ccm 10.150.38.101 identifier 2 version 6.0
sccp ccm 10.150.38.100 identifier 1 version 6.0
sccp ip precedence 3
sccp
!
sccp ccm group 900
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 2 register CFB0025842bf500
switchback method immediate
switchback interval 15
!
dspfarm profile 2 conference 
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
associate application SCCP
shutdown
!
!
dial-peer voice 1 pots
translation-profile incoming indid
incoming called-number .
direct-inward-dial
port 0/0/1:15
!
dial-peer voice 2 pots
destination-pattern 9T
incoming called-number .
direct-inward-dial
port 0/0/1:15
!
dial-peer voice 999010 pots
service mgcpapp
port 0/1/0
!
!
!
!
call-manager-fallback
secondary-dialtone 9
max-conferences 8 gain -6
transfer-system full-consult
timeouts interdigit 3
ip source-address 10.153.32.1 port 2000
max-ephones 42
max-dn 144
keepalive 60
!

1 REPLY
Cisco Employee

Re: Unity 4.2 voice message broken issue

When you were placing the internal test calls, where was your phone located?   The RTP streams are usually only set up between the two endpoints (assuming no transcoder or MTP is used).

Have you have already checked calls between IP phones at your central site (where Unity is located) and IP Phones at site A?   Are these working fine?   If not, then it's likely you do have a QoS issue over the WAN to Site A.

Have you confirmed whether or not calls from the PSTN gateway at site A experience any voice QoS issues when transferred to an IP Phone at the central site?

Is the same codec is being used for the MGCP gateway as for IP Phones at that site (check the Region settings for the Device Pool it's in)?

If these things have all been checked, then you may want to consider collecting a simultaneous sniffer trace from each end of a single call, and comparing what's seen at the two endpoints.

Kind regards,

Craig

198
Views
0
Helpful
1
Replies
CreatePlease login to create content