Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unity Connection greetings "Invalid media stream" error

I'm playing (in a lab setup) with Unity Connection 8.5.1.10000-206, and I appear to be running into bug CSCti46125. Symptoms are that using the Media Master applet in the web interface, I can upload a WAV file to use as a greeting in a call handler, it plays back through my computer speakers OK, but if I try to play back on a handset (8961) I get the "invalid media stream" error on the screen and the call out from Connection to the handset drops. If I dial the call handler it drops the call as soon as it should play the relevant prompt.
The bug toolkit says that this happens with a particular file format and that converting to an audio sample rate of 8KHz should resolve it, but I can't get it to work. I'm recording a prompt using the text to speech facility on my mac, e.g. :

say -o prompt1.wave --data-format=I8@8000 "This is only a test prompt"

then opening the file in Windows Sound Recorder and saving it out as CCITT uLaw 8KHz 8-bit mono (I'm sure there must be a simple way to do that on the mac too, but I'm new to macs and I've used Sound Recorder for Unity prompt recordings for years).

Suggestions where I might be going wrong would be appreciated!

3 REPLIES
New Member

Hi McReilly,

Hi McReilly,

Did you ever find the fix for this issue?

I am coming across the same issue and tried various audio formats, however nothing has worked.  - Running Cisco Unity 8.6.2

Any suggestions will be greatly appreciated!

Thank you!

New Member

Unfortunately not - I spent

Unfortunately not - I spent some time on it without finding a resolution, it wasn't a production environment problem so I didn't bother logging a TAC case to enlist Cisco help on it.

New Member

Thanks for the reply, I

Thanks for the reply, I appreciate it!

Unfortunately, I didn't find a resolution either however I did find a workaround.  I ended up using the Recordings > Record  > By phone method and had the client record the greeting from there.

Odd thing was the file was the exact format I was trying to upload.  

Thanks again!

-Diana 

1020
Views
0
Helpful
3
Replies
CreatePlease login to create content