Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unity Connections 8.6.2a Single Inbox Problem

We have a Unity Connections Server version 8.6.2a talking to Exchange 2010 SP1.  We have verified Authenications, HTTPS, Certs etc.  If we run a test from the Edit Unified Messaging Screen, we get the following:

Severity                               Issue                               Recommendation                               Details

The validation results for unified messaging service Exchange are the following:                                                                                                                                                                                                                                               Service "Exchange": AuthenticationMode=[Basic] [use  HTTPS/validate] Server=[server.internaldomain.com] Type=[Exchange  2007/2010] Username=[domain\UnityUser]

The server domain name can be resolved.

Server server.domain.com can be contacted by pinging.

The service port for calendaring is functioning.

The certificate verification results from SSL is X509_V_OK.

This test does not test all aspects of the configuration of  the service. To complete testing, add a unified messaging account for a  user and test the account using the Test button on the Edit Unified  Messaging Account page.            

However under the user we get:

The validation results for the user unified messaging service  account user@domain.com with service Exchange are the  following:                                                                                                                                                                                                                                               Service "Exchange": AuthenticationMode=Basic [use  HTTPS/validate] Server=[server.internaldomain.com] Type=[Exchange  2007/2010] Username=[domain\UnityUser]

Failed accessing user@domain.com on server.internaldomain.com                                    .                                                                                                                                                                                                           Diagnostic=[] Verb=[] url=[] request=[] response=[]

The system failed to perform a typical calendar operation.                                    Refer to other warnings and errors generated by the tool, and check the Tomcat log file for details.                                                                                                                                                                                                           The system failed while trying to make an API call.          

I'm completely at a loss.          

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Unity Connections 8.6.2a Single Inbox Problem

Jason,

My bet is that when you are able to view the Tomcat logs from Unity Connection you will find that you are getting an error 401 response from Exchange.

We ran into the exact same issue with our Unity Connection 8.6.2a system connecting with our Exchange 2010 SP1 server. After working with TAC and Microsoft we were able to get this working by recreating the EWS virtual directory in IIS on the the Exchange 2010 CAS server.

I hope that helps.

Thanks,

Michael Putney

9 REPLIES
New Member

Unity Connections 8.6.2a Single Inbox Problem

I've never seen the diagnostic= verb= url- request= reponse= be empty before.

Cisco Employee

Unity Connections 8.6.2a Single Inbox Problem

Hi Jason,

You're hitting a new defect that's being investigated:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCtw78566

You'll want to collect the Tomcat and Mailbox sync traces to see what the actual failure is.  The diags should have the errors that would normally be presented in the GUI.

Hope that helps,

Brad

New Member

Unity Connections 8.6.2a Single Inbox Problem

I would do that except for the fact that the RTMT with 8.6.2 gives me a java error everytime I try to use it.  Is there a way to get a different version?

Cisco Employee

Unity Connections 8.6.2a Single Inbox Problem

You can download RTMT from the Plugins menu item within Connection Administration and install that version.

New Member

Unity Connections 8.6.2a Single Inbox Problem

I get the following when I attempt to run that after install:

C:\Program Files\Cisco\Unified Serviceability\JRtmt>".\jre\bin\java" -Dsun.java2

d.d3d=false -Xbootclasspath/a:.;.\lib\xerces.jar;.\lib\log4j.jar;.\lib\jcchart45

0J.jar;.\lib\collections.jar;.\lib\JbcBeans.jar;.\lib\activation.jar;.\lib\axis.

jar;.\lib\axis-ant.jar;.\lib\commons-discovery.jar;.\lib\commons-io-1.3.2.jar;.\

lib\commons-logging.jar;.\lib\commons-lang-2.1.jar;.\lib\commons-net.jar;.\lib\i

fxjdbc.jar;.\lib\mail.jar;.\lib\maverick-debug-all.jar;.\lib\jaxrpc.jar;.\lib\sa

aj.jar;.\tzupdater.jar;.\lib\jide-common.jar;.\lib\jide-dialogs.jar;.\lib\jide-g

rids.jar;.\lib\wsdl4j.jar;.\lib\javacsv.jar;.\lib\jtds.jar;.\lib\commons-beanuti

ls.jar;.\lib\commons-collections.jar;.\lib\commons-digester.jar;.\lib\commons-el

.jar;.\lib\commons-jexl.jar;.\lib\commons-scxml.jar;.\lib\derby.jar;.\lib\xalan.

jar;.\lib\openssoclientsdk.jar -jar JRtmt.jar

Exception in thread "main" java.lang.NullPointerException

        at com.cisco.ccm.serviceability.rtmt.ui.SystemUtil.getLog4jConf(Unknown

Source)

        at com.cisco.ccm.serviceability.rtmt.ui.JRtmtMain.initTrace(Unknown Sour

ce)

        at com.cisco.ccm.serviceability.rtmt.ui.JRtmtMain.main(Unknown Source)

C:\Program Files\Cisco\Unified Serviceability\JRtmt>

Cisco Employee

Unity Connections 8.6.2a Single Inbox Problem

Yeah... looks like some sort of Java conflict with your machine.  I'd suggest trying on another machine.  The other option is to push the diags off to an SFTP server from UC's CLI. 

file list activelog cuc/diag_*

file get activelog cuc/filesyouwanttocollecthere

Brad

New Member

Unity Connections 8.6.2a Single Inbox Problem

Jason,

My bet is that when you are able to view the Tomcat logs from Unity Connection you will find that you are getting an error 401 response from Exchange.

We ran into the exact same issue with our Unity Connection 8.6.2a system connecting with our Exchange 2010 SP1 server. After working with TAC and Microsoft we were able to get this working by recreating the EWS virtual directory in IIS on the the Exchange 2010 CAS server.

I hope that helps.

Thanks,

Michael Putney

New Member

Unity Connections 8.6.2a Single Inbox Problem

You sir are 100% correct.  After grabbing the logs, we had this exact issue!

Thank you so much!

Jason    

New Member

Unity Connections 8.6.2a Single Inbox Problem

I am having same issue, however I am not able to find anything in log that references teh diagnostics=401, maybe I have wrong files, I enable all tomcats and mailbox sync?

4023
Views
0
Helpful
9
Replies