Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Unity does not transfer calls (or only sometimes) - trying now for 2 days

Hello fellow sufferers,

my Unity 5.0/CCM4.2 system drives me crazy. I want to setup a simple autoatendant that transfers calls to different extensions. I have done this in Untiy 4.0.5 a view times, but now with Unity 5 there seems to be some difference ...

So there is a Subscriber with "Caller Input" - when 1 is pressed it goes to a Call-Handler (System transfer to Call-Handler). The Call-Handler does Call-Transfer with ring this extension Nr.

But it does not transfer the call. Instead it plays the greeting message of this callhandler and wants to take a message. Why???

Normaly it shoudl transer a call as soon as there is a number entered in the transfer setings. Is this a bug or whats going on?

Tanks for your help.

Greetings, Ingo

btw. what exatly does this mean (from unity docs):

Transfer options apply only to indirect calls; they do not apply when an outsider caller or another subscriber dials a subscriber extension directly.


Re: Unity does not transfer calls (or only sometimes) - trying n

Hi Ingo -

Check the subscriber that has the caller input key set to Press 1. In the action for the call handler, does it say "Attempt transfer for" or does it say "Send to Greeting for". It should say Attempt transfer for" to ring the phone number or subscriber phone you have configured in the call handler. Or are you using the special conversation here "Caller System Transfer" that sends the call to a conversation that allows callers to transfer to a number they specify? In your question related to the indirect calls - indirect means the call came through Unity, i.e. the Opening greeting, another call handler, or as in your example, by a caller input key on a subscriber's Unity account. Direct call means I dialed a subscriber's phone and it rolled to voicemail because the phone was busy or not answered.

Regards, Ginger

Community Member

Re: Unity does not transfer calls (or only sometimes) - trying n


i have tried "Send Caller to Subscriber" with the "Attempt transfer" option - Unity plays greeting message instead of transfering.

I have also tried "Send Caller to Callhandler" with "Attempt transer" - the selected Callhandler has a telephonenumber entered in the transer call settings. Unity plays greeting message instead of transfering.

When i direct the call to the automatic converstation thing where you can transfer calls - Unity allways tells me "Call can not be transfered".

The rest of my voicemail works fine (1500 users voicemail only ...).

I have upgraded from 4.0.5 to 5.0 a view month ago - maybe it is a problem with the update or a bug.

Thanks, Ingo

Community Member

Re: Unity does not transfer calls (or only sometimes) - trying n

Hi gain,

now i got it ... damn it!

If you set "Send to Subscriber" with "Attempt transer" option you need to set the alternate transfer rule in the subcriber you want to transfer to.

Open the destination subscriber, go to "Call transfer", switch to alternate and make shure it is enabled, then select "Yes, ring extension for .." instead of "No, send directly to greeting".

That is the trick. It also works the same whay if you send a call to call handler.

Easy, but i searched on the wrong things ...

Greetings, Ingo

CreatePlease to create content