Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
New Member

unity mwi sync issue

we have unity um 5.0 w/ exch.

tac recommended w einstall ES82 due to a issue where mwi seems to get stuck either on  or off for various users at various times.

in all cases, a 'refresh' cleared issue.

After running ES82 , tac tried to rerun msg store wiz, but it failed with generic error 'unity not properly installed'.

tac said we needed to rerun permission wiz, which we can't do [only exch admin does it].

unity  seemed to be working correctly so  we left request to exch admin,

permission was rerun 3 days after the ES install and soon after the rerun, we received same user reports of mwi being stuck.

could the rerun of PW casued this? issues all reported within 1hr of pw rerun.

also, the pw rerun did not fix the msgstore wiz issue. still getting same error msg.

any thoughts or ideas would be greatly appreciated



Cisco Employee

Re: unity mwi sync issue


Did you make sure that you ran the post installation instructions

contained in the ReadMe?  There is a DTMF file and a

TestWriteableDomainController file that both need to be ran and

extracted to the root of the Commserver folder.

Hope that helps,


New Member

Re: unity mwi sync issue


i specifically asked tac about the post install stuff ....

per the cisco tac engr - there were no post install items we needed to run with our system.

are you saying these are necessary to install?



Cisco Employee

Re: unity mwi sync issue

ES73 is the latest one posted on but TAC probably provided you

with the latest internally posted ES83, which is fine.  Post

installation steps are required, otherwise you'll run into what you are

hitting now for example.  Below is the link that contains all of the

files you'll need.  Disregard the ES73, since you've already installed

83.  But, the two other files (DTMF, and TestWriteable..) are the same

for all ESes.  Follow the ReadMe.


New Member

Re: unity mwi sync issue

Hi Rob, Brad,

I am experiencing the same issue. The customer suddenly has some VMbox with the MWI not updated after a new voicemail is posted.

He did the test with the Port Monitor tool opened, and no MWI=on request is sent from Unity to CCM.

Refreshing manually the MWI status from Subscriber webpage/Message turns ON the MWI lamp.

I have the ES73 installed and I will install the ES83 tomorrow.

Rob, did you find the cause and fix?

Brad, I installed the TestWritable and DTMF patches but it did not help.

Thank you for your help.


New Member

Re: unity mwi sync issue


we installed ES82 but problem persisted.

tac had us do the registry step from the post-install notes. [original tac engr said it wasn't necessary.]

also had us configure traces

we rebooted svrs this weekend, but had 6 user reported issues yesterday. tac now analyzing traces


New Member

Re: unity mwi sync issue

Hi Rob,

Thank you for your feedback. I will install ES82 tomorrow. I will keep you informed if it solves the issue (or other fix). Can you do the same?

Thank you


CreatePlease to create content