Cisco Support Community
Community Member

Unity "Failed To Commit Changes" Message

I have Unity 4.05, Unified Messaging, WIN2K, EX2K. New install, had problems seeing the Exchange Message Store until TAC provided an ES, installed, fixed my issue. Today I changed a subscriber extension, and received the above message. The extension changed and worked, but when I rebooted to install CSA, the change was gone.

Where can I start troubleshooting or should I just call TAC?

Thanks! I saw this problem before on Schedules in an earlier version and that time it was just cosmetic. This time it means what it says.


Re: Unity "Failed To Commit Changes" Message

There are a few cosmetic errors in every version of Unity that will flag in the event log of windows. Some you can ignore. I don't know for sure if you can ignore this one without calling TAC to confirm. If you rebooted and lost the extension, it's probably not saving the change correctly.

I would make sure you are running all the latests releases for 4.0(5). This version has a few patches and SP1 release for it that helps alot!

You could run a quick test this way. Go into AD where Unity sits... pick a Unity Subscriber and change their First Name. Now go into Unity SA and see this subscribers first name has been updated. If it has not been updated, then you know something is going on with the AD/SQL sync in Unity. Unity pulls the names from AD and syncs with the Subscrbers for updates.

Any SQL errors in the event log?

The extension is not used anywhere else in Unity? All Extensions and Alternate extensions have to be unique.


Community Member

Re: Unity "Failed To Commit Changes" Message

Thanks for your reply! It seems that the customer has users in several AD OU's. The user I was trying to change is in the "IT" OU and I couldn't change him. I tried a user from another OU and there was no problem. So, it was rights to that OU in AD. From what I could discern, the user involved is unityinstall, so the customer made this user a member of Domain Admins and that fixed the problem. I had tried upgrading the Permissions Wizard and running that but it ddidn't help. I hope elevating the rights of unityinstall doesn't cause problems.

I was unaware of SP1 for 4.05. I'll get it and install.

Re: Unity "Failed To Commit Changes" Message

Hi -

The unityinstall account is not "typically" the account that is used to update the user information for directory synchronization. It is "usually" the unitydirsvc account that does this. You may want to check the accounts that you selected when running the Permissions wizard to see which ones you selected or if you selected the same account for install and directory updates. Another thing to check is inheritance. Inheritance must be selected on the user accounts otherwise the correct permissions the Unity accounts need do not get applied.


Community Member

Re: Unity "Failed To Commit Changes" Message

I have a named account, unitydirsvc, for the directory facing account, but in my case, Event Viewer was complaining about the owner of the AvDSAD service not having rights to update AD or a network connectivity issue. The owner, the account that this service logs on as, is unityinstall. I don't believe you have a choice in this matter. Customer's AD structures are unique, each one is different, and each customer has differing abilities with AD. It's a challenge to work in apps so dependent on their AD setups.

I was happy they raised the privilege on this account and fixed the problem! Thanks for your reply.

CreatePlease to create content