Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Blue

Unity Upgrade/Install Failing

Ok, here is the story. (there is a tac case on this 602929269)

- Unity 4.0(2) Primary and Secondary partnered with Exchange 2000 upgrading to 4.0(5)

In our first attempt, the upgrade of the Primary was 100% successful. However, the secondary server went through the entire upgrade and then failed at the end. A grey box popped up and said to collect all the logs from the local settings\temp directory and contact TAC. So..we reverted back to do some research.

- The second attempt. We went back through and made sure 100% that we followed the upgrade guide. Everything was followed completely. DB Walker ran fine, permissions wizard, etc. However the same exact thing happend. Primary was fine, secondary failed.

- Third attempt - This time we used "uninstall unity" utility to remove Unity and re-tried the install on the Secondary. It failed again. Each time in the tempu log it fails at:

2006-02-04T21:17:50 - Error installing default settings. (e:\views\cs_CU4.1.0.12\un_Setup\UnitySetup\Common\Src\ConfigDCS.cpp 454)

2006-02-04T21:18:20 - RunConfig Thread failed: -2147467259 (e:\views\cs_CU4.1.0.12\un_Setup\UnitySetup\Common\Src\ConfigDCS.cpp 249)

2006-02-04T21:18:20 - Mode:Install, Step:FailedStep [IDD_FAILED] (e:\views\cs_CU4.1.0.12\un_Setup\UnitySetup\InstallExe\Src\MYSETUP.CPP 252)

2006-02-04T21:18:20 - Step 'CSetupStep' (5029) modeless: 51485 milliseconds (e:\views\cs_CU4.1.0.12\un_Setup\SetupEngine2\IWLib\src\step.cpp 910)

2006-02-04T21:18:20 - Step 'CSetupStep' (5018) modeless: 0 milliseconds (e:\views\cs_CU4.1.0.12\un_Setup\SetupEngine2\IWLib\src\step.cpp 910)

I attached the tempu log just in case anyone has any ideas.

5 REPLIES
New Member

Re: Unity Upgrade/Install Failing

Did you ever figure out the answer to your problem? I am having the same error in my install log when trying to install a clean copy of 4.1.

Blue

Re: Unity Upgrade/Install Failing

Nope. Its been two weeks and we haven't been able to figure it out.

New Member

Re: Unity Upgrade/Install Failing

I have the same behaviour right now with Unity 4.2(1). Do you have a solution in the meantime?

Kind regards,

Tim

New Member

Re: Unity Upgrade/Install Failing

Have you verify if you have the SQLSERVERAGENT running? Also verify that you don't have the database set to suspect. Verify that the correct authentication is set on SQL and you have proper permissions.

Re: Unity Upgrade/Install Failing

I had a horrible time with an upgrade of a 4.0(5) to 4.2. It was because Failover did not upgrade at all.. it basically killed my secondary server. I have not rebuilt the secondary yet, but I think I can get away with by doing the following:

Unistall Failover and Start OVer.. By I my secondary server might be completely hosed up and need Unity Uninstalled. Primary upgraded just fine with no problems.

Here is the procedures for uninstalling failover and installing failover:

http://www.cisco.com/univercd/cc/td/doc/product/voice/c_unity/rug/ex/ru_130.htm#wp1230060

http://www.cisco.com/application/pdf/en/us/guest/products/ps4608/c2001/ccmigration_09186a00801b923b.pdf

141
Views
0
Helpful
5
Replies