Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unity Upgrade issue, SQL stored procedure problem

Hello all!

I am attempting to upgrade a 4.21 server to 5.01. Right at the end of the upgrade, i hit an error saying Unity was unable to configure default settings, collect a bunch of logs and call tac. That was a paraphrase. I have seen these error 3 other times and I have been able to get past it each time by either running a workaround that recreates the ReportDb or reinstalling SQL server. I have tried both of these things and neither worked. After some troubleshooting, I had come to discover in the OSQLdumps that the problem is the unity upgrade is not able to find a stored procedure. I found the folder that holds all the default procedures and they are all being created. I re-ran the upgrade and opened enterprise manager to see what store procedures are being created. I noticed that right before it gets to the point of failure, a microsoft script window comes up and what it is doing is creating the stored procedures. Enterprise manager shows about 30 stored procedures being created at this point. The stored procedure that the upgrade is looking for is not one of them. I looked at a working server and it looks like there are about 70+ stored procedures that should be loaded and the one the upgrade is looking for was one of them.

So here is my plan... I found that if you run UnityDbEX.SQL it will create all the stored procedures. I was thinking, maybe I could run that right before the point of failure and see if it will allow the install to continue. I am wondering if the script that should be creating these procedures will erase them after i load them. I am also thinking this idea may be crazy and won't work.

I have a TAC case open on the issue and have already gone through two engineers, one of which was an escalation engineer that was a CCIE. We tried many different things and the escalation engineer suggested I use cobras, so i can just cobras back up, wipe out 4.21 install 5.01 and cobras restore. I rather not go that route.

Could someone please give some guidance???

p.s. sorry for the book

Cisco Employee

Re: Unity Upgrade issue, SQL stored procedure problem


What ES level are you at with 4.2(1)? If 162 was installed, you may have hit the following during your upgrade:



New Member

Re: Unity Upgrade issue, SQL stored procedure problem

Hi Brad,

This Unity server has no ES's installed on it. Also, the error I am getting is not the same. My error is saying could not find stored procedure.

Thanks for the help,