Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Urgent help required - DBWalker error

Has anyone seen the error "Run-time error '3704' Operation is not allowed when the object is closed"

I'm trying to run this prior to an upgrade tonight so am keen for a quick reply.

Many Thanks

Glyn

9 REPLIES
Cisco Employee

Re: Urgent help required - DBWalker error

Make sure you are using the latest version of DBWalker. You can get the latest one by opening Unity to the internet and running the current DBwalker. It should search for a newer version if one exists and prompt you to download and install it.

Tray

New Member

Re: Urgent help required - DBWalker error

I downloaded the latest version from Ciscounitytools.com this evening and get exactly the same error. I'm running this on unity UM 4.0.5 in preparation for an upgrade I'm planning to under take in the next couple of days to 5.0.1.

The above error occurs as soon as I click walk Database. It also launches a DOS window which looks like it is doing a check against Ciscounitytools.com to make sure it is the latest version. DOS window contents are d:\commServer\utilities\dbWalker>versioncheck 4.0.52 http://www.ciscounitytools.com/App_DirectoryWalker4.htm

The window disappears after around 40 - 50 seconds. No errors in the event log

Re: Urgent help required - DBWalker error

Hi Glyn -

Best to call Cisco TAC directly and let them know you are having DBWalker problems and need to run for planned upgrade tonight, escalate if you have too. Check the DBWalker folder on the Unity server to see if you are seeing any errors or log info posted there. Note, before you call TAC, you might just try running Unity DiRT backup to make sure you can get a good backup even if you don't run DBWalker first. If you see any errors there, include those in your TAC call. My last advice, break your RAID-1 mirror set if your Unity server is configured as such before upgrading, even if you do use DiRT backup. It's an added measure of protection.

Edit to my own post - I was searching for this error in www.dogpile.com and found a recommendation to turn off antivirus and make sure Windows firewall is not running (hinting at TCP 1433 port needed for MSDE/SQL access). It's a stretch, but might be something you can check after getting your call into TAC. I'd still do this first, then stop antivirus, CSA, etc. and check for no firewall before rerunning DBWalker.

Best wishes! Ginger

New Member

Re: Urgent help required - DBWalker error

I've now got around this. I managed to get it working by running it from the Unity 5 install disk. I also had to upgrade another Unity server and didn't bother trying to upgrade the DBWalker and just used the one that came with 4.0.5 and this worked also. It seems to me like there may be a problem with the latest version on unitytools.com???

Glyn

New Member

Re: Urgent help required - DBWalker error

I was also trying to upgrade from 4.0.5 to 4.2.1 and ran into the run-time error. I had to get the update done, so I went ahead without using DBWalker. I ended up being able to check the DB later in the process by selecting the option to use the utility from the media (Unity Software CD). That contained an earlier version that still worked. I know this reply probably is too late for you, but hopefully it can help someone else who turns to the forums for this problem.

Cisco Employee

Re: Urgent help required - DBWalker error

Just as a side note, the Unity mainline team knows about this issue and will put out an updated dbWalker version that works with both 5.0 and 4.2(1) (and the upcoming 7.0 product - which is how this check ended up getting broke along the way).

New Member

Re: Urgent help required - DBWalker error

I ran into the same problem after installing the latest version of DBWalker (4.0.52). Rolling back to 4.0.50 resolved the issue.

Jason

Cisco Employee

Re: Urgent help required - DBWalker error

All,

This has become a very well known issue and development is working on a solution. See Lindborg post on this thread.

Tray

Cisco Employee

Re: Urgent help required - DBWalker error

The Unity team popped a new version of dbWalker out on the tools site that fixes this issue - version 4.0.53 should fly right on all versions of 4.x and later now:

http://www.ciscounitytools.com/App_DirectoryWalker4.htm

139
Views
10
Helpful
9
Replies
CreatePlease login to create content