Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Voice Mail on CME not working

Dears,

I have a Cisco 2921 CME configured to support office IP phones.

I configured the VM as shown on the attached file but still VM no working.

Appreciate your support,

Regards,

1 ACCEPTED SOLUTION

Accepted Solutions

Voice Mail on CME not working

Hi,

update the host route to 192.168.130.101, also the dial-peer should use session-target ipv4:192.168.130.101

G.

9 REPLIES

Voice Mail on CME not working

Can you post the CME config as well and explain what doesn't work? fast busy when you hit the messages button, etc...

New Member

Voice Mail on CME not working

Below the CME configuration,

Regarding the VM :- When I call phone if I got no answer should be converted me to VM right?? my CME didn't convert me to VM and disconnected the call.

Show run

!
!
!
ip domain name yourdomain.com
!
multilink bundle-name authenticated
!
!
!
!
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-3776112720
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3776112720
revocation-check none
rsakeypair TP-self-signed-3776112720
!
!
crypto pki certificate chain TP-self-signed-3776112720
certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33373736 31313237 3230301E 170D3132 30363237 31313031
  31355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 37373631
  31323732 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  81009BE3 D1DC6B04 CEE7441F EE9F79A6 F74B47CF 5412F95B B2921616 8779A58B
  A82609AD F8E2433D 6D0A37C0 322ADC8B 4065DDE5 5F47F85A 54057E61 4CF90E99
  67C4C428 A064FBCE 033C9F0F 1299BD16 612899A2 DBFC574A B1265A16 08B2DAEF
  8DBDD938 0D84E11A 1B3C68C9 F905D4DF 6CFF1C1E 926E3A05 94FCC8BA 63DAD67F
  97A90203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 14679E56 F5BEBE49 D92548F7 47B87DD7 DC2B5281 17301D06
  03551D0E 04160414 679E56F5 BEBE49D9 2548F747 B87DD7DC 2B528117 300D0609
  2A864886 F70D0101 05050003 81810007 977FF3AD 0A28B1F5 644A959A D35D6E93
  7CCFC9E7 459B05BB E59F322A C07D4C02 398727CE 9B9F470D 03081AB9 4F9AD975
  272153C3 99F287F9 4977E28C CAEA2873 B24F3B5B 16745BE5 F5201EF3 5EC81328
  BEE5A144 F6A4A353 25B95063 90C34D19 8525F8C6 55519959 E1C101CF 64CAAD6B
  EF36CB75 200A686E 002424F6 628F18
        quit
voice-card 0
!
!
!
voice service voip
no ip address trusted authenticate
no supplementary-service sip handle-replaces
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
!
!
!
!
!
license udi pid CISCO2921/K9 sn FCZ162670HW
hw-module ism 0
!
hw-module pvdm 0/0
!
!
!
username Afnan privilege 15 password 0 afnan
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
!
interface GigabitEthernet0/0
description CME
ip address 31.25.137.107 255.255.255.192
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface ISM0/0
ip address 192.168.130.100 255.255.255.0
service-module ip address 192.168.130.101 255.255.255.0
!Application: CUE Running on ISM
service-module ip default-gateway 192.168.130.100
hold-queue 60 out
!
interface GigabitEthernet0/1
description connected to Branches VPN
ip address 192.168.80.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
description connected to Inside Network
no ip address
duplex auto
speed auto
!
interface ISM0/1
description Internal switch interface connected to Internal Service Module
no ip address
!
interface Vlan1
no ip address
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 192.168.80.1
ip route 192.168.130.100 255.255.255.255 ISM0/0
!
!
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0
connection plar 311
caller-id enable
!
voice-port 0/0/1
!
!
!
mgcp profile default
!
!
dial-peer cor custom
name international
name national
name local
!
!
dial-peer cor list PT-international
member international
!
dial-peer cor list PT-national
member national
!
dial-peer cor list PT-local
member local
!
dial-peer cor list CSS-international
member international
member national
member local
!
dial-peer cor list CSS-national
member national
member local
!
dial-peer cor list CSS-local
member local
!
!
dial-peer voice 111 voip
translation-profile incoming HQ-CME
destination-pattern 3..
session target ipv4:192.168.80.2
dtmf-relay h245-signal h245-alphanumeric
!
dial-peer voice 121 voip
translation-profile outgoing Baghdad_Router
destination-pattern 2..
session target ipv4:192.168.60.2
dtmf-relay h245-signal h245-alphanumeric
codec g729br8
!
dial-peer voice 1 pots
corlist outgoing PT-national
destination-pattern 07[4-9]........
incoming called-number .T
port 0/0/0
forward-digits all
!
dial-peer voice 2 pots
corlist outgoing PT-international
destination-pattern 00T
incoming called-number .T
port 0/0/0
forward-digits all
!
dial-peer voice 25 voip
fax protocol pass-through g711ulaw
!
!
!
!
gatekeeper
shutdown
!
!
telephony-service
sdspfarm transcode sessions 15
max-ephones 90
max-dn 90
ip source-address 192.168.80.2 port 2000
auto assign 1 to 90
service directed-pickup gpickup
system message Almouyasser
voicemail 700
max-conferences 8 gain -6
call-park system redirect
transfer-system full-consult
create cnf-files version-stamp 7960 Aug 21 2013 16:25:47
!
!
ephone-dn  1
number 314
label Supply Chain Manager
name Supply Chain Manager
!
!
ephone-dn  2
number 303
label Erbil Beauty
name Erbil Beauty
!
!
ephone-dn  3  dual-line
number 300
label General Manager
name General Manager
!
!
ephone-dn  4
number 333
label IT Manager
name IT Manager
!
!
ephone-dn  5
number 301
label F&A Manager
name F&A Manager
!
!
ephone-dn  6
number 302
label Erbil Acct
name Erbil Acct
!
!
ephone-dn  7
number 304
label Erbil Food1
name Erbil Food1
corlist incoming CSS-local
corlist outgoing CSS-local
!
!
ephone-dn  8
number 306
label HPC1 BM
name HPC1 BM
!
!
ephone-dn  9
number 305
label Erbil Food2
name Erbil Food2
!
!
ephone-dn  10
number 309
label HR Manager
name HR Manager
!
!
ephone-dn  11
number 311
label Network Administrator
name Network Administrator
corlist incoming CSS-international
corlist outgoing CSS-international
!
!
ephone-dn  12
number 323

HQ-CME#

Hall of Fame Super Gold

Voice Mail on CME not working

For VM ou need to configure call-forward options.

Also in your configureatipon, DNs are single line and other mistakes.

Voice Mail on CME not working

Hi,

as Paolo said, if you want call forwarding on no answer or when busy, adjust your ephone-dn's.

Also, I am kind of missing a dial-peer towards the CUE.

G.

New Member

Voice Mail on CME not working

Dears,

I updated the configuration but still facing the same issue the VM is not working.

Below the configuration of the CME and Engine:-

CME:-

Building configuration...


Current configuration : 15795 bytes
!
! Last configuration change at 09:00:09 GMT Sun Sep 15 2013
! NVRAM config last updated at 14:23:00 GMT Wed Sep 11 2013
! NVRAM config last updated at 14:23:00 GMT Wed Sep 11 2013
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HQ-CME
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
enable secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY
!
no aaa new-model
!
clock timezone GMT 3 0
clock calendar-valid
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
ip domain name yourdomain.com
!
multilink bundle-name authenticated
!
!
!
!
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-3776112720
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3776112720
revocation-check none
rsakeypair TP-self-signed-3776112720
!
!
crypto pki certificate chain TP-self-signed-3776112720
certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33373736 31313237 3230301E 170D3132 30363237 31313031
  31355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 37373631
  31323732 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  81009BE3 D1DC6B04 CEE7441F EE9F79A6 F74B47CF 5412F95B B2921616 8779A58B
  A82609AD F8E2433D 6D0A37C0 322ADC8B 4065DDE5 5F47F85A 54057E61 4CF90E99
  67C4C428 A064FBCE 033C9F0F 1299BD16 612899A2 DBFC574A B1265A16 08B2DAEF
  8DBDD938 0D84E11A 1B3C68C9 F905D4DF 6CFF1C1E 926E3A05 94FCC8BA 63DAD67F
  97A90203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 14679E56 F5BEBE49 D92548F7 47B87DD7 DC2B5281 17301D06
  03551D0E 04160414 679E56F5 BEBE49D9 2548F747 B87DD7DC 2B528117 300D0609
  2A864886 F70D0101 05050003 81810007 977FF3AD 0A28B1F5 644A959A D35D6E93
  7CCFC9E7 459B05BB E59F322A C07D4C02 398727CE 9B9F470D 03081AB9 4F9AD975
  272153C3 99F287F9 4977E28C CAEA2873 B24F3B5B 16745BE5 F5201EF3 5EC81328
  BEE5A144 F6A4A353 25B95063 90C34D19 8525F8C6 55519959 E1C101CF 64CAAD6B
  EF36CB75 200A686E 002424F6 628F18
        quit
voice-card 0
!
!
!
voice service voip
no ip address trusted authenticate
no supplementary-service sip handle-replaces
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
!
!
!
!
!
license udi pid CISCO2921/K9 sn FCZ162670HW
hw-module ism 0
!
hw-module pvdm 0/0
!
!
!
username Afnan privilege 15 password 0 afnan
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
!
interface GigabitEthernet0/0
description CME
ip address 31.25.137.107 255.255.255.192
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface ISM0/0
ip address 192.168.130.100 255.255.255.0
service-module ip address 192.168.130.101 255.255.255.0
!Application: CUE Running on ISM
service-module ip default-gateway 192.168.130.100
hold-queue 60 out
!
interface GigabitEthernet0/1
description connected to Branches VPN
ip address 192.168.80.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
description connected to Inside Network
no ip address
duplex auto
speed auto
!
interface ISM0/1
description Internal switch interface connected to Internal Service Module
no ip address
!
interface Vlan1
no ip address
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 192.168.80.1
ip route 192.168.130.100 255.255.255.255 ISM0/0
!
!
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0
connection plar 311
caller-id enable
!
voice-port 0/0/1
!
!
!
mgcp profile default
!
!
dial-peer cor custom
name international
name national
name local
!
!
dial-peer cor list PT-international
member international
!
dial-peer cor list PT-national
member national
!
dial-peer cor list PT-local
member local
!
dial-peer cor list CSS-international
member international
member national
member local
!
dial-peer cor list CSS-national
member national
member local
!
dial-peer cor list CSS-local
member local
!
!
dial-peer voice 111 voip
translation-profile incoming HQ-CME
destination-pattern 3..
session target ipv4:192.168.80.2
dtmf-relay h245-signal h245-alphanumeric
!
dial-peer voice 121 voip
translation-profile outgoing Baghdad_Router
destination-pattern 2..
session target ipv4:192.168.60.2
dtmf-relay h245-signal h245-alphanumeric
codec g729br8
!
dial-peer voice 1 pots
corlist outgoing PT-national
destination-pattern 07[4-9]........
incoming called-number .T
port 0/0/0
forward-digits all
!
dial-peer voice 2 pots
corlist outgoing PT-international
destination-pattern 00T
incoming called-number .T
port 0/0/0
forward-digits all
!
dial-peer voice 25 voip
fax protocol pass-through g711ulaw
!
dial-peer voice 777 voip
translation-profile incoming HQ-CME
destination-pattern 7..
!
dial-peer voice 431 voip
description Voicemail
destination-pattern 7..
session protocol sipv2
session target dns:192.168.130.100
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
!
!
!
gatekeeper
shutdown
!

telephony-service
sdspfarm transcode sessions 15
max-ephones 90
max-dn 90
ip source-address 192.168.80.2 port 2000
auto assign 1 to 90
service directed-pickup gpickup
system message Almouyasser
voicemail 700
max-conferences 8 gain -6
call-park system redirect
call-forward pattern .T
transfer-system full-consult
create cnf-files version-stamp 7960 Aug 21 2013 16:25:47
!
!
ephone-dn  11  dual-line
number 311
name Network Administrator
call-forward busy 700
call-forward noan 700 timeout 4


ephone-dn  29  dual-line
number 330
label Erbil IT
name Erbil IT
call-forward busy 700
call-forward noan 700 timeout 5

Service Engine:-

se-192-168-130-101# sh running-config
Generating configuration:


clock timezone UTC

hostname se-192-168-130-101

line console

system language preferred "ar_SA"

ntp server 192.168.130.100 prefer

software download server url "ftp://127.0.0.1/ftp" credentials hidden "6u/dKTN/h
sEuSAEfw40XlF2eFHnZfyUTSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfG
WTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmP"

license agent max-sessions 9

privilege ViewPrivateList create
privilege ManagePrompts create
privilege ViewRealTimeReports create
privilege broadcast create
privilege manage-users create
privilege ManagePublicList create
privilege manage-passwords create
privilege local-broadcast create
privilege vm-imap create
privilege ViewHistoricalReports create

groupname Broadcasters create

username NetworkAdmin create
username admin create

privilege ViewPrivateList description "Privilege to view private list"
privilege ManagePrompts description "Privilege to create, modify, or delete syst
em prompts"
privilege ViewRealTimeReports description "Privilege to view realtime reports"
privilege broadcast description "Privilege to send local or remote broadcast mes
sages"
privilege manage-users description "Privilege to create, modify, and delete user
s and groups"
privilege ManagePublicList description "Privilege to manage public lists"
privilege manage-passwords description "Privilege to reset user passwords"
privilege local-broadcast description "Privilege to send local broadcast message
s"
privilege vm-imap description "Privilege to manage personal voicemail via IMAP c
lient"
privilege ViewHistoricalReports description "Privilege to view historical report
s"
privilege ViewPrivateList operation voicemail.lists.private.view
privilege ManagePrompts operation system.debug
privilege ManagePrompts operation prompt.modify
privilege ViewRealTimeReports operation report.realtime
privilege broadcast operation system.debug
privilege broadcast operation broadcast.local
privilege broadcast operation broadcast.remote
privilege manage-users operation user.pin
privilege manage-users operation user.password
privilege manage-users operation user.mailbox
privilege manage-users operation system.debug
privilege manage-users operation user.remote
privilege manage-users operation group.configuration
privilege manage-users operation user.configuration
privilege manage-users operation user.notification
privilege ManagePublicList operation voicemail.lists.public
privilege ManagePublicList operation system.debug
privilege manage-passwords operation user.pin
privilege manage-passwords operation user.password
privilege manage-passwords operation system.debug
privilege local-broadcast operation system.debug
privilege local-broadcast operation broadcast.local
privilege vm-imap operation voicemail.imap.user
privilege ViewHistoricalReports operation report.historical.view

groupname Administrators member admin
groupname Broadcasters privilege broadcast

username NetworkAdmin phonenumber "311"

restriction msg-notification create
restriction msg-notification min-digits 1
restriction msg-notification max-digits 30
restriction msg-notification dial-string preference 1 pattern * allowed

backup server url "ftp://127.0.0.1/ftp" credentials hidden "EWlTygcMhYmjazXhE/VN
XHCkplVV4KjescbDaLa4fl4WLSPFvv1rWUnfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8Z
ZNgd+Y9J3xlk2B35j0nfGWTYHfmP"

calendar biz-schedule systemschedule
open day 1 from 00:00 to 24:00
open day 2 from 00:00 to 24:00
open day 3 from 00:00 to 24:00
open day 4 from 00:00 to 24:00
open day 5 from 00:00 to 24:00
open day 6 from 00:00 to 24:00
open day 7 from 00:00 to 24:00
end schedule

ccn application autoattendant aa
description "Cisco Auto-Attendant"
enabled
maxsessions 2
script "aa.aef"
parameter "dialByExtnAnytime" "false"
parameter "busOpenPrompt" "AABusinessOpen.wav"
parameter "dialByExtnAnytimeInputLength" "4"
parameter "operExtn" "311"
parameter "welcomePrompt" "AAWelcome.wav"
parameter "disconnectAfterMenu" "false"
parameter "dialByFirstName" "false"
parameter "busClosedPrompt" "AABusinessClosed.wav"
parameter "allowExternalTransfers" "false"
parameter "holidayPrompt" "AAHolidayPrompt.wav"
parameter "businessSchedule" "systemschedule"
parameter "MaxRetry" "3"
end application

ccn application ciscomwiapplication aa
description "ciscomwiapplication"
enabled
maxsessions 10
script "setmwi.aef"
parameter "CallControlGroupID" "0"
parameter "strMWI_OFF_DN" "8001"
parameter "strMWI_ON_DN" "8000"
end application

ccn application msgnotification aa
description "msgnotification"
enabled
maxsessions 10
script "msgnotify.aef"
parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
parameter "DelayBeforeSendDTMF" "1"
end application

ccn application promptmgmt aa
description "promptmgmt"
enabled
maxsessions 1
script "promptmgmt.aef"
parameter "appManagementScript" ""
end application

ccn application voicemail aa
description "cisco voicemail"
enabled
maxsessions 2
script "voicebrowser.aef"
parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
end application

ccn engine
end engine

ccn reporting historical
database local
description "se-192-168-130-101"
end reporting

ccn subsystem jtapi
ccm-manager address 0.0.0.0
end subsystem

ccn subsystem sip
gateway address "192.168.130.100"
end subsystem

ccn trigger http urlname msgnotifytrg
application "msgnotification"
enabled
maxsessions 2
end trigger

ccn trigger http urlname mwiapp
application "ciscomwiapplication"
enabled
maxsessions 1
end trigger

ccn trigger sip phonenumber 700
application "voicemail"
application "voicemail"
enabled
maxsessions 2
end trigger

service voiceview
enable
end voiceview

voicemail broadcast recording time 300
voicemail default messagesize 240
voicemail notification restriction msg-notification
voicemail mailbox owner "NetworkAdmin" size 300
expiration time 5
messagesize 120
end mailbox

end

se-192-168-130-101#
se-192-168-130-101#

Voice Mail on CME not working

Hi,

update the host route to 192.168.130.101, also the dial-peer should use session-target ipv4:192.168.130.101

G.

New Member

Voice Mail on CME not working

Thank you so much for your help.

Please can you support me with any documents related to the IVR configuration.

Regards,

Voice Mail on CME not working

Hi,

what do you mean by "IVR" - the autoattendant feature of CUE or the regular IVR (= UCCX)?

G.

New Member

Voice Mail on CME not working

autoattendant feature of CUE

Regards,

475
Views
0
Helpful
9
Replies
CreatePlease to create content