Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

1000v Connectivity

Hi everyone

Im new to the nexus 1000v and i had  a question

Lets say you have 6 nics and 3 different uplink profiles

LAN   - vmnic0 +1

MGT - vmnic 2+3

Vmotion - vmnic 4+5

I understand how to ensure vmotion will use nic 4+5 etc - create vmotion vmkernal and migrate it to that uplink profile

But if the  switch is setup and working for a while and i create a new portgroup for vms in vlan 50 for example.

How can i make sure that that portgroup will use vmnic0 and 1 and not the other nics ???

Its easy for mgt etc as you are migrating a vmkernel but how does it work for the vm portgroups ?

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: 1000v Connectivity

Hi Michael,

system vlans need to be defined on both ethernet & vethernet port-profiles.  A better example would be the management vlan.  If the system vlan is not included on the vethernet port-profile, when the ESX host boots, the vmk interface will be DOWN and therefore not be able to connect to vCenter.

port-profile type vethernet mgmt

vmware port-group

switchport mode access

switchport access vlan 20

no shut

state enable

!

port-profile type ethernet mgmt-uplink  <-----put vmics2+3

vmware port-group

switchport mode trunk

switchport trunk allowed vlan 20

channel-group auto mode on mac-pinning

no shut

state enable

system vlan 20

Matthew

6 REPLIES
Cisco Employee

1000v Connectivity

Hello Michael,

Each uplink port-profile needs to trunk a unique set of vlans.  You should not have the same vlan in multiple port-profiles (the VSM will throw a warning message if this rule is violated).

Here is a stub config.  You'll notice the vlans in the ethernet port-profiles do not overlap. Traffic on vlan 50 will only egress/ingress the VEM through vmnics on VMs-uplink port-profile.  For information on selecting the proper channel-group command, please see my port-channeling best practices document.

port-profile type vethernet vmotion

vmware port-group

switchport mode access

switchport access vlan 10

no shut

state enable

system vlan 10

!

port-profile type ethernet vmotion-uplink  <-----put vmics4+5

vmware port-group

switchport mode trunk

switchport trunk allowed vlan 10

channel-group auto mode on mac-pinning

no shut

state enable

system vlan 10

!

port-profile type vethernet mgmt

vmware port-group

switchport mode access

switchport access vlan 20

no shut

state enable

!

port-profile type ethernet mgmt-uplink  <-----put vmics2+3

vmware port-group

switchport mode trunk

switchport trunk allowed vlan 20

channel-group auto mode on mac-pinning

no shut

state enable

system vlan 20

!

port-profile type vethernet VMS

vmware port-group

switchport mode access

switchport access vlan 50

no shut

state enable

!

port-profile type ethernet VMs-uplink  <-----put vmics4+5

vmware port-group

switchport mode trunk

switchport trunk allowed vlan 50,60,70,80

channel-group auto mode on mac-pinning

no shut

state enable

Matthew

New Member

1000v Connectivity

Matthew

Thanks for the reply.

So is it a very bad configuration so to have just one uplink port profile and all nics assigned to it with the uplinks trunking all vlans ? Would you see packet loss in that situation

WIth regard to your config above , is it a typ that you have vlan 10 as a sytem vlan in port-profile type vethernet vmotion. You dont seem to have a system vlan in the mgt port profile , only the mgt uplink profile

Do you need a system vlan added to the vm's uplink profile ?

I have been testing recently and could still ping my host after shutting down the vsm. I restarted the vem then and lost connectivity - is this normal ? Is it possible to have connectivity for a while after the vsm is down ?

Cisco Employee

Re: 1000v Connectivity

Hello Michael,

System vlans should be used for managment(vmk), storage(nfs/iscsi), vmotion/FT, control, packet, management, and vCenter (if behind VEM).  I did miss the system vlan for the mgmt traffic in the above example.

It is fine to have many NICs in the same port-profile as long as the upstream switchports have corresponding vlans and matching port-channeling is configured..  In this setup all NICs carry all VLANs.  From your description above, it sounded as if you wanted VLANs to be pinned to certain vmnics.  We see this topology frequently where lower speed adapters are used for management type traffic and 10GE adapters used for VM data.

It is normal/expected to be able to ping vmk's, VMs, etc when the VSM is down. Virtural Machine connectivity will remain indefinitely while the VSM is down until the ESX host is rebooted. The VSM need only be powered on to change configuration, vmotion, VM power up to provide basic connectivity. (The VSM must be up for some other functions such as multicast). 

Matthew

New Member

Re: 1000v Connectivity

Matthew

I thought that you only used system vlans for uplink port profiles!

If you didnt add the sytem vlan to this config then what would the outcome be ?

port-profile type vethernet vmotion

vmware port-group

switchport mode access

switchport access vlan 10

no shut

state enable

system vlan 10

Cisco Employee

Re: 1000v Connectivity

Hi Michael,

system vlans need to be defined on both ethernet & vethernet port-profiles.  A better example would be the management vlan.  If the system vlan is not included on the vethernet port-profile, when the ESX host boots, the vmk interface will be DOWN and therefore not be able to connect to vCenter.

port-profile type vethernet mgmt

vmware port-group

switchport mode access

switchport access vlan 20

no shut

state enable

!

port-profile type ethernet mgmt-uplink  <-----put vmics2+3

vmware port-group

switchport mode trunk

switchport trunk allowed vlan 20

channel-group auto mode on mac-pinning

no shut

state enable

system vlan 20

Matthew

New Member

Re: 1000v Connectivity

You must created the new portprofile,vlan and assigned vlan to new portprofile.

Sent from Cisco Technical Support iPhone App

563
Views
0
Helpful
6
Replies
CreatePlease to create content