Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

B200 M3 SAN Boot Windows 2012 Issues

Hi,

 

I am trying to install Windows 2012 on a LUN hanging off an EMC Clariion CX120 to a B200 M3 blade.  The blade has 1 FC HBA zoned to a single target.

What I notice during the Windows install is that once the FCoE Miniport driver is loaded, the initiator is no longer logged into the SAN and the LUN is not seen by Windows Setup.  Up until that point, the initiator is logged in.

I have booted the blade with an ESXi install CD to verify the LUN is seen and can be accessed by the blade.

The blade is running 2.21(c) firmware, I have tried downgrading to 2.1.3a.  I have tried various driver version.  I have gone so far as to create a LUN on our CX-240 and ran into the same results.

Any ideas?  Need more info?  Please let me know.

 

Thanks.

19 REPLIES
Cisco Employee

Hi Cam,Please try the

Hi Cam,

Please try the following to determine if the blade is able to see the correct information of the storage during boot up.

 

1) Reboot your blade

2) Press F2 to make sure it goes into the BIOS screen

3)SSH into your primary fabric interconnect

4) Identify the location of the blade for example x/y where 'x' represents the chassis and 'y' represents the slot location in the chassis

5) run the following comands

connect adapter x/y/1     <---- again 'x' represents the chassis and 'y' represents the slot in the chassis

      F-A# connect adapter 9/1/1

      adapter 9/1/1 # connect

      adapter 9/1/1 (top):1# attach-fls

      adapter 9/1/1 (fls):1# lunlist

 

6) Upload the output of the last command

7) Upload a screenshot of your boot order

8) Upload the a screenshot showing the wwpn of your HBAs (only for the server in question)

what type of adapter do you have installed?

Where did you get the drivers from?

If you are using the bundle with the cisco drivers can you share the path of the location of the drivers that you are selecting during installation?

 

 

VIP Green

This should worksee eg.http:/

This should work

see eg.

http://www.cisco.com/c/en/us/td/docs/unified_computing/ucs/os-install-guides/windows/b_B-Series_Windows_Install/BSERIES-WINDOWS_chapter_011.html#t_sanbootinstallation

and

http://systemcenterclouds.blogspot.ch/2013/12/installing-hyper-v-2012-on-boot-from.html

 

 

VIP Green

Something is weird here

Something is weird here:

Normally, you don't see the lun, before you install the fnic driver ? You claim that in your case it's different.

Is your FI in FC NPV mode ?

what is your SAN fabric

can you please show us the flogi database output of the SAN switch?

the initiator pwwn of your screenshot doesn't agree with your lunlist output

Can you also show us the active zone and zoneset output

New Member

I do not see the LUN in the

I do not see the LUN in the Windows setup at all, even before loading the driver.

What I meant, was that the output of lunlist shows the lun before I load the driver in Windows Setup and then does not after loading the driver.  The HBA ROM sees the LUN (see the attached screenshot)

Yes, the FIs are in NPV mode.

SAN Fabric is 2 Cisco 9124 MDS switches.

Flogi Output:

fc1/14     2     0x6c0904  20:00:00:25:b5:00:00:0a  20:00:00:25:b5:01:00:05
                           [HS120SQL01-HBA0]

 

Active Zoneset Output: 
  zone name HS120SQL01-HBA0__CX120 vsan 2
  * fcid 0x6c0000 [pwwn 50:06:01:60:44:60:06:cf] [CX120-A0]
  * fcid 0x6c0904 [pwwn 20:00:00:25:b5:00:00:0a] [HS120SQL01-HBA0]

Zone Output:

zone name HS120SQL01-HBA0__CX120 vsan 2
  pwwn 50:06:01:60:44:60:06:cf [CX120-A0]
  pwwn 20:00:00:25:b5:00:00:0a [HS120SQL01-HBA0]

 

 

 

 

VIP Green

OK, I see that the zoning is

OK, I see that the zoning is ok, and the host sees the lun.

Did you do a manual install, attaching the W2012 CD, then installing drivers, mapping to the driver iso, and finally mapping back to W2012 CD to continue with the installation ?

During the installation, can you make sure, that you only see one path ? because multipathing is not yet available.

New Member

Yes, manual install.  It is

Yes, manual install.  It is only zoned to 1 SAN target.

VIP Green

Did you try W2012 R2 ?I would

Did you try W2012 R2 ?

I would delete and recreate a new lun ! just in case there is some obsolete information on it.

New Member

i've tried 2008R2, 2012 and

i've tried 2008R2, 2012 and 2012R2.  Same result.

I have created LUNs on 3 different SANs, same result.

VIP Green

Can we see the SP, specially

Can we see the SP, specially the vhba's ? pwwn, nwwn ?

Have you set a adaptor policy, to Windows ?

can you show the software of CIMC, BIOS, Adaptor of this blade ?

New Member

See attached screenshots.Yes,

See attached screenshots.

Yes, I have set the adaptor policy to Windows and default.

VIP Green

Just to clarify:- you

Just to clarify:

- you installed fnic AND enic drivers

- after this installation; you don't see anymore the flogi on the MDS ?, nor the active zone/zoneset, appearing with a * in front of the fcid/pwwn ?

- if this is the case, did you check the log file on the MDS ??

New Member

i did try installing both

i did try installing both fnic and enic drivers.

after driver installation, it is still logged in to the MDS, there is an asterisk before the pwwn.

what i did notice is that on the Clariion, the initiator shows as "logged out".  See screenshot.

Like i have mentioned, only during Windows installs do we encounter this issue.

 

VIP Green

after you install the enic

after you install the enic/fnic drivers, and map the iso back to the windows installer ?

Did you try to do a refresh ?
 

New Member

yes

yes

VIP Green

Maybe you will find a hint in

Maybe you will find a hint in below document; something trivial must be causing this trouble; honestly, I strongly believe that your UCS and MDS setup is correct.

CISCO MICROSOFT PRIVATE CLOUD FAST TRACK 3.0 SOLUTION FOR EMC VSPEX WITH SYSTEM CENTER 2012 SP1 FOR 250 VMS DEPLOYMENT GUIDE

http://www.cisco.com/c/dam/en/us/td/docs/unified_computing/ucs/UCS_CVDs/ucs_mspc_fasttrack30.pdf

 

New Member

adapter 2/5/1 (fls):1#

adapter 2/5/1 (fls):1# lunlist
vnic : 15 lifid: 4
  - FLOGI State : flogi est (fc_id 0x6c0904)
  - PLOGI Sessions
     - WWNN 50:06:01:60:44:60:06:cf WWPN 50:06:01:60:44:60:06:cf fc_id 0x6c0000
       - LUN's configured (SCSI Type, Version, Vendor, Serial No.)
           LUN ID : 0x0000000000000000 (0x0, 0x4, DGC     , APM00092300547)
       - REPORT LUNs Query Response
           LUN ID : 0x0000000000000000
  - Nameserver Query Response
     - WWPN : 50:06:01:60:44:60:06:cf

The output is before loading the driver during windows installation.  After loading the driver, there is no output.

Adapter installed is: Cisco UCS VIC 1240 (UCSB-MLOM-40)

Drivers are from ucs-bxxx-drivers.2.2.1a.iso

Path is: K:\Windows\Storage\Cisco\MLOM\W2K12\x64

 

Thanks for your response, any other info needed, please let me know.

 

 

Cisco Employee

Hi CamFrom the output you

Hi Cam

From the output you provided looks like the storage configuration is correct. Now, it is expected to see no output at the screen after you load the drivers as at that point, the adapter is not anymore in charge of the communication with the storage.  Once you load the drivers, the drivers are the ones in charge with the communication with the storage.

Now, in your boot order did you include the "local CD/DVD" option? if not can you add this too please.  I am not sure if you did since you cropped the screenshot.

 

How are you loading these drivers?

Are you mounting the drivers image to the KVM?

New Member

Yes, CD/DVD boot option is

Yes, CD/DVD boot option is included in the boot order.  I am loading the drivers from the images mount to the KVM.

New Member

Turns out the MDS switches

Turns out the MDS switches were running v3.3(3).  I upgraded them to 5.2.8d, loaded the fnic driver during Windows install and the LUN was immediately seen.

 

Thanks all for the help

954
Views
5
Helpful
19
Replies
CreatePlease to create content