Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

B440 M1 without raid BBU possible?

I work for a major Cisco distributor, and we have a two chassis UCS system setup for demonstration purposes. One of the blades is a B440 M1, and the RAID BBU (battery backup unit) is missing. We don't have another one to replace it with, and since the unit is already EOL we don't want to buy another one if we can avoid it. However without the BBU, we can't use any of the hard disks as the raid controller will not function according to one of the boot messages.

The VMware ESXi installer sees the four disks independently rather than a single raid unit. If we install it to the first bootable disk, the system won't boot to that disk, I'm guessing that this is because it will only boot to the raid array as a whole. I tried setting the device profile to no raid, which didn't work. I also can't see a way to disable the raid configuration in the BIOS, but there are no options for that. I also tried to tell the raid BIOS to treat them as independent disks, but it doesn't seem to offer that option.

So my question is, is there any way to use the B440 without a raid battery backup unit? Going without raid entirely and using just one disk is also acceptable if raid cannot be enabled. I also tried removing all but disk 1 and it doesn't see any drives at all with that configuration.

Everyone's tags (3)
2 REPLIES

B440 M1 without raid BBU possible?

Justin,

As you may see here, the BUU is optional, check Table 3:

http://www.cisco.com/en/US/partner/prod/collateral/ps10265/ps10280/ps10921/data_sheet_c78-591190_ps10280_Products_Data_Sheet.html

Please post the error message you are getting to have a better idea about the problem.

-Kenny

New Member

Re: B440 M1 without raid BBU possible?

Thanks!

I'm actually an intern for the company and I am very new to UCS. That said though, I found a solution earlier, just wanted to report back what I found in case somebody else runs into the same problem, along with an explanation of why things are the way they are.

The drives were configured in a 4 disk raid 0 volume, with the cache in write-back mode (which I wasn't aware of.) I didn't know the purpose of the battery until I read elsewhere that it is meant to hold the write-back cache for up to 72 hours in the event of a power failure, so that no data is lost, and when power is restored, it flushes the cache on to the disks. Given that we had no battery, and the raid volume was configured in write-back mode, the raid BIOS didn't present a raid volume to the operating system, rather it just showed it as four disks. However for some reason that I'm not yet aware, it will not boot from just one of the disks, rather if there is no functioning raid volume it just doesn't boot from any disks at all.

So I fixed the problem by going into the raid web-bios (where it prompts for control-h) and clearing out the existing raid configuration and creating a new one from scratch. This time I built the raid volume with write-through mode with raid 1. Write-through mode yields slower performance in general, however writes are made to the disks immediately so there is very little chance of data corruption in the event of a power failure. The upshot is that you don't need a raid battery backup unit. The lost performance isn't that important for our purposes since it is only for a proof of concept demonstration for a customer.

483
Views
0
Helpful
2
Replies