Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

C240 cant Flogi into Nexus 5548s

Hi All,

 

I have 3 C240 servers connected to a Nexus 5548. I want to configure FCoE across to them and i have configured the exact same configuration on 6 ports:

vlan 10
  fcoe vsan 10

vsan database
  vsan 10
device-alias mode enhanced
device-alias database
  device-alias name XenServer1_fc0 pwwn 20:00:c0:67:af:2d:d0:07
  device-alias name XenServer1_fc1 pwwn 20:00:c0:67:af:2d:d0:08
  device-alias name XenServer2_fc0 pwwn 20:00:b0:fa:eb:36:11:6f
  device-alias name XenServer2_fc1 pwwn 20:00:b0:fa:eb:36:11:70
  device-alias name XenServer3_fc0 pwwn 20:00:b0:fa:eb:36:11:1b
  device-alias name XenServer3_fc1 pwwn 20:00:b0:fa:eb:36:11:1c

interface vfc1
  bind interface Ethernet1/1
  switchport trunk allowed vsan 10
  no shutdown

interface vfc2
  bind interface Ethernet1/2
  switchport trunk allowed vsan 10
  no shutdown

interface vfc3
  bind interface Ethernet1/3
  switchport trunk allowed vsan 10
  no shutdown

interface vfc4
  bind interface Ethernet1/4
  switchport trunk allowed vsan 10
  no shutdown

interface vfc5
  bind interface Ethernet1/5
  switchport trunk allowed vsan 10
  no shutdown

interface vfc6
  bind interface Ethernet1/6
  switchport trunk allowed vsan 10
  no shutdown
vsan database
  vsan 10 interface vfc1
  vsan 10 interface vfc2
  vsan 10 interface vfc3
  vsan 10 interface vfc4
  vsan 10 interface vfc5
  vsan 10 interface vfc6

interface Ethernet1/1
  description ***Link To XenServer1 FCx***
  switchport mode trunk
  switchport trunk allowed vlan 1,10
  spanning-tree port type edge trunk

interface Ethernet1/2
  description ***Link To XenServer1 FCx***
  switchport mode trunk
  switchport trunk allowed vlan 1,10
  spanning-tree port type edge trunk

interface Ethernet1/3
  description ***Link To XenServer2 FCx***
  switchport mode trunk
  switchport trunk allowed vlan 1,10
  spanning-tree port type edge trunk

interface Ethernet1/4
  description ***Link To XenServer2 FCx***
  switchport mode trunk
  switchport trunk allowed vlan 1,10
  spanning-tree port type edge trunk

interface Ethernet1/5
  description ***Link To XenServer3 FCx***
  switchport mode trunk
  switchport trunk allowed vlan 1,10
  spanning-tree port type edge trunk

interface Ethernet1/6
  description ***Link To XenServer3 FCx***
  switchport mode trunk
  switchport trunk allowed vlan 1,10
  spanning-tree port type edge trunk

 

However Only 1 of the C240s can Flogi into the Nexus switch:

N5K01# show flogi database
--------------------------------------------------------------------------------
INTERFACE        VSAN    FCID           PORT NAME               NODE NAME
--------------------------------------------------------------------------------
vfc5             10    0x150000  20:00:c0:67:af:2d:d0:07 10:00:c0:67:af:2d:d0:07
                           [XenServer1_fc0]
vfc6             10    0x150040  20:00:c0:67:af:2d:d0:08 10:00:c0:67:af:2d:d0:08
                           [XenServer1_fc1]

Total number of flogi = 2.

 

The other C240s are not logging in and are stuck in initiazing state.

 

N5K01# show interface vfc1
vfc1 is trunking
    Bound interface is Ethernet1/1
    Hardware is Ethernet
    Port WWN is 20:00:54:7f:ee:3c:b4:ff
    Admin port mode is F, trunk mode is on
    snmp link state traps are enabled
    Port mode is TF
    Port vsan is 10
    Trunk vsans (admin allowed and active) (10)
    Trunk vsans (up)                       ()
    Trunk vsans (isolated)                 ()
    Trunk vsans (initializing)             (10)
    1 minute input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
    1 minute output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
      19 frames input, 1788 bytes
        0 discards, 0 errors
      20 frames output, 2568 bytes
        0 discards, 0 errors
    last clearing of "show interface" counters Thu Aug 14 12:40:43 2014

    Interface last changed at Fri Aug 15 08:15:53 2014

 

What could be the possible issue??

 

 

 

 

1 REPLY
New Member

Its ok guys, found the issue.

Its ok guys, found the issue.

 

On the C240s, under the 'inventory' then 'properties' than 'Cisco VIC adaptors' than 'vHBAs' you have to have boot enabled for it to flogi into the Nexus.

40
Views
5
Helpful
1
Replies
CreatePlease login to create content