Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Cannot install the Windows 2012 R2 on UCS C220 M3 servers

Cannot install the Windows 2012 R2 on local disks on a UCS C220 M3 server. Megaraid embedded Raid controller. C-Series managed by UCSM (2.1.3a)

Windows sees the disk, but raises error message: cannot install on this partition.

Don't suggest the usual advices; this has all been done, without success.

Something odd must be wrong here; TAC escalation was involved, no resolution up to now.

Anybody seen this as well ?

see SR 628120971

Cisco Employee

Cannot install the Windows 2012 R2 on UCS C220 M3 servers


Issue is resolved as per case notes by following standard procedure.

Use megaSR driver during windows installation,create local disk configuration policy as " Any RAID " with proper boot order.

Let us know if you still have issues with it.


Re: Cannot install the Windows 2012 R2 on UCS C220 M3 servers

Hi Padma

No, unfortunaltely not; I let Robert Nilsson add the details; he was with several different Tac engineers and TAC escalation folks working for hours on this case.

It's also very strange, eg. doesn't mention W2012 R2 support for C220-M3 SFF


Maybe I'm dreaming, I cannot find anything about W2012 R2 mentioned in

Has this W2012 R2 entry been removed recently; at least I've seen it for B200-M3......

Thanks and Kind Regards


Community Member

Cannot install the Windows 2012 R2 on UCS C220 M3 servers

Hi Padma,

The issue is not resolved.

Last thing is that I was working with TAC on the 3. C220 M3 SFF with Software RAID and 8 Disks (1 TB SATA), RAID1

constallation and we couldn't get this to work.

We have even gone back to installing Windows 2012 Standard ISO image which has been supported sonce quite some time. This was done Friday but no change to the issue.

We have seen the same issue on 3 different server constallations.

1. C220 M3 SFF with Software RAID and 2 Disks (1 TB SATA), RAID1

2. C220 M3 SFF with Hardware RAID Controller, 2 Disks (600GB SAS), RAID1

3. C220 M3 SFF with Software RAID and 8 Disks (1 TB SATA), RAID1

We need a proper clarification what is going on since this is environement will be handed over to the client on Wednesday and all need to be operational.

We have 48 x C220 M3 SFF

Thanks for your help,


Community Member

Thanks for documenting this.

Thanks for documenting this. I had a similar issue on B200 M3. It was formerly booting iSCSI. Added internal drives but was having trouble installing Windows 2012 R2. This helped solved my problem.

Cisco Employee

Re: Cannot install the Windows 2012 R2 on UCS C220 M3 servers

Hi Robert,

The message the Windows generates, "cannot install on this partition ensure that the disk's controller is enabled in the computer's BIOS menu" can be caused If boot order is setup incorrectly or you might not using the right drivers for the embeded controller.

1. What is the boot order?

If you are installing the OS on an internal drive, define the following Boot Order:


2. Local Disk

If you still get an error that states “Windows cannot be installed on this disk. Re-attatch Windows Server install ISO and click “Rescan”

2. For C-Series servers managed by UCSM, the supported firmware and drivers will be in the 1.5(2) C-Series Compatibility guide.

What is the CIMC version running on your C220?

3. In case of the embeded raid controrller, Windows or Linux require to download additional drivers for these OS with the embeded raid controller.

Please check:  RAID Controller Considerations ->

Installing LSI MegaSR Drivers For Windows and Linux

As you said several steps have been performed before. However, I am not really sure if you have tried this step already.

Re: Cannot install the Windows 2012 R2 on UCS C220 M3 servers

This case is slowly becoming chaotic: some people (TAC !) claim

1)     Boot order should be CD/DVD-Local Disk, others Local-Disk/CD/DVD

2)     some claim that W2012 R2 is not supported on C220-M3 (managed by UCSM)

3)     some claim you need CIMC V 1.5.3d, which would require to take all servers standalone and upgrade CIMC.

Why can we not upgrade CIMC of C220-M3 with UCSM to 1.5.3d ? We use UCSM 2.1.3a, which creates a 1.5.3 CIMC !!

Cannot install the Windows 2012 R2 on UCS C220 M3 servers

No answer ! we seem to need CIMC V1.5.3d, to successfully install W2012 on a C220-M3 managed by UCSM !!

The procedure is: take C220 off FEX to standalone, use HUU to do the CIMC.... upgrade to 1.3.5d, then connect again to FEX and UCSM.

Where is the benefit of UCSM, allowing firmware manangement of Rack Mount servers ?

Can someone give me a 1.5.3d CIMC version, that I can use from UCSM (today we use 2.1.3a, which only has 1.5.3 !!)


Cannot install the Windows 2012 R2 on UCS C220 M3 servers


The aswer is that C-Series servers managed under UCSM 2.1(3a) are not supported with Windows 2K12 R2 ( This support was added for stand-alone for 1.5(3d).  That version of C-Series FW/BIOS was not part of the 2.1(3a) firmware bundle for UCSM managed C-Series servers due to timing of releases.  We will commonly release stand-alone FW in more rapid succession than we will integrated FW.  The next version of UCSM managed C-Series that will support Win2K12 R2 will likely be UCSM 2.2 which will include a C-Series bundle that includes a 1.5(4) CIMC/BIOS image.

As for taking the C220 out of UCSM managed mode to update the Firmware  & BIOS, updating the FW and BIOS to something other than what is in UCSM packaged bundle, this is officially NOT SUPPORTED by Cisco when managed by UCSM.  The bundles included in UCSM were tested and qualified for the specific UCSM infrastructure FW versions that are included with the build.  You can also use server BIOS/FW that is supported by the N-1 firmware support policy (, however using integrated servers with FW not listed in this matrix is NOT supported.  The benefit to UCSM is that you should always stay within the tested/certified Firmware bundles that are included in the UCSM packages.  Deviating from this violates supportability of that server within the infrastructure and TAC and the BU may not be able to help you with any problems that may arise as a result of running outside of the supportability matrix.

In this case you are trying to install an OS version that is not yet supported for your particular server in UCSM management and are having to go through an unnatural process to upgrade the CIMC/BIOS.

Note it is POSSIBLE (NOT SUPPORTED) to upgrade a C-Series with the HUU while in UCSM mode without reverting it to stand-alone mode.  This is accomplished by attaching the HUU ISO through virtual media and running through the update. Again I must stress this is NOT SUPPORTED or RECOMMENDED, however it is technically possible and makes the task you were trying to accomplish much more manageable. 

Hope this clears up any confusion,

Steve McQuerry

UCS - Technical Marketing

Cannot install the Windows 2012 R2 on UCS C220 M3 servers

Thanks Steve ! understood ! However, we tried to install W2012 (not W2012 R2), which is supported; and was not working with 1.3.5 but with 1.3.5.d.

We got the famous error message: windows cannot be installed on this partition.

Btw. it was a TAC advice to move CIMC to 1.3.5d; seems to be an issue with the embedded Raid controller.



Cannot install the Windows 2012 R2 on UCS C220 M3 servers


Thanks.  I didn't realize you were attempting to install Windows 2k12 server the title was 2k12 R2 and I didn't read through your third post completely.  I now see you were having this problem with 2k12 standard and 2.1(3) which should have worked with the 1.5(3) image.  Can you tell me what other cards if any you have in the system?  I also understand that it was TACs advice to move to the 1.5(3d) image, but as mentioned previously the advantage of UCSM firmware management requires staying within the boundaries of the supported image(s). 

In response to your question on November 25th regarding an image that works, the next release of UCSM will inclue a 1.5(4) image which will include any fixes that were added to 1.5(3d) that corrected your problem.  I will also attempt to reproduce your issue in my setup to see if we can understand the specific problem and look to modify the supportibility matrix if required.

Steve McQuerry

UCS - Technical Marketing

Community Member

Cannot install the Windows 2012 R2 on UCS C220 M3 servers

Hi Steve,

my name is Peter ( and I was working with the partner on this case, together with Walter.

We got stuck with those C220s that have a LSI-9266i phys. Raid controller. After taking the C220 away from UCSM (decommission) and doing a SA-upgrade with HUU to 1.5.3d, we do see LSI-controller in CIMC unter PCIe cards, but when rebooting and trying to configure the Raid-config, we do not see the Controller in the console where we could enter "CTRL-M" to configure the Raid-Controller. With those servers using the embedded Raid-Controller, we did not have this problem.

For the physical Raid-Controllers we disabled the embedded Raid-Ctrl in the BIOS.

When we take a Server upgraded to 1.5.3d back to UCSM control, we can see the Raid-Controller and configure it,

but when installing Win2012Standard on this UCS-managed C220, we do not even find a driver for Win2012 (not R2!!!!) in the latest ISO-file for UCS-managed Servers. According to the support-mtx we support Win2012Std on UCSM-managed C-Series, but then I would also expect to find a driver. So we tested other drivers that we found in our ISO-files, but none of them worked and allowed us to install the Win20012 image to the local virtual boot-lun.

We are totally stuck  with 48 C-Series that should be ready by the end of this week. Can you give us a hint or test this on your side? We also have a case open, but that did not help us so far  (SR 628120971).

thx for your help!!


Cannot install the Windows 2012 R2 on UCS C220 M3 servers


OK.  Let's forget the embedded RAID for a moment and deal only with the 9266-8i controller.  What I think I hear you say is that the OS will not let you install on that RAID device.  Two things to check.  First make sure that the RAID controller option ROM is enabled for the card.  In integrated mode enter the BIOS through F2 and locate the card in inventory and then check to make sure that you see the card in the PCIe inventory in a slot and that the optionROM is enabled.

As yours is a 9266-8i it will show a slot.  If the option ROM is not enabled verify that your Service profile has the "any disk" configuration policy and that the HDD is in the boot order.  If this is the case UCSM should have this enabled.  If it is not enabled then something happened during the upgrade out of UCSM managed mode and conversion back to UCSM managed mode.  If it is disabled press F9 here to reset the BIOS defaults and then save and exit.  If it is enabled move on.

By the way if this is not enable then you will never be presented with the CTRL-Y option during boot to configure the RAID as presented below.  Wen you veify that the option ROM is there also make sure Next you need to see that the Virtual Drive is found (this means you created one on the controller) and that it is being "handled by the BIOS".  These numbers should be NON Zero (unlike this example).

If you see a virtual drive but 0 virtual drives are being handled by the BIOS then you need to issue a Ctrl-Y to enter WebBIOS, select the controller properties and click the next button until you get to the 4th page.  Here enable the controller BIOS as shown and submit.  Next reboot the server and verify that the virtual drive is "handled by BIOS"

I have seen this happen a few times but have yet to root cause the issue as I can not make it happen consistently.  I would make a small wager that these steps would clear up the issue, but if not.  Contact me directly via e-mail and we can get this working.

Also I tested the embedded RAID with Windows 2K12 Standard, the 2.1(3) UCSM firmware/bios, and the C-Series 1.5(3a) drivers ISO and had no issues installing the OS.  I would be interested in speaking to you and Walter offline sometime to try and understand these issues in more detail.

Let me know if this works,

Steve McQuerry

UCS - Technical Marketing

Community Member

Cannot install the Windows 2012 R2 on UCS C220 M3 servers

After you loaded the device driver from the driver cd, did you go back to the windows dvd as mapped dvd? I have seen this error before, the moment you load the driver you get back to the main screen, but you get the error it cannot install. If you then unload the driver dvd and load the windows dvd and do a refresh, all is resolved.

Community Member

I had this issue due to the

I had this issue due to the fact that CIMC and virtual media can only have 1 virtual DVD mounted. When I dismount the 2012 media and mount the drivers ISO to add the LSI driver, the install window gives an error until you re-mount the 2012 media and then hit refresh.


I'm setting up 5 servers and 1 server is still having a similar problem with the LSI drivers. I mount the ISO for drivers, browse to the LSI driver which I've done on 4 other servers but this one server gives an error, "no new devices were found. make sure the installation media contains the correct drivers, and then click OK.".


I'm using the same ISO file, using the same LSI C600 driver but this one C220 M3 box just won't accept it. I have the same RAID settings on this server as I do on the other 4 but 2012 won't see it.


All servers are running the same firmware version, 2.0.3d.


If I have to call TAC, I'll be less than impressed. :)


EDIT: Found the problem. The ISO was bad so I re-downloaded it and it worked just fine.

CreatePlease to create content