Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco B200 M3 : Discovery State = Invalid Adaptor Iocard

Recently purchased 8x B200 M3's. We currently run 6120XP, 2x 5108's with 2104XP. We have 12x B230 M2's working just fine on 2.0(3a). When we installed 1x B200 M3 into slot 8x it will not discover all the way and fails/hangs with error "invalid adaptor iocard". B200 M3 has 1240 without mezz card. Assuming it was a fluke, we installed a 2nd B200 M3 in 2nd chassis in slot 8, same problem. Naturally, searched google and Cisco support for error message and can't find a thing. Any ideas?

Everyone's tags (1)
12 REPLIES
Silver

Cisco B200 M3 : Discovery State = Invalid Adaptor Iocard

Hi Andrew,

On the mezz card, did you physically open the blade and verify there is no adapter  in the mezz card slot?

./Abhinav

Cisco Employee

Cisco B200 M3 : Discovery State = Invalid Adaptor Iocard

Hi Andrew ,

If you made sure that the card is installed on the server, take into consideration this information:

B200 M3 blades are only supported in firmware versions
above 2.0(2m), and will fail to discover in older versions of firmware. In
order to use the new blades the firmware will need to be upgraded.

Additionally, there are some restrictions to be aware of if you are running
2104XP fabric extenders. The 2104XP fabric extender is not compatible with
any I/O card installed in the mezzanine connector. This will also cause the
discovery to fail, even in a system running firmware 2.0(2m) and later.

Please check on the following documentation for a further explanation of the
blade:

http://www.cisco.com/en/US/prod/collateral/ps10265/ps10280/B200M3_SpecSheet.
pdf

Please check on that

David
Cisco Employee

Cisco B200 M3 : Discovery State = Invalid Adaptor Iocard

Since you're running 2.0(3a), i'm placing my bets with Abi - you likely have an adaptor populated in the Mezz slot (not mLOM).

I'll venture my guess further and guess its an 1240 Port Expander. 

Your only option is to use an mLOM (1240) by itself.  If you didn't order an mLOM you will have no connectivity with your 2104.

Robert

New Member

Cisco B200 M3 : Discovery State = Invalid Adaptor Iocard

I did some checking. Even though I thought we didn't have the expander we do. We're removing them now and reseating to see if that fixes the problem. Should know in about an hour. Thanks!

Cisco Employee

Cisco B200 M3 : Discovery State = Invalid Adaptor Iocard

Point set match.

New Member

Cisco B200 M3 : Discovery State = Invalid Adaptor Iocard

Guys.. that was it.. we removed the expander and everything is great now !!!

New Member

Cisco B200 M3 : Discovery State = Invalid Adaptor Iocard

Can I get some clarification on the resolution to this? The link provided above by David no longer works. I'm having the exact same issue and was curious if someone could expand on exactly what needs removed for this to work.

Thanks!

Cisco Employee

Re: Cisco B200 M3 : Discovery State = Invalid Adaptor Iocard

Can you double check (visually) which adaptors you have in your blade and in which slots.  Normally this has to do with a 1240 Port expander in the Mezz slot with an incompatible IOM (2100 series).  Port expanders are only compatible with 2200 series IOMs..

http://www.cisco.com/en/US/prod/collateral/ps10265/ps10280/B200M3_SpecSheet.pdf

Robert

New Member

Cisco B200 M3 : Discovery State = Invalid Adaptor Iocard

We are using 2104XP fabric extenders.

I looked inside the blade and it appears there is an "MLOM" (UCSB-MLOM-PT-01) installed in the mezz port. I removed it to re-seat it, but am not clear if this *should* be in the blade or not. The PDF on page 18 indicates that the 2104XP is not compatible with any card installed in the mezz slot - does this mean the slot should be empty? What do I do with this mLOM card?

New Member

Cisco B200 M3 : Discovery State = Invalid Adaptor Iocard

Aha - I think I get it. The card installed in the mezz slot is the 1240 expander as mentioned above. I *do* have a UCSB-MLOM-40G-01 installed in the dedicated MLOM slot, which I presume is the actual VIC 1240 itself. Long story short, I have to remove the 1240 expander from the mezz slot because it is not compatible with the 2104XP. However, means I don't get the additional 4 10GE ports on the blade.

Anything erroneous with what I just said?

Cisco Employee

Re: Cisco B200 M3 : Discovery State = Invalid Adaptor Iocard

Correct, since the 2104 can't support the additional backplane lanes, the 1240 expander will raise this fault.  The 2104 only support 2 x 10G lanes total.  If you want to utilize more than this you'll need a 2204 or 2208.

Robert

Silver

Cisco B200 M3 : Discovery State = Invalid Adaptor Iocard

Matt,

The link:

http://www.cisco.com/en/US/prod/collateral/ps10265/ps10280/B200M3_SpecSheet.
pdf

Check page 18 of the pdf and table 8 for the supported adapter combination on the blade, dependent on the IOM you are using.

./Abhinav

4008
Views
0
Helpful
12
Replies