Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco UCS C240 M3 issues

Hi

I'm trying to install VMWare ESXi on a Cisco UCS C240 M3 and having some issues.

I've configured other servers before, but never a Cisco UCS.

Firmware Versions

v1.5(7c) I couldn't load the KVM as I get a Java issue. I'm running Java v1.6.0_27 on my client.

v2.0 (1b) The server kept on booting to BIOS and seemed to ignore any other boot options

v2.0 (3d) The keyboard no longer works in KVM.

Boot Options

There are a lot of boot options, and they seem to be configurable in lots of different places.

I'm not sure where to start or what the best practices would be?

Nothing appears to work as I expect, and I've done a lot of reading through documents, help, online etc.

My local Cisco support person in on annual leave so I hope someone can help me out or guide me in the right direction.

Thanks & Regards

Steve

1 ACCEPTED SOLUTION

Accepted Solutions

Glad you found the way to fix

Glad you found the way to fix it, don't forget to mark the question as answered for future users facing the same situation.

-Kenny

5 REPLIES

-What is the present CIMC

-What is the present CIMC version running on the server?

-What is the ESXi version you are trying to install?

-What is the RAID controller model in the server?

-Do you have the RAID controller as the first option to boot up?

 

-Kenny

New Member

v2.0 (3d)5.5 update2LSI 9271

  • v2.0 (3d)
  • 5.5 update2
  • LSI 9271-8i MegaRAID SAS HBA
  • I can't identify which boot option is the RAID controller, and where I should enable it;
    • In the IMC
    • In the WebBIOS
    • In the BIOS/Setup on bootup
    • In the KVM?

Maybe one setting overrides another one?

Here are the boot options in the IMC;

  • Local HDD
  • PXE boot
  • SAN boot
  • iSCSI boot
  • SD card
  • USB
  • Virtual Media
  • PCHStorage
  • UEFISHELL

I tried the obvious ones (to me anyway)

Local HDD, Virtual Media and PCHStorage but none worked.

Thanks for your response.

No matter where you enable

No matter where you enable the RAID controller as a boot option, the other options where you can also configured will synch up.  Now, you cannot configure the RAID controller as the boot option from WebBIOS, from WebBIOS you can select the virtual drive as boot drive (in case you have multiple virtual drives).

KVM is just a way to remotely see what the server console displays locally, and the only time when you boot up from "KVM" is when you are installing the OS and you have an .iso image mapped there.

Whit the above being said, you can configure the boot options from BIOS (by pressing F2 during bootup) or from BIOS (in the CIMC GUI).

To be sure your RAID controller can be seen when trying to boot up, go to:

Server tab> BIOS > Configure BIOS > "Advanced" tab > scroll down to the bottom and be sure that ONLY the RAID controller has the "Option ROM" enabled and that all other cards have it disabled.  (Note:  Also leave the option "ALL PCIe Slots Option ROM" enabled)

Now, when the server boots up, press F6 when you see the Cisco logo and select the option that says something similar to "PCI RAID ..."  if you dont see anything like that, paste the screenshot in this post and I will tell you what to select.

 

-Kenny

 

New Member

Hey KennyIt's interesting

Hey Kenny

It's interesting reading your post, as I have just managed to get it booting OK, and it survives a power reset as well; The PCI RAID Adapter was not showing as a boot device until now.

I tried to configure the RAID controller from CIMC first, that's where all my problems started I suppose. I'm trying to configure 16x drives in RAID 10.

To fix it I did this;

  1. Upgraded FIRMWARE/BIOS/CIMC to v2.0 (3d)
  2. Rebooted the KVM to get the keyboard going
  3. Configured the RAID controller from the WebBIOS (not CIMC)
  4. Removed ALL boot options from CIMC BIOS boot order

Thanks for your help

 

Glad you found the way to fix

Glad you found the way to fix it, don't forget to mark the question as answered for future users facing the same situation.

-Kenny

389
Views
0
Helpful
5
Replies