Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

FC Port-Channel not working

Hi,

I need help, i am configuring FC port-channel between MDS 9148 and Cisco Fabric Interconnect 6248 and the port-channel isn't working. It says no operational members.

See the config below for the MDS:

sw(config)#feature npiv

sw(config)#feature fport-channel-trunk

sw(config)#interface fc1/17-18

sw(config-f)#channel-group 63 mode force

sw(config-if)#switchport mode F

sw(config-if)#switchport trunk allowed vsan 1-2 (i have only vsan 1 and 2)

sw(config)#no shut

sw(config)#interface port channel 63

sw(config-if)#switchport mode F

sw(config-f)#switchport trunk allowed vsan 1-2

sw(config-)#no shut

Note: the ports are assigned to vsan 2

See the attached screenshots for Fabric Interconnect config

The switchport mode on the Fabric Interconnects are set E. Do i have to change it to F. If yes where do i change it since the option is not there on the UCS manager?

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: FC Port-Channel not working

did you add the Vsans on the UCSM as well?

what Code are you runnig on the Norhbound San Switch?

You may be hitting

https://tools.cisco.com/bugsearch/bug/CSCty04686

12 REPLIES
VIP Green

Re: FC Port-Channel not working

UCS FI has to be in FC End Host mode (=npv); E port implies that UCS is in FC switching mode, which is wrong !

xxx.png

New Member

Re: FC Port-Channel not working

Hi Wdey,

I turned FC End Host mode after i saw your response but i the but channel is still down with no operational members

VIP Green

Re: FC Port-Channel not working

Did you enable fc uplink trunking on UCS ?

Is channel mode active ?

see http://www.virtualdatacenter.me/2012/06/fibre-channel-trunking-and-port.html

Sometimes you also have to shut / no shut the pc, as well as the individual links

New Member

Re: FC Port-Channel not working

Yes i did, i'll try to shut / not shut the pc. currently out of office. i'll let you know!

Thanks

New Member

Re: FC Port-Channel not working

Hi Wdey

i have / no shut the port-channel and the interfaces as well but there are still no operational members. The port-channel is still down. please see the screenshots of my configurations on both the FI and the MDS below:

What could be the problem?

Capture.PNG

Capture2.PNG

Capture3.PNG

Capture4.PNGCapture5.PNGCapture8.PNG

Capture6.PNGCapture9.PNG

Capture7.PNG

New Member

Re: FC Port-Channel not working

Capture10.PNG

I am configuring the FC uplinks between the FI's and MDS 9148

New Member

Re: FC Port-Channel not working

did you add the Vsans on the UCSM as well?

what Code are you runnig on the Norhbound San Switch?

You may be hitting

https://tools.cisco.com/bugsearch/bug/CSCty04686

New Member

Re: FC Port-Channel not working

Thank you for your response,

It looks like it, i am using code 5.0 (1a)

New Member

You were right, it was a bug.

You were right, it was a bug. The issue was resolved after upgrading from 5.0 (1a) to 6.2.5.

 

Thanks again

Cisco Employee

Re: FC Port-Channel not working

The native VSAN set on the UCS FI ports is VSAN 2 (this is what you select from the drop down box). The native VSAN on the MDS is VSAN 1. Can you make this the same and check?

Thanks,

Shankar

VIP Green

Re: FC Port-Channel not working

Native ?? VSAN ?

It seams to me, that at least on the MDS, pc and fc 1/17 and 18 are in port VSAN 2, which is ok; the pc on the UCS is in port VSAN 2 as well.

On the MDS, you see that both FC ports are error disabled; something is wrong there ?

http://www.cisco.com/en/US/products/ps5989/prod_troubleshooting_guide_chapter09186a008067a2bb.html#wp38672

Could you please give us the show interface fc 1/17 and 18, and the pc, for UCS and MDS ?

New Member

Hi,Thanks for your help, the

Hi,

Thanks for your help, the issue has been resolved. I logged a TAC and found out that i was hitting a bug. I upgrade MDS switches from 5.0 (1a) to 6.2.5 and all the ports went up on both MDS and Fabric interconnect switches

 

Thank you guys, much appreciated!

1870
Views
0
Helpful
12
Replies
CreatePlease login to create content