Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

FCoE mysterious multiport target hang

Hi All

I'm debugging a very strange hang/disconnect with our FCoE initiator software for Mac OS X. 

Here's the situation:  We have a Nexus 5010 and our customer has a 5548UP. We are both running version 5.2(1)N1(5)

He connects a promise RAID to his switch and can talk to it with both FC and our FCoE initiator. Everything is happy and stable.

When he connects *more than one port* on the RAID to the switch, the FCoE initiator gets told to logout (the RAID has no record of doing this) and thr FC initiators hang. When the FCoE initiators are taken off the network, the FC initiators wake up.

The RAID has no errors other than noting the FCoE initiator logged off.

The initiator just sees IO timeouts.

The switch logs that it's not seeing FIP keepalives from us (we've disabled the fip keepalive termination with fpk-disable).

In our shop, we can connect a multiport linux target and we have no trouble at all. We never see fip keepalive timeouts.

We have a strong suspicion that some minor setting in the 5548UP switch is wrong and causing us to get blocked, but we see no vsan errors. we're also unsure why our getting kicked off would cause the FC initiators to hang.  Does anyone have any trouble shooting ideas?

Steve

Everyone's tags (6)
194
Views
0
Helpful
0
Replies
CreatePlease login to create content