Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Flexflash card and UCS C firmware upgrade

Hi All,

I'm facing a problem with UCS C firmware upgrade and flexflash card.


We have some UCS C220 M3 installed with esxi 5.0u2 on flexflash card and we want to upgrade UCS firmware from 1.4.7b to 2.0.1b using the host upgrade utility.

The upgrade was done fine, but when server reboot was unable to load operating system. If I check from CIMC GUI I saw that flexflash card was in error (Invalid RAID) and no virtual drives were detected. I tried to do some check and I also reset the controller but nothing change.

So I tried to downgrade to 1.5.7a2 but problem was the same.


After checked a lot of release notes I notice this about flexflash card:

firmware version 1.5.3 or lower:
Overview of the Pre-Installed Cisco Flexible Flash Card
The Cisco Flexible Flash card is pre-installed with three software bundles, each on one of four preconfigured virtual drives (VDs). The fourth VD allows you to install an OS or an embedded hypervisor.
The VDs are configured with the following content:
•Cisco UCS Server Configuration Utility (SCU).
•Hypervisor (HV). This is a VD that you can use for your own purposes.
•Cisco Drivers (Drivers).
•Cisco Host Upgrade Utility (HUU).

firmware version 1.5.4 or higher:
Overview of the Pre-Installed Cisco Flexible Flash Card
Starting with this version, the SD storage device is available to CIMC as a single hypervisor (HV) partition configuration. Prior versions had four virtual USB drives.

Seems to be that after 1.5.4 there is a different partition schema...

So after this check, I tried to install firmware 1.5.3d (with old partition schema) and flexflash card was seen correctly from UCS and I was able to boot the operating system.

Now my question is: there is a particular procedure to upgrade from release prior 1.5.3 to release 1.5.4 or higher if I have OS installed on flexflash? Is possible to convert 4 partition schema in the new single partition schema used starting from release 1.5.4 without losing data? Or I need to reset the partition schema and install the OS from scratch?

I don't find anything about this on cisco web site and supportforums...

Regards

Danilo

  • Unified Computing
Everyone's tags (1)
2 REPLIES
New Member

Hi Danilo,Hope below link

Hi Danilo,

Hope below link will be helpful:-

http://www.cisco.com/c/dam/en/us/solutions/collateral/data-center-virtualization/unified-computing/whitepaper_C11-718938.pdf

Regards,

Gaurav

New Member

Hi Gaurav,thanks for your

Hi Gaurav,

thanks for your reply. I already read the whitepaper but it refers to SD cards with 4 partition.

Starting from firmware 1.5.4 SD cards has only one single HV Partition, so the white paper seems not apply to the new version of firmware.

Regards

Danilo

477
Views
0
Helpful
2
Replies