Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Hard drives not showing up in BIOS of UCS C22M3 Server

Hi there,

I am wondering if someone can help me work out why my internal hard drives aren't showing up in the BIOS. When I enable the RAID controller and set up an array they are detected and placed online, but if I remove the RAID array they do not show up in the BIOS as a device from which I can boot from. I am using the onboard SCU as the RAID controller and it makes no difference with this enabled or not, the internal hard drives do not show up in the BIOS. I have tried many different combinations but are unable to ever see the drives listed in the BIOS. Initially when I first received the server I was sure this was the case but have since formatted the drives. I have also tried resetting the BIOS settings to default.

I would be most grateful if someone could help me as I have been working on this problem for a long time with no success.

Thanks in advance.

Tim

Image1.jpg

This image shows the drives with the array active, if I remove the array the drives still show up on this screen but not in BIOS.

Everyone's tags (2)
11 REPLIES

Hard drives not showing up in BIOS of UCS C22M3 Server

Hey Tim, welcome to the communy!

I don't think you are even supposed to see the individual disks as a boot option.  For all I know UCS is not intendeed to use its disks as JBOD (we'll see if that changes with new technologies like Hadoop) reason why you dont see the disks; you can see the RAID controller as a boot option  if you enable it to control the disks.

I made the test in a C220 with a PCIe RAID controller (I don't have a C22 but it is very similar) and when I went to BIOS I didn't see the disks listed either, then I rebooted and pressed F6 and still the disks are not showing up, only the PCIe RAID controller showed up as a boot option:

BBBBBBPPPPPPPPPPPPPPPPPPTTTTTTTTTTTTTTTTTTTTTTTTTTTT  .PNG

Last 2 things:

1-Why do you want to see the individual disks as a boot option?

2-Have you check another C22 or any other model to see if the behavior is different? If this does not happen on other servers (which I think it is NOT going to be the case) open a TAC case for further investigation.

Rate ALL helpful answers.

-Kenny

New Member

Hi Kenny,Thanks for the

Hi Kenny,

Thanks for the welcome and advice. The reason I ask is my listed boot devices show up similar to your server and I am able to install linux on it but when I go to reboot after the install is finished linux won't boot up and I receive a "Failed to find bootable device" message. Do i need to install any other software or drivers to boot to the drives?

Regards.

Tim

New Member

tamarsh did you find any

tamarsh did you find any solution...??

 

Are you having the same

Are you having the same situation?  Any screenshot or scenario you can share with us?

 

 

-Kenny

New Member

yes my scenerio is the same i

yes my scenerio is the same i have the raid controller UCS-RAID9286CV-8E i have searched theat its external raid which i cannot use for ESXi please correct me if i am wrong, second thiing above screen shots whihc shared in this thread i am seeing exactly the raid the drives when i enable embeddded mode from BIOS, but in ESXi installation i can see 4 drives and i insatlled esxi on one of the drive, but when i get boot from the raid (PCI card ) as shown in above screen shot it says "BOOT ERROR " , i wat to insatll esxi and CUCM 9.1 on this server, please suggest me how to confiugre esxi on this.

The PCIe RAID controller can

The PCIe RAID controller can be used for ESXi, the one that is not compatible is the embedded RAID controller.

Be sure to configure your RAID controller to be the part of your Boot Options in BIOS.  If you check here and the PCIe RAID controller is not listed, you probably have it disabled.

Rate ALL helpful answers

 

 

-Kenny

 

New Member

its external raid controller

its external raid controller card as mentioned in part number, when i go to webbios by pressing ctrl + H , there is no drive when i select my raid controller, if its disabled please let me know how to enable this??

 

I dont think it is disable if

I dont think it is disable if you have the option to get to it.

 

Check the cabling is correct by opening up the server.  You can see the correct cabling here:

 

http://www.cisco.com/c/en/us/td/docs/unified_computing/ucs/c/hw/C22/install/C22/raid.html#pgfId-1020431

Rate ALL helpful answers

 

 

-Kenny

 

 

New Member

two cables connected from

two cables connected from harddrives to two mini SAS ports , there is no internal ports on raid controller which can connect internally , raid contrller have two external ports only.

New Member

Thanks to all that have tried

Thanks to all that have tried to help me, I think my problem is a poor understanding of Linux. I have been trying to install Zentyal with RAID support but was unable to get it to boot up until I created the boot partition containing the Grub file on the internal USB drive.

Thanks again.

Tim

Cisco Employee

Tamarsh  what is the version

Tamarsh 

 

what is the version of Linux that you trying to install?

2605
Views
0
Helpful
11
Replies