Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

How to move UCS blade with OS on local disks between chassis

Hi,

I've to move blade between chassis - blade have OS installed on local disks and associated profile.

Can I simply:

shutdown

enter maintenance

remove it from chassis

swap with other blade from second chassis

power on

Will blade be properly recognized and profile will go with it ?

I've found advise here that is is better to decommission blade and associate profile back after move:

https://supportforums.cisco.com/discussion/11230671/physically-move-blade-server-another-slot-best-practise

but it seems too complex for me - can somebody who tired this exercise share some experience ?

 

Cheers

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,Assuming that the chassis

Hi,

Assuming that the chassis belong to the same domain (same pair of Fabric Interconnect) and that you are using ESXi, you may try the following:

1-Enter the host in maintenance mode (this might include moving the VMs to other server/power them off/make them enter maintenance mode as well)

2-Turn off the blade

3-Make sure that the Service Profile does not have a disk scrub policy so that data is not deleted when the Service Profile (SP) is disassociated

4-Disassociate the SP

5-Decommission the blade

6-Take out the blade and insert the new blade

7-Move the original blade to the second chassis

8-Reacknowledge the blade and associate the same/original SP

9-Power on the blade

10-Take the server out of maintenance mode. as well as the VMs

 

Note: For the blade inserted in the slot we took our blade out from, you may create a new SP and associate it to it or you can actually have any SP (including the one assigned to the blade recently taken out) and assign it to the new blade. 

Only one SP per sever and only one server per SP.

SPs are independent from the hardware (as long as the hardware is compatible with the features configured in the SP)

 

Let me know if this info was of help, otherwise let me know and I wil expand or try to make this easier.

 

Please rate ALL helpful answers

-Kenny

3 REPLIES

Hi,Assuming that the chassis

Hi,

Assuming that the chassis belong to the same domain (same pair of Fabric Interconnect) and that you are using ESXi, you may try the following:

1-Enter the host in maintenance mode (this might include moving the VMs to other server/power them off/make them enter maintenance mode as well)

2-Turn off the blade

3-Make sure that the Service Profile does not have a disk scrub policy so that data is not deleted when the Service Profile (SP) is disassociated

4-Disassociate the SP

5-Decommission the blade

6-Take out the blade and insert the new blade

7-Move the original blade to the second chassis

8-Reacknowledge the blade and associate the same/original SP

9-Power on the blade

10-Take the server out of maintenance mode. as well as the VMs

 

Note: For the blade inserted in the slot we took our blade out from, you may create a new SP and associate it to it or you can actually have any SP (including the one assigned to the blade recently taken out) and assign it to the new blade. 

Only one SP per sever and only one server per SP.

SPs are independent from the hardware (as long as the hardware is compatible with the features configured in the SP)

 

Let me know if this info was of help, otherwise let me know and I wil expand or try to make this easier.

 

Please rate ALL helpful answers

-Kenny

Community Member

Followed this procedure, host

Followed this procedure, host was moved successfully without data lost on local disks.

Cheers!

Glad to help!   ;)-Kenny 

Glad to help!   ;)

-Kenny

 

2013
Views
0
Helpful
3
Replies
CreatePlease to create content