Cisco Support Community
Community Member

In-band KVM stopped working


With the help of the following thread,, I successfully configured in-band KVM for a customer and had it working to the point I was able to pull up the console on a service profile and install ESXi using vMedia.  However, when I returned to the customer site to perform some training I discovered that the consoles no longer worked and received the error "The viewer has terminated. The network connection has been dropped".

The in-band configuration is using the same VLAN for ESXi host management.  I'm able to ping the ESXi host IP's but not the KVM IP's.  Per the link above, I have a VLAN group which is associated to the ESXi management VLAN and has no uplink ports or port-channels assigned.  The LAN global policy in-band profile is correctly set with the VLAN group and the network set to the ESXi management VLAN.  I even went as far as creating a separate IP pool and specified that in the policy.  The service profile is assigned addresses from the pool as expected but is simply not reachable.

UCSM is 2.2.2c and I've tested with two versions of Java 1.7.  I do have a TAC case open, unfortunately, they're not much help.  He originally had me setup an out-band address on the profile, which of course worked, and seemed to be good enough for TAC.  After pressing the in-band issue, I was told that a senior engineer told him that the FI required an access port, whatever that means, but was unable to elaborate when I asked for clarification or specific configuration examples.  He later stated that his research showed I should be able to setup an IP pool, configure the service profile, and allow it to pass management traffic through the inbound.  LOL, OK....  

Any help would be appreciated!





Community Member

Just to put it out there -

Just to put it out there - this issue has been resolved.  TAC reviewed the configuration and said all looked good.  Resolution was to reset the CIMC on each blade.  Root cause is unknown, although we discussed the possibility that some failover testing may have had a hand in the CIMC issue.

Community Member

HI team,

HI team,

i had the same problem but for me the issue was " IP Duplication" , the moment i changed the IP, taken it from unused IP pool, i was able to access the KVM-Console.

Community Member

I know this question is 11

I know this question is 11 months old but I had this same issue and I couldn't find the resolution.  For me, resetting the CIMC did not work.  Resetting the KVM Server is what fixed it:


  • UCSM-->Equipment tab
  • Select Chassis/Server having the KVM issue
  • Click Recover Server in the Actions pane
  • Select Reset KVM Server


My environment details:

  • UCSM version 2.2(3b)
  • B Series B200 M3 blade
  • Java 8 Update 60
Cisco Employee

I had a similar kind of

I had a similar kind of problem when I was using vMedia with the KVM console. KVM stopped working after some time giving a connection failed error. So I had to reset the CIMC in order to get it to work. To do that go to Admin -> firmware mgmt -> activate cimc (even though it's the same version). This will trigger a CIMC reboot and you will loose the connection for a while.

After the reboot I was able to launch KVM as before. I used JRE 7u21.

Cisco Employee

actually you can reboot cimc

actually you can reboot cimc from utilities also

Community Member

Re: actually you can reboot cimc

I had the same issue KVM not connecting -- viewer disconnecting it or network dropping.  I resolved it by updating CIMC firmware from 2.2(1b) to 3.1(25b)

Community Member

Re: I know this question is 11

Thank you!
Trying to upgrade from Win2008 to 2012(which is not working), then lost connectivtiy to the console. Resetting the KVM did the trick! Now back to my Windows issues :/
Thanks again.

CreatePlease to create content