Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Initial Installation of UCS 220 M3; issues with dedicated NIC mode

Hi all,

we are currently deploying two UCS 220 M3 rack servers. Each of them has two connections. One to the management port and another to LAN1. Both ports are in the same VLAN.

Currently the NIC mode is set to Shared LOM and Redundancy to active-standby. I now want to limit access to the CIMC to the management port only and according to the documentation I have to set NIC mode to dedicated and redundancy to none. Whenever I do that the system loses connection and I have to revert back to the shared LOM mode.

The CIMC version is 1.4(7)

Is there anything I am missing?

Regards,

Patrick

P.S.: On a side note is there a more detailed explanation regarding NIC Modes and the correlation to the redundancy mode? What happens for example if I set the mode to dedicated, which mandates redundancy set to none. How will the other ports react to this? Is it still possible to have them use active-standby or active-active redundancy? If so, how do I have to configure it?

Everyone's tags (5)
6 REPLIES
New Member

Initial Installation of UCS 220 M3; issues with dedicated NIC mo

Hi,

maybe you will find (most of) the answers in this great document:

http://www.cisco.com/en/US/docs/solutions/SBA/February2013/Cisco_SBA_DC_UnifiedComputingSystemDeploymentGuide-Feb2013.pdf

I already discovered it last week... Too late for me, but it maybe will help you.

Best,

Timo

Cisco Employee

Initial Installation of UCS 220 M3; issues with dedicated NIC mo

Sounds like a VLAN tagging issue.  Double check the CIMC configuration that you're NOT doing any VLAN tagging on CIMC interface from the web GUI. 

What does the two upstream switch port interface configs looks like?  Please paste the interface configs.  Likely one is not configured properly.

There should be information on NIC modes in the CIMC Guides on CCO.  When the CIMC is in dedicated mode, there is no redundancy unless the platform has dual CIMC interfaces.  The C220 only has one. 

Regards,

Robert

New Member

Re: Initial Installation of UCS 220 M3; issues with dedicated NI

Hi Robert,

the CIMC on each of the UCS server have not been configured with VLAN tagging.

Switchport config for LAN1 Interface:

switchport

switchport access vlan

switchport mode access

switchport nonegotiate

no logging event link-status

no snmp trap link-status

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable

Switchport config for Mgmt Interface:

switchport access vlan

switchport mode access

no logging event link-status

no snmp trap link-status

spanning-tree portfast

spanning-tree bpduguard enable

end

However, what I have forgotten to mention is, that the port where Mgmt is connected to points to a FastEthernet Interface as it is on different switch. Might that the problem?

Regarding CIMC in general. It is my understanding that everything related to CIMC means administration of the UCS server itself. Dedicated NIC mode is then the only means of accessing the CIMC. All the other ports are then used for the OS running on the UCS, am I right?

With redundancy set to none this would basically mean that I am not able to team the NICs anymore?

Regards,

Patrick

New Member

Re: Initial Installation of UCS 220 M3; issues with dedicated NI

Yep, it was indeed the FastEthernet Port. I feel dumb now.

Regards,

Patrick

Cisco Employee

Initial Installation of UCS 220 M3; issues with dedicated NIC mo

The NIC modes are used only to acess CIMC.

If you set it to Dedicated, CIMC traffic will only pass that port. It will not use the LOM ports. However, the LOM port will be able to pass data and will be available for the operating system.

New Member

Initial Installation of UCS 220 M3; issues with dedicated NIC mo

Hello,

may be you will find the answer on the below given link.

http://www.cisco.com/en/US/docs/unified_computing/ucs/c/hw/C220/install/install.html

Thanks you,

Regards

keshav

1564
Views
0
Helpful
6
Replies
CreatePlease login to create content