Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

PowerTool Command for Network Card Firmware Details

I need following network card firmware information through powertool command, please let me know if anyone knows about any command for this.

Capture.PNG                  

2 REPLIES
Cisco Employee

PowerTool Command for Network Card Firmware Details

Hi,

This might help:

Get-UcsFirmwareBootUnit | Where-Object {$_.dn -eq "sys/chassis-1/blade-1/adaptor-1/mgmt/fw-boot-def/bootunit-combined"}

AdminState      : triggered

IgnoreCompCheck : no

Image           : running

OperState       : pending-next-boot

PrevVersion     : 2.1(2a)

ResetOnActivate : no

Type            : combined

Version         : 2.1(1e)

Dn              : sys/chassis-1/blade-1/adaptor-1/mgmt/fw-boot-def/bootunit-combined

Rn              : bootunit-combined

Status          :

Ucs             : UCSPOD-A-B
AdminState      : triggered
IgnoreCompCheck : no
Image           : running
OperState       : pending-next-boot
PrevVersion     : 2.1(2a)
ResetOnActivate : no
Type            : combined
Version         : 2.1(1e)
Dn              : sys/chassis-1/blade-1/adaptor-1/mgmt/fw-boot-def/bootunit-combined
Rn              : bootunit-combined
Status          :
Ucs             : UCSPOD-A-B

New Member

PowerTool Command for Network Card Firmware Details

Thanks Brian For Response.

Regarding above command, we can get details but i need backup version which is not a part of this result.

Version property will provide running version but PreVersion is not a backup version.

This is something we was updated last time. I want information for Current and Backup Version for Adapter.

When i am trying to activate older version which is not in activate list, i am getting below error where it is clearly showing what is current and backup version. So i need command where i can get current and backup version so that i can set condition in my script.

Thanks Again :-)

Firmware.png

337
Views
0
Helpful
2
Replies
CreatePlease to create content