Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ucs kvm - connection failed

Hi,

I run into problem with kvm.

When i try to run kvm console i get "connection failed" , but i manage to connect once from 10 times.

I have "Managament IP Pool" and i can see assigned ip addres to my blade server.

Is someone have the same issue ?

Thanks!

Everyone's tags (1)
2 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

Re: ucs kvm - connection failed

To correct this issue with CICM access (KVM), make sure the Management IP Pool(ext-mgmt) is within the same VLAN and subnet as the FIC IP's. CICM access is provided over the MGMT 0 and 1 interfaces on the FIC's and not from the 10GB uplinks.

New Member

Re: ucs kvm - connection failed

I encountered this problem yesterday.  Make sure that you decommission the blades before reseating them.

15 REPLIES
Cisco Employee

Re: ucs kvm - connection failed

Remi,

Provide the following info

What are the following details for your FI-A, FI-B and VIP:

IP Address

Mask

Gateway

- Do you have this connection issue from other clients?

- What version UCSM are you running?

- What is the upstream connectivity? (Switch type, connecitvity - Port channel, VPC etc)

As the Mgmt Interfaces will proxy your KVM connections to the BMC (KVMs) there's likely some mis-conifg somewhere.

Robert

New Member

I have

I have

$ java -version
java version "1.7.0_75"
Java(TM) SE Runtime Environment (build 1.7.0_75-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.75-b04, mixed mode)

And security settings should be as per attached

New Member

Re: ucs kvm - connection failed

Hi Reni,

I am experiencing the same issue with the kvm. As far I know this is known problem among other vendors also. I cannot tell what exaclty the problem is but is related to the kvm hardware itself.

The workaround which I am using it to reseat the blade server or located in different chassis's slot.

Stanley

New Member

Re: ucs kvm - connection failed

I am having the same problem as well.  I currently have 1 machine that is affecting only me.  It can only be accessed maybe 1/50 times...however I can access any of our other 21 machines no problem.  Other users have sporadically seen the error but a retry gets them in no problem.  We currently have B200-M2s.

New Member

Re: ucs kvm - connection failed

To correct this issue with CICM access (KVM), make sure the Management IP Pool(ext-mgmt) is within the same VLAN and subnet as the FIC IP's. CICM access is provided over the MGMT 0 and 1 interfaces on the FIC's and not from the 10GB uplinks.

New Member

Re: ucs kvm - connection failed

one solutions is to go to start>control panel>java>

on the general tab click network settings and select direct connection.

after this go to general tab, and temporary internet files, select view and erase those old connections. then go to settings and erase files.

New Member

Re: ucs kvm - connection failed

I encountered this problem yesterday.  Make sure that you decommission the blades before reseating them.

New Member

ucs kvm - connection failed

Marek,

Your fix for the JAVA settings is what fixed the issue for me. Thank you for posting !

Marek Slabej wrote:

one solutions is to go to start>control panel>java>

on the general tab click network settings and select direct connection.

after this go to general tab, and temporary internet files, select view and erase those old connections. then go to settings and erase files.

New Member

Re: ucs kvm - connection failed

This fixed my issue.

Changing the Network settings under Java as it was set to browser settings and my browser is using proxy as per our company settings.

Thanks mate!

one solutions is to go to start>control panel>java>

on the general tab click network settings and select direct connection.

after  this go to general tab, and temporary internet files, select view and  erase those old connections. then go to settings and erase files.

Silver

Re: ucs kvm - connection failed

Thanks!

New Member

ucs kvm - connection failed

Thanks for that hint. This fixed my issue: I got disconnected when  the blade was rebooted and I could not reconnect quick enough to mount  the ISO image before the system leaves the POST.

New Member

ucs kvm - connection failed

I'm installing a new UCS system with the 2.0 UCS Manager version, and getting the KVM "Connection Failed" error message some times. When I reset the blade, the KVM works properly, but after X successful KVM connections (or after X hours...who knows) I get the "Connection Failed" KVM message again...and it persists till I reset the blade one more time.

I'm running JAVA 1.6.0_21

Any one experiencing the same or having any suggestions?

Thanks a lot,

Cisco Employee

ucs kvm - connection failed

Dani,

Are the failures all to the same blade or multiple?

Does the connection fail from multple clients (while it's in a failed state)?

Next time it fails, can you enable the Java logging terminal (from Control Panel - Java), and paste the session log here.

Thanks,

Robert

New Member

Re: ucs kvm - connection failed

Robert,

We have tried from several different clients, but no success. We have 2x B-250M2 with vSphere 4 installed on local disks and 2x B-200M2 without any OS. Failures occur on both the B-250M2 blades and do not seem to occur on the B-200M2, though that should not be a fair conclusion, as we constantly try to access KVM in the B-250M2's, but we don't in the B-200M2's (I somehow suspect the failure triggers after X succesful attempts to get to the KVM).

Following you can find the Java log. It is what says when the failure occurs...actually, the failure is not blinking but permanent..till the moment one resets the blade.

Java Log doesn't seem to help a lot:

Java Web Start 1.6.0_26

Usar versión JRE 1.6.0_26-b03 Java HotSpot(TM) 64-Bit Server VM

Directorio local del usuario = C:\Users\dcamps.IPMCTL

----------------------------------------------------

c:   borrar ventana de consola

f:   finalizar objetos en la cola de finalización

g:   liberación de recursos

h:   presentar este mensaje de ayuda

m:   imprimir sintaxis de memoria

o:   activar registro

p:   recargar configuración de proxy

q:   ocultar consola

r:   recargar configuración de norma

s:   volcar propiedades del sistema y de despliegue

t:   volcar lista de subprocesos

v:   volcar pila de subprocesos

0-5: establecer nivel de rastreo en

----------------------------------------------------

Could not launch from cache. Will try online mode. [Some of required resources are not cached.]

-- parameters --

kmport=2068

vport=2068

apcp=1

version=2

sslv3=1

autoEof=0

user=__computeToken__

passwd=57083892027303183566091

tempunpw=true

ip=10.1.1.176

title=UCS / Chassis 1 - Server 3 - KVM Console

helpurl=https://10.1.1.174/ucsm/help/content/kvm_vm_help.html

Adding Frame Listener because is temp user [__computeToken__]

log4j:WARN No appenders could be found for logger (com.nuova.centrale.core.log4j.NuRollingFileAppender).

log4j:WARN Please initialize the log4j system properly.

10/17/2011 12:18:48:931:  Connection failed.

New Member

Re: ucs kvm - connection failed

Hello ,

Hope the below data with link will help.

1. If you are unable to ping the KVM IP address, which was assigned from the management (MGMT) IP

pool, you must verify that the IP pool addresses are within the same subnet as the management IP

address assigned to the fabric interconnect. If the pool does not match, all KVMs that receive IP

addresses from this pool are impacted.

2.Verify TCP port 2068 is not blocked by the access control list (ACL) or firewall between client and

blade CIMC. With this port closed, it results in failure to connect to any UCS KVM.

3. Verify browser configuration to ensure HTTP proxy does not break communication.

4. If you are unable to ping the KVM IP address, check which fabric interconnect manages the instance

for the blade and verify if it responds. If a fabric interconnect suffers from a failed/down mgmt0

interface, all blades that are managed by it experience KVM accessibility issues.

To verify the management instance of the blade, choose the blade from Equipment > General > .

5.If you are able to ping the KVM IP address, but still not able to connect to the KVM, you may have a

duplicate IP address in the network. One way to verify this is to statically assign a new IP address that

you know is not in use to the blade. If the host can be taken down, decommission the blade in

question and then try to ping the KVM IP address again. If it is still successful, that IP is duplicated in

the network. Remove the IP from the other device, or adjust the UCS MGMT IP Pool to not include

that address. 5.If you are able to ping the KVM IP address, but still not able to connect to the KVM, you may have a
duplicate IP address in the network. One way to verify this is to statically assign a new IP address that
you know is not in use to the blade. If the host can be taken down, decommission the blade in
question and then try to ping the KVM IP address again. If it is still successful, that IP is duplicated in
the network. Remove the IP from the other device, or adjust the UCS MGMT IP Pool to not include
that address.

http://www.cisco.com/image/gif/paws/115958/ucsm-kvm-troubleshooting-00.pdf

http://www.cisco.com/en/US/docs/unified_computing/ucs/sw/cli/config/guide/2.0/b_UCSM_CLI_Configuration_Guide_2_0.pdf

Regards

keshav

66352
Views
45
Helpful
15
Replies