Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

UCS Port Channeling

Hello all,

I'm setting up our UCS for port channeling and i believe we're having switch configuration issues. My supervisor is our interim network guy and isn't too familiar with the LACP protocol. After configuring the switch for LACP and enabling a Port Channel with an ID of 20 on the UCS, I have 1 of 2 interfaces with a Membership of UP and the other interface has a Membership of Individual.

I feel it's a switch configuration issue and I was hoping someone could help or point us in the right direction?

Here is the configuration he has set:

!

interface Port-channel20

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet4/7

switchport access vlan 30

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 20 mode active

!

interface GigabitEthernet4/8

switchport access vlan 30

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

channel-group 20 mode active

Thanks!

5 REPLIES

Re: UCS Port Channeling

You should also enable Port Fast on the upstream port channel.  It's on one member, but apply it to the Port-Channel20 interface also.

Once you do this, down and up the Port Channel and member interfaces from UCS.  It should come up.

Let us know.

Regards,

Robert

New Member

Re: UCS Port Channeling

We have these two warning messages. The first one I think we can ignore, the second I believe means these ports should no longer be setup for trunk mode?

%Warning: portfast should only be enabled on ports connected to a single

host. Connecting hubs, concentrators, switches, bridges, etc... to this

interface  when portfast is enabled, can cause temporary bridging loops.

Use with CAUTION

%Portfast has been configured on Port-channel20 but will only

have effect when the interface is in a non-trunking mode.

Here's his configuration:

!

interface Port-channel20

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast


Cisco Employee

Re: UCS Port Channeling

This should be fine.

Since the UCS is a device that operated in End Host Mode by default it acts as if the vNic is a physical cable plugged into the switch.

Therefore the portfast would be enabled for all vlans because the vnics would have different vlans.

Portfast is typically used for switchports connected to hosts and the UCS is doing just that just passing them over less links if that makes sense.

Is the PC still not working?  If not when you "connect nxos" on the fabric interconnect and do a "show run interface x/y" for the interface in the port channel what is the fabric interconnect config?

The upstream switch config looks good providing you are not trying to do a vPC.  If you are doing a vPC you will need to configure the vPC on the port channel on the upstream switch.

Joey

New Member

Re: UCS Port Channeling

The one item that stands out to me with your configuration are that the interfaces 4/7 and 4/8 are configured for both access and trunk. Removing the switchport access VLAN 30 and adding switchport trunk allowed vlans 30 should help. Do a shut then no shut and you should be okay

Sent from Cisco Technical Support iPhone App

New Member

Re: UCS Port Channeling

You should add trunk to your portfast command and as the previous person said you should remove the access commands from the physical interfaces

Sent from Cisco Technical Support iPhone App

1266
Views
0
Helpful
5
Replies