Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

UCS "Protect configuration" feature

I have created a Service Profile with the Local Disk Configuration Policy set to the default value. All went ok until I wanted to associate a different profile, now with RAID1 as the policy for the local disks. Here I got a misconfiguration error. Apparently, the default disk policy has the Protect Configuration activated by default and only Any Configuration mode is now accepted.

On the Cisco documentation it says the following about the Protect Configuration setting:

If checked, the server retains the configuration in the local disk configuration policy even if the server is disassociated from the service profile.

This property is checked by default.

When a service profile is disassociated from a server and a new service profile associated, the setting for the Protect Configuration property in the new service profile takes precedence and overwrites the setting in the previous service profile.


If you disassociate the server from a service profile with this option enabled and then associate it with a new service profile that includes a local disk configuration policy with different properties, the server returns a configuration mismatch error and the association fails.

So, from what I understand just create a new service profile with a Local Disk Policy that has the same Mode (Any Configuration in this case) but with the Protect Configuration not activated, and on associating it the new setting for Protect Configuration will be overwritten.

I've tried this, but it doesn't work. The new profile gets associated with the new created LocalDisk Configuration Policy but the setting for Protect Configuration does not get overwritten.

Do you have any suggestions?

P.S. The firmware version is 1.3(1n)

Everyone's tags (1)

Re: UCS "Protect configuration" feature

If you uncheck the protect option on the original policy you will be able to get around this error. I had this happen to me in the lab once and that fixed it for me.

New Member

Re: UCS "Protect configuration" feature

What were the steps you did?

Here is what I tried:

- Reassigned to the blade a service profile with the default Local Disk Configuration Policy and with the Protected Configuration activated (as was on the first profile assigned to the blade)

- After assignment I've modified the default Local Disk Configuration Policy by deactivating the Protected Configuration setting.

- Dissociated the service profile

- Associated a new service profile that had a new Local Disk Configuration Policy with Protected Configuration not activated and the Mode the same as the default policy.

Although in the service profile it shows the Protected Configuration as not activated, in the blade inventory I still see it activated.

Did you do it in a different way?

Or do you have any other suggestions?

Re: UCS "Protect configuration" feature

I received the config error when I created a new service profile that had a different local disk config policy than the one that was currently assigned to the blade. To resolve I unchecked the protected option on the disk config policy that was assigned to the original service profile.

New Member

Re: UCS "Protect configuration" feature

I've tried this, but with no success.

One strange thing is the following: in the Service Profile, Protect Configuration is set to no, but on the inventory of the server that has the service profile assigned it appears as activated.

Re: UCS "Protect configuration" feature

Try disassociating the profile again and wait for it to be completely removed before reassigning it.

New Member

Re: UCS "Protect configuration" feature

Disassociated the profile, waited for the whole process to finish, and then re-associated it.

Having at the LocalDiskConfiguration Policy the same Mode as the one stored in the storage contoller, but with the Protect Configuration option not checked, this should have overwritten the settings stored.

But it doesn't happen and I still see the same captures as on the above post.

New Member

Re: UCS "Protect configuration" feature

Problem solved and it had nothing to do with the Service Profile or with the Protect Configuration setting.

Apparently, the UCS Management Interface GUI has a bug on the Inventory tab and it doesn't update the status of the Protect Configuration setting once it gets changed.

I've found this when I needed to connect to the manager from a different workstation than the one that I was using. And surprise... surprise... The Protect Configuration setting was off. Once I restarted the GUI on the original workstation, I got the same results: everything was ok. I was fighting with windmills.

This is a good lesson: never trust a GUI

Thanks Jeremy for your help and time.