Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

UCSM 2.0(1t) doesn't like Java 1.7

Guys,

I have no luck whatsoever with starting UCSM 2.0(1t) on a Windows 2003 R2 (32-bit) machine: it says "Java 1.7 detected, Java 1.6 (or higher) required".

Release notes say: "The Cisco UCS Manager GUI is a Java-based application that requires Sun JRE 1.6 or higher"

So what's the bottom line - shall I expect UCSM 2.0 to work with Java 1.7, or not?

Regards,

Radek

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

UCSM 2.0(1t) doesn't like Java 1.7

Javea 1.7 is supported on 2.0(3) releases and newer.  2.0(3) is currently avaialble for download from CCO.

Regards,

Robert

19 REPLIES
New Member

UCSM 2.0(1t) doesn't like Java 1.7

Tried this, so the UCSM application got downloaded & installed from scratch, yet the problem remains:

Silver

UCSM 2.0(1t) doesn't like Java 1.7

Radek,

What is the OS on the client you are trying to access the UCSM from?

Is the java a 32-bit or 64-bit?

What browser are you trying to launch the UCSM from?

./Abhinav

New Member

UCSM 2.0(1t) doesn't like Java 1.7

Hi Abhinav,

It's Windows 2003 R2 SE SP2 32-bit.

The browser is IE6, but the UCSM application seems to be downloading & installing fine (there is a nice shortcut to UCSM on the desktop) - it just doesn't want to start.

Regards,

Radek

New Member

UCSM 2.0(1t) doesn't like Java 1.7

Anyone with any hints (other than downgading JRE, which I'd like to avoid)?

Cisco Employee

UCSM 2.0(1t) doesn't like Java 1.7

Radek,

How about upgrading UCSM to 2.01w :-)

There is a known internal defect which causes UCSM to fail with JRE 1.7 and is fixed in 2.0.1w and above version.

To isolate the cause, can you try launching UCSM from a system running JRE 1.6 and verify the behavior ?

Padma

New Member

UCSM 2.0(1t) doesn't like Java 1.7

I'm running 2.01(w) and just updated my Win7 x64 machine to Java 1.7 from 1.6 and now UCSM is broken with the same error posted above.  I've cleaned the Java cache, uninstalled/reinstalled JRE with no success. It seems Oracle has removed downloads for JRE 1.6 so downgrading isn't an option anymore.  Is 1.7 really supposed to work with UCSM 2.01(w)?

Win7 SP1 x64 launching from IE9

-- Adam

Re: UCSM 2.0(1t) doesn't like Java 1.7

Java 7 is not currently supported on any releases including UCSM 2.0(2q), 2.0(1x) or earlier.  Support will be built into the upcoming 2.1 release later this year, and possibly backwards patched into UCS 2.0(2) and 2.0(1) software trains..

For now the requirement is for Java 1.6

http://www.oracle.com/technetwork/java/archive-139210.html

Regards,

Robert

New Member

UCSM 2.0(1t) doesn't like Java 1.7

Hi Robert,

  I know this thread is a little stale.

There is the ability to directy download older versions of the Java JRE from the java.com site.

http://java.com/en/download/manual_v6.jsp

This should tide everyone over until 1.7 is supported.

Kris

UCSM 2.0(1t) doesn't like Java 1.7

Thanks for the direct like Kris - much easier!

1.7 support will be in Del Mar (2.1) and beyond.

Rob

New Member

UCSM 2.0(1t) doesn't like Java 1.7

Even with java 1.6 I get the error:

com.sun.deploy.net.JARSigningException: Found unsigned entry in resource: https://x.x.x.x/ucsm/unpacked/OfficeLnFs_2.7.jar

I am running java 1.6.0_33.

Cisco Employee

UCSM 2.0(1t) doesn't like Java 1.7

Did you remove Java 1.7 before/after installing Jave 1.6?

Java 1.7 should be completely removed

Cisco Employee

UCSM 2.0(1t) doesn't like Java 1.7

In Control Panel > Java, do you have the keep temporary files setting enabled in Temporary Internet Files? I was able to replicate the error you're seeing by disabling temporary files in java 1.6.

New Member

UCSM 2.0(1t) doesn't like Java 1.7

Hi Radek,

I assume you and I are in the same boat.... Cisco UCSM needs 1.6 and Netapp tools require 1.7.... Bloody annoying....

Still no fix...??

mick

UCSM 2.0(1t) doesn't like Java 1.7

Javea 1.7 is supported on 2.0(3) releases and newer.  2.0(3) is currently avaialble for download from CCO.

Regards,

Robert

New Member

UCSM 2.0(1t) doesn't like Java 1.7

Hi robert,

Thanks for that its now resolved and working

Michael .

New Member

UCSM 2.0(1t) doesn't like Java 1.7

Hi Michael,

I've lost access to my UCS toys since, as they got 'repurposed' - but I would trust Robert on this one: if he says it's fixed, it probably means it really is!

Regards,

Radek

New Member

UCSM 2.0(1t) doesn't like Java 1.7

Hi Radek,

Ive  got a full fleaxPod in my Demolab so I am now upgreading to 2.0(3) now.  Ill let you know when its done... Im sure it will work and will be  better then running a VM for an older version..

You comming to Dublin in November??

Michael

New Member

UCSM 2.0(1t) doesn't like Java 1.7

As an alternative, you can always launch java webstart manually - from the dos command line.  This gives you the flexibility to use the JVM of choice with the jnlp application.  (for example, you could use java 1.6 for UCS emulator without downgrading your workstation from 1.7).

It is quite simple:

1) Launch JRE console from your java installation (something like C:\Program Files\Java\jre 6\bin\javacl.exe).  Under Java/View panel - only select Java 1.6. 

2) Launch the jnlp manually.  For example:

C:\Program Files\Java\jre6\bin\javaws.exe "ucsm.jnlp"

Cheers

Ike

New Member

UCSM 2.0(1t) doesn't like Java 1.7

We have faced this issue in release 2.11b and now after upgrading firmware 2.1.3b it's got resolved.

23444
Views
26
Helpful
19
Replies