Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VM-FEX problem - uplinks in VmWare are blocked by admin

Hello,

Im trying to configure VM-FEX on our UCS infrastructure. I have updated all UCS components to version 2.1(3a). Our VmWare is in verision 5.1.0 and we have Enterprise Plus feature set.

I have studied several documentations about setting VM-FEX, but no success yet.....

I have the UCS an the VCenter integration up. My DVS created in the UCSM can be seen in the vCenter, also when I create the port profile, I can see him in the vcenter and attach the virtual machine with it.

The only problem is, that the uplinks from the VM-FEX DVS are in the "blocked by the admin" state in the vCenter and there is no possibility to shut them up.

Can anyone help me?

Thanks and regards Jiri.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

VM-FEX problem - uplinks in VmWare are blocked by admin

Yes, initially we used to have the same file for both the N1k and VM-FEX but this was changed sometime back. A good way to check this would be to see what VEM modules are loaded. For example:

N1k:

~ # esxcfg-module -l | grep vem
vem-v160-l2device        3    36
vem-v160-n1kv            13   220
vem-v160-vssnet          4    6820
vem-v160-stun            1    128

VM-FEX:

~ # esxcfg-module -l | grep vem
vem-v152-vmfex-svs-mux   11   32
vem-v152-vmfex-pts       1    148

The version number (v160, v152) could vary, but the modules PTS, svs-mux etc won't change.

Thanks,

Shankar

6 REPLIES
Cisco Employee

VM-FEX problem - uplinks in VmWare are blocked by admin

Hello,

We're just extending the fabric till the VM. So are you able to connect to the VM via the network and is the VM showing up on UCSM?

I think the state of the uplink is expected. The uplink does not really matter when you are using VM-FEX here.

Regards,

Shankar

New Member

VM-FEX problem - uplinks in VmWare are blocked by admin

No, the VM is not able to communicate and I can not also see him in the UCSM.

Cisco Employee

VM-FEX problem - uplinks in VmWare are blocked by admin

VM-FEX configuration example:

http://www.cisco.com/en/US/products/ps10280/products_configuration_example09186a0080c13ee2.shtml

Troubleshooting guide:

http://www.cisco.com/en/US/solutions/collateral/ns340/ns517/ns224/ns944/basic_troubleshooting_vm_fex.html

Would it be possible for you to go through these and make sure you have the correct policies selected (for dynamic vNIC policy etc)?

What is the server model/adapter/UCS version/ESX version that you are using?

What is the output of 'vmkload_mod -l | grep vem', 'vem status -v' and 'esxcfg-vswitch -l' from the ESX host?

Thanks,

Shankar

New Member

VM-FEX problem - uplinks in VmWare are blocked by admin

We had the same problem today, with just two of our hosts.  It occured after doing some UCS firmware upgrades and installing VMWare patches.

Somehow, we managed to remove the VM-FEX VEM software module and replaced it with the 1000v VEM software module. 

We tried everything....finally we opened a TAC case.  The first email from the engineer asking us why we had the 4.2.xxxx module installed and not the 5.1.xxxx module, clued us in.

We removed the wrong module and installed the correct one....all is working now....When we check the VEM it shows the right module now.

# vem status -v

Package vssnet-esxmn-next-release

Version 5.1-1.1.1.1

Build 1

# vem status -v

Package vssnet-esxmn-next-release

Version 5.1-1.1.1.1

Build 1

Cisco Employee

VM-FEX problem - uplinks in VmWare are blocked by admin

Yes, initially we used to have the same file for both the N1k and VM-FEX but this was changed sometime back. A good way to check this would be to see what VEM modules are loaded. For example:

N1k:

~ # esxcfg-module -l | grep vem
vem-v160-l2device        3    36
vem-v160-n1kv            13   220
vem-v160-vssnet          4    6820
vem-v160-stun            1    128

VM-FEX:

~ # esxcfg-module -l | grep vem
vem-v152-vmfex-svs-mux   11   32
vem-v152-vmfex-pts       1    148

The version number (v160, v152) could vary, but the modules PTS, svs-mux etc won't change.

Thanks,

Shankar

New Member

VM-FEX problem - uplinks in VmWare are blocked by admin

Hello,

thank you for your replies. It seems that it is the version problem. One host which is working has this version:

~ # esxcfg-module -l | grep vem

vem-v151-vmfex-svs-mux   11   32

vem-v151-vmfex-pts       1    148

another, which is not has:

~ # esxcfg-module -l | grep vem

vem-v160-l2device        3    36

vem-v160-n1kv            16   228

vem-v160-vssnet          4    6824

vem-v160-stun            1    128

Problem is, that the VmWare update manager is this upgrade recommending....... When you install the recommended update VM-FEX is gon...

Thanks again.

Regards Jiri

1000
Views
10
Helpful
6
Replies