Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

7921 Firmware Problem CME

I have cme 4.1 running on a 2851. I have configured some 7921s on the router. When they boot the firmware upgrade fails. Below is the code.

tftp-server flash:APPS-1.0.3.SBN

tftp-server flash:CP7921G-1.0.3.LOADS

tftp-server flash:GUI-1.0.3.SBN

tftp-server flash:SYS-1.0.3.SBN

tftp-server flash:TNUX-1.0.3.SBN

tftp-server flash:TNUXR-1.0.3.SBN

tftp-server flash:WLAN-1.0.3.SBN

Telephony-Service

load 7921 CP7921G-1.0.3

when the phone loads up i logged the following.

May 16 13:58:07.059: TFTP: Looking for CTLSEP001F6C7A7D4C.tlv

May 16 13:58:07.203: TFTP: Looking for SEP001F6C7A7D4C.cnf.xml

May 16 13:58:07.203: TFTP: Opened system:/its/SEP001F6C7A7D4C.cnf.xml, fd 0, size 1275 for process 237

May 16 13:58:07.219: TFTP: Finished system:/its/SEP001F6C7A7D4C.cnf.xml, time 00:00:00 for process 237

May 16 13:58:07.451: TFTP: Looking for Ringlist.xml

May 16 13:58:07.551: TFTP: Looking for DistinctiveRingList.xml

May 16 13:58:07.563: TFTP: Opened flash:DistinctiveRingList.xml, fd 0, size 2823 for process 237

May 16 13:58:07.595: TFTP: Finished flash:DistinctiveRingList.xml, time 00:00:00 for process 237

May 16 13:58:07.703: TFTP: Looking for English_United_States/7921-dictionary.xml

May 16 13:58:07.807: TFTP: Looking for English_United_States/7921-kate.utf-8.xml

May 16 13:58:07.915: TFTP: Looking for English_United_States/7921-font.dat

May 16 13:58:10.455: %IPPHONE-6-REG_ALARM: Name=SEP001F6C7A7D4C Load=CP7921G-MFG-A.7 Last=Initialized

May 16 13:58:10.655: %IPPHONE-6-UNREGISTER_ABNORMAL: ephone-56:SEP001F6C7A7D4C IP:192.168.10.112 Socket:55 DeviceType:Phone has unregistered abnormally.

May 16 13:58:10.655: %IPPHONE-6-REGISTER: ephone-56:SEP001F6C7A7D4C IP:192.168.10.112 Socket:48 DeviceType:Phone has registered.

May 16 13:58:16.160: TFTP: Looking for CP7921G-1.0.3/CP7921G-1.0.3.LOADS

May 16 13:58:16.272: TFTP: Looking for CP7921G-1.0.3.LOADS

May 16 13:58:16.288: TFTP: Opened flash:CP7921G-1.0.3.LOADS, fd 0, size 871 for process 237

May 16 13:58:16.300: TFTP: Finished flash:CP7921G-1.0.3.LOADS, time 00:00:00 for process 237

The phone shows firmware failed and when I show the ephone phone-load it has not updated.

I have also tried 1.0.1 version of the code.

thanks,

14 REPLIES
Hall of Fame Super Gold

Re: 7921 Firmware Problem CME

You need to configure with "tftp-server ..." all and any CP79xx files.

Hope this helps, please rate post if it does!

Community Member

Re: 7921 Firmware Problem CME

i just included the tftp commands related to the 7921. Is there any that I may have missed for the 7921?

Hall of Fame Super Gold

Re: 7921 Firmware Problem CME

You must have misspellings or something, from the trace above phone request certain files but the router doesn't give them to phone.

Community Member

Re: 7921 Firmware Problem CME

I have checked and my spellings are all correct. When I entered the commands I copied the original filename to prevent any misspellings.

Anonymous
N/A

Re: 7921 Firmware Problem CME

did you ever resolve this problem. we have had similar issues upgrading firmware on 7921 wireless phones and have resolved by first resetting the 7921 to factory defaults as below.

Step 1 Press the Navigation Button downwards to enter SETTINGS mode

Step 2 Navigate to and select Phone Settings.

Step 3 Press **2 on the keypad. The phone briefly displays this prompt: Restore to Default?

Step 4 Press the Yes softkey to confirm or No to cancel. The phone resets after selecting Yes

regards

David

Community Member

Re: 7921 Firmware Problem CME

Yes we did.

The phones had not actually upgraded from the factory firmware. I upgraded them to 1.0.1 and it upgraded. It wouldn't upgrade to 1.0.3 after that. We then upgraded to 1.0.4 and then to 1.0.5 and they are working great now. I added some more later and those wouldn't upgrade to 1.0.1 so I had to upgrade them to 1.0.4 directly and then 1.0.5.

I hope this helps.

Community Member

Re: 7921 Firmware Problem CME

Hi,

I have the same issue, did you just follow the same procedure and just replace the version (phones load and tftp settings etc with 1.0.1) to get it working.

I`m using ios version c2800nm-spservicesk9-mz.124-11.XW1.bin.

Thanks

N

Hall of Fame Super Gold

Re: 7921 Firmware Problem CME

Watch out because XW1 is riddled with bugs and you might be affected unexpectedly.

Community Member

Re: 7921 Firmware Problem CME

I brought it slowly up to 1.0.5 and things have been working great since then.

Community Member

Re: 7921 Firmware Problem CME

Hi, Have followed your advice, but still not getting the phones to pick the 1.0.1 load, when debugging, not even getting an attempt to get the 1.0.1 load file.

Probably going to upgrade the ios to XW2 as I believe all the phone loads are the same as XW1.

Community Member

Re: 7921 Firmware Problem CME

Hi Thanks,

seem to be having strange issues with hunt groups with the 7921G`s too.

Will try upgrading the ios to XW2.

Community Member

Re: 7921 Firmware Problem CME

Try to go to 1.0.4 and then 1.0.5. The last one I deployed had to take that path.

Hall of Fame Super Gold

Re: 7921 Firmware Problem CME

As mentioned in another thread. avoid early release of XW, due to many bugs. Currently XW7 is out and is the only one to be used unless proved otherwise.

Community Member

Re: 7921 Firmware Problem CME

I got round this issue by moving the files out of the sub directory and placing them in the the root. Changed the tftp location accordingly and they seem to work now!!!

Cheers

976
Views
8
Helpful
14
Replies
CreatePlease to create content