Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Back to Back T1 PRI Call Failure Issue!!!

Hello All,

        I have 2 CMEs setup using a back to back T1  for PRI Configs. The phones ring when I call from on but when I pick up  the other phone's handset there is nothing. No RTP. The call just hangs up  after about 10 - 18 seconds. Below are the configs and debugs I have captured.  Please advise. Should the Ascending and Descending channel selection be  the same on both T1 card or one be Ascending and the other be  Descending? Thanks.

!

hostname 2801

!

boot-start-marker

boot-end-marker

!

card type t1 0 3

!

no aaa new-model

network-clock-participate wic 3

ip cef

!

!

!

!

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

multilink bundle-name authenticated

!

isdn switch-type primary-ni

!

voice-card 0

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

controller T1 0/3/0

framing esf

clock source internal

linecode b8zs

cablelength short 133

pri-group timeslots 1-6,24

!

controller T1 0/3/1

framing esf

linecode b8zs

cablelength short 133

pri-group timeslots 1-6,24

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.100.1 255.255.255.0

duplex auto

speed auto

!

interface Service-Engine0/0

no ip address

shutdown

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1/0

!

interface FastEthernet0/1/1

!

interface FastEthernet0/1/2

!

interface FastEthernet0/1/3

!

interface Serial0/3/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn protocol-emulate network

isdn incoming-voice voice

no cdp enable

!

interface Serial0/3/1:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Vlan1

no ip address

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

!

!

!

!

!

!

control-plane

!

disable-eadi

!

!

voice-port 0/3/0:23

!

voice-port 0/3/1:23

!

!

!

!

!

dial-peer voice 100 pots

preference 1

destination-pattern 2001

incoming called-number .

direct-inward-dial

port 0/3/0:23

forward-digits all

!

dial-peer voice 101 pots

preference 2

destination-pattern 3001

port 0/3/0:23

forward-digits 4

!

!

!

!

telephony-service

max-ephones 10

max-dn 20

ip source-address 192.168.100.1 port 2000

max-conferences 4 gain -6

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn  1  dual-line

number 2001

!

!

ephone  1

device-security-mode none

mac-address 000B.5F6E.7421

type 7960

button  1:1

!

!

!

line con 0

exec-timeout 0 0

line aux 0

line 66

no activation-character

no exec

transport preferred none

transport input all

transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

login

!

scheduler allocate 20000 1000

end

---------------------------------------------------------------------------------------------------------------------==

hostname 2621

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$pm72$B3.hYa/Iw9uKYfRPD6Id8/

enable password

!

no aaa new-model

network-clock-participate slot 1

no network-clock-participate wic 0

voice-card 1

!

ip cef

!

!

!

!

no ip domain lookup

!

isdn switch-type primary-ni

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller T1 1/0

framing esf

linecode b8zs

cablelength short 133

pri-group timeslots 1-6,24

!

!

!

!

!

interface FastEthernet0/0

ip address 10.10.200.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

!

interface Serial1/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

2801 eigrp 1

network 172.16.0.0

no auto-summary

!

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

voice-port 1/0:23

!

!

!

!

!

dial-peer voice 200 pots

preference 1

destination-pattern 3001

incoming called-number .

direct-inward-dial

port 1/0:23

forward-digits all

!

dial-peer voice 201 pots

preference 2

destination-pattern 2001

port 1/0:23

forward-digits 4

!

!

!

!

telephony-service

max-ephones 10

max-dn 20

ip source-address 10.10.200.1 port 2000

create cnf-files version-stamp Jan 01 2002 00:00:00

max-conferences 4 gain -6

!

!

ephone-dn  1  dual-line

number 3001

!

!

ephone  1

mac-address 0013.1AE5.BC1A

type 7940

button  1:1

!

!

banner motd ^CC**********ALL TRESPASSERS WILL BE SHOT**********^C

!

line con 0

password cisco

logging synchronous

line aux 0

line vty 0 4

exec-timeout 0 0

password cisco

login

!

!

end

---------------------------------------------------------------------------------------------------------------------------

debug isdn q931 is              ON.

2621#

*Mar  1 04:31:06.850: ISDN Se1/0:23 Q931: RX <- SETUP pd = 8  callref = 0x0088

        Bearer Capability i = 0x8090A2

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98381

                Exclusive, Channel 1

        Progress Ind i = 0x8583 - Origination address is non-ISDN

        Calling Party Number i = 0x0080, '2001'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80, '3001'

                Plan:Unknown, Type:Unknown

*Mar  1 04:31:06.898: ISDN Se1/0:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8088

        Channel ID i = 0xA98381

                Exclusive, Channel 1

2621#

*Mar  1 04:31:06.910: ISDN Se1/0:23 Q931: TX -> ALERTING pd = 8  callref = 0x8088

        Progress Ind i = 0x8188 - In-band info or appropriate now available

2621#

*Mar  1 04:31:15.790: ISDN Se1/0:23 Q931: TX -> CONNECT pd = 8  callref = 0x8088

*Mar  1 04:31:15.802: ISDN Se1/0:23 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x0088

*Mar  1 04:31:15.810: ISDN Se1/0:23 **ERROR**: call_progress: DEV_CONNECTED VOICE ERROR: Bearer capability not available(0x3A): b channel 0 call id 0x9

2621#

*Mar  1 04:31:15.810: %ISDN-6-CONNECT: Interface Serial1/0:0 is now connected to 2001 N/A

2621#

vnm_dsprm_vtsp_indicate_alarm: fatal_err 1

*Mar  1 04:31:31.002: %DSPRM-5-KEEPALIVE: DSP 1 in slot 1, NOT RESPONDING - auto restart(8 times)

*Mar  1 04:31:31.002: %DSMP-3-DSPALARM: Alarm on DSP 1/1:1: status=0x1 message=0x0 text=-

*Mar  1 04:31:31.006: chnl info(1, 1, 1)

*Mar  1 04:31:31.006: vnm_dsprm_alarm_indication_msg_proc: fatal err 1

*Mar  1 04:31:31.010: %ISDN-6-DISCONNECT: Interface Serial1/0:0  disconnected from 2001 , call lasted 15 seconds

2621#

*Mar  1 04:31:31.018: ISDN Se1/0:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8088

        Cause i = 0x80AC - Requested circuit/channel not available

*Mar  1 04:31:31.030: ISDN Se1/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x0088

*Mar  1 04:31:31.042: ISDN Se1/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8088

2621#

*Mar  1 04:31:39.934: %DSPRM-5-UPDOWN: DSP 1 in slot 1, changed state to up

---------------------------------------------------------------------------------------------------------------------------

debug isdn q921 is              ON.

2621#

*Mar  1 04:34:31.042: ISDN Se1/0:23 Q921: User RX <- RRp sapi=0 tei=0 nr=52

*Mar  1 04:34:31.042: ISDN Se1/0:23 Q921: User TX -> RRp sapi=0 tei=0 nr=40

*Mar  1 04:34:31.046: ISDN Se1/0:23 Q921: User TX -> RRf sapi=0 tei=0 nr=40

*Mar  1 04:34:31.050: ISDN Se1/0:23 Q921: User RX <- RRf sapi=0 tei=0 nr=52

*Mar  1 04:34:31.622: ISDN Se1/0:23 Q921: User RX <- INFO sapi=0 tei=0, ns=40 nr=52

*Mar  1 04:34:31.626: ISDN Se1/0:23 Q921: User TX -> RR sapi=0 tei=0 nr=41

*Mar  1 04:34:31.670: ISDN Se1/0:23 Q921: User TX -> INFO sapi=0 tei=0, ns=52 nr=41

*Mar  1 04:34:31.678: ISDN Se1/0:23 Q921: User RX <- RR sapi=0 tei=0 nr=53

2621#

*Mar  1 04:34:31.682: ISDN Se1/0:23 Q921: User TX -> INFO sapi=0 tei=0, ns=53 nr=41

*Mar  1 04:34:31.690: ISDN Se1/0:23 Q921: User RX <- RR sapi=0 tei=0 nr=54

2621#

*Mar  1 04:34:37.158: ISDN Se1/0:23 Q921: User TX -> INFO sapi=0 tei=0, ns=54 nr=41

*Mar  1 04:34:37.166: ISDN Se1/0:23 Q921: User RX <- RR sapi=0 tei=0 nr=55

*Mar  1 04:34:37.170: ISDN Se1/0:23 Q921: User RX <- INFO sapi=0 tei=0, ns=41 nr=55

*Mar  1 04:34:37.174: ISDN Se1/0:23 Q921: User TX -> RR sapi=0 tei=0 nr=42

*Mar  1 04:34:37.178: ISDN Se1/0:23 **ERROR**: call_progress: DEV_CONNECTED VOICE ERROR: Bearer capability not available(0x3A): b channel 0 call id 0xA

2621#

*Mar  1 04:34:37.178: %ISDN-6-CONNECT: Interface Serial1/0:0 is now connected to 2001 N/A

2621#

vnm_dsprm_vtsp_indicate_alarm: fatal_err 1

*Mar  1 04:34:49.934: %DSPRM-5-KEEPALIVE: DSP 1 in slot 1, NOT RESPONDING - auto restart(9 times)

*Mar  1 04:34:49.934: %DSMP-3-DSPALARM: Alarm on DSP 1/1:1: status=0x1 message=0x0 text=-

*Mar  1 04:34:49.938: chnl info(1, 1, 1)

*Mar  1 04:34:49.938: vnm_dsprm_alarm_indication_msg_proc: fatal err 1

*Mar  1 04:34:49.942: %ISDN-6-DISCONNECT: Interface Serial1/0:0  disconnected from 2001 , call lasted 12 seconds

2621#

*Mar  1 04:34:49.946: ISDN Se1/0:23 Q921: User TX -> INFO sapi=0 tei=0, ns=55 nr=42

*Mar  1 04:34:49.958: ISDN Se1/0:23 Q921: User RX <- RR sapi=0 tei=0 nr=56

*Mar  1 04:34:49.962: ISDN Se1/0:23 Q921: User RX <- INFO sapi=0 tei=0, ns=42 nr=56

*Mar  1 04:34:49.962: ISDN Se1/0:23 Q921: User TX -> RR sapi=0 tei=0 nr=43

*Mar  1 04:34:49.974: ISDN Se1/0:23 Q921: User TX -> INFO sapi=0 tei=0, ns=56 nr=43

*Mar  1 04:34:49.982: ISDN Se1/0:23 Q921: User RX <- RR sapi=0 tei=0 nr=57

------------------------------------------------------------------------------------------------------------------------

2801#debug isdn q931

debug isdn q931 is              ON.

2801#

*Jan  1 04:45:14.450: ISDN Se0/3/0:23 Q931: Applying typeplan for sw-type 0xD is 0x0 0x0, Calling num 2001

*Jan  1 04:45:14.450: ISDN Se0/3/0:23 Q931: Applying typeplan for sw-type 0xD is 0x0 0x0, Called num 3001

*Jan  1 04:45:14.454: ISDN Se0/3/0:23 Q931: TX -> SETUP pd = 8  callref = 0x008A

        Bearer Capability i = 0x8090A2

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98381

                Exclusive, Channel 1

        Progress Ind i = 0x8583 - Origination address is non-ISDN

        Calling Party Number i = 0x0080, '2001'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80, '3001'

                Plan:Unknown, Type:Unknown

*Jan  1 04:45:14.510: ISDN Se0/3/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0x808A

        Channel ID i = 0xA98381

                Exclusive, Channel 1

*Jan  1 04:45:14.526: ISDN Se0/3/0:23 Q931: RX <- ALERTING pd = 8  callref = 0x808A

        Progress Ind i = 0x8188 - In-band info or appropriate now available

*Jan  1 04:45:20.850: ISDN Se0/3/0:23 Q931: RX <- CONNECT pd = 8  callref = 0x808A

*Jan  1 04:45:20.854: %ISDN-6-CONNECT: Interface Serial0/3/0:0 is now connected to 3001 N/A

*Jan  1 04:45:20.854: ISDN Se0/3/0:23 Q931: TX -> CONNECT_ACK pd = 8  callref = 0x008A

*Jan  1 04:45:26.854: %ISDN-6-CONNECT: Interface Serial0/3/0:0 is now connected to 3001 N/A

*Jan  1 04:45:30.934: ISDN Se0/3/0:23 Q931: RX <- DISCONNECT pd = 8  callref = 0x808A

        Cause i = 0x80AC - Requested circuit/channel not available

*Jan  1 04:45:30.934: %ISDN-6-DISCONNECT: Interface Serial0/3/0:0  disconnected from 3001 , call lasted 10 seconds

*Jan  1 04:45:30.938: ISDN Se0/3/0:23 Q931: TX -> RELEASE pd = 8  callref = 0x008A

*Jan  1 04:45:30.958: ISDN Se0/3/0:23 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x808A

---------------------------------------------------------------------------------------------------

2801#debug isdn q921

debug isdn q921 is              ON.

2801#

*Jan  1 04:46:57.458: ISDN Se0/3/0:23 Q921: Net TX -> INFO sapi=0 tei=0, ns=46 nr=62

*Jan  1 04:46:57.470: ISDN Se0/3/0:23 Q921: Net RX <- RR sapi=0 tei=0 nr=47

*Jan  1 04:46:57.514: ISDN Se0/3/0:23 Q921: Net RX <- INFO sapi=0 tei=0, ns=62 nr=47

*Jan  1 04:46:57.518: ISDN Se0/3/0:23 Q921: Net TX -> RR sapi=0 tei=0 nr=63

*Jan  1 04:46:57.530: ISDN Se0/3/0:23 Q921: Net RX <- INFO sapi=0 tei=0, ns=63 nr=47

*Jan  1 04:46:57.534: ISDN Se0/3/0:23 Q921: Net TX -> RR sapi=0 tei=0 nr=64

*Jan  1 04:47:04.722: ISDN Se0/3/0:23 Q921: Net RX <- INFO sapi=0 tei=0, ns=64 nr=47

*Jan  1 04:47:04.722: ISDN Se0/3/0:23 Q921: Net TX -> RR sapi=0 tei=0 nr=65

*Jan  1 04:47:04.726: %ISDN-6-CONNECT: Interface Serial0/3/0:0 is now connected to 3001 N/A

*Jan  1 04:47:04.726: ISDN Se0/3/0:23 Q921: Net TX -> INFO sapi=0 tei=0, ns=47 nr=65

*Jan  1 04:47:04.738: ISDN Se0/3/0:23 Q921: Net RX <- RR sapi=0 tei=0 nr=48

*Jan  1 04:47:10.726: %ISDN-6-CONNECT: Interface Serial0/3/0:0 is now connected to 3001 N/A

*Jan  1 04:47:19.886: ISDN Se0/3/0:23 Q921: Net RX <- INFO sapi=0 tei=0, ns=65 nr=48

*Jan  1 04:47:19.886: ISDN Se0/3/0:23 Q921: Net TX -> RR sapi=0 tei=0 nr=66

*Jan  1 04:47:19.890: %ISDN-6-DISCONNECT: Interface Serial0/3/0:0  disconnected from 3001 , call lasted 15 seconds

*Jan  1 04:47:19.890: ISDN Se0/3/0:23 Q921: Net TX -> INFO sapi=0 tei=0, ns=48 nr=66

*Jan  1 04:47:19.902: ISDN Se0/3/0:23 Q921: Net RX <- RR sapi=0 tei=0 nr=49

*Jan  1 04:47:19.910: ISDN Se0/3/0:23 Q921: Net RX <- INFO sapi=0 tei=0, ns=66 nr=49

*Jan  1 04:47:19.910: ISDN Se0/3/0:23 Q921: Net TX -> RR sapi=0 tei=0 nr=67

------------------------------------------------------------------------------------------------------------------------

2621#show controller T1

T1 1/0 is up.

  Applique type is Channelized T1

  Cablelength is short 133

  No alarms detected.

  alarm-trigger is not set

  Soaking time: 3, Clearance time: 10

  AIS State:Clear  LOS State:Clear  LOF State:Clear

  Version info Firmware: 20060623, FPGA: 20, spm_count = 0

  Framing is ESF, Line Code is B8ZS, Clock Source is Line.

  CRC Threshold is 320. Reported from firmware  is 320.

  Data in current interval (552 seconds elapsed):

     0 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

  Total Data (last 18 15 minute intervals):

     65343 Line Code Violations, 16769 Path Code Violations,

     2791 Slip Secs, 0 Fr Loss Secs, 4 Line Err Secs, 1 Degraded Mins,

     2789 Errored Secs, 0 Bursty Err Secs, 9 Severely Err Secs, 1711 Unavail Secs

2 REPLIES
Hall of Fame Super Gold

Back to Back T1 PRI Call Failure Issue!!!

*Mar  1 04:31:31.002: %DSPRM-5-KEEPALIVE: DSP 1 in slot 1, NOT RESPONDING - auto restart(8 times)

Update IOS.

You also need to configure clocks and network-clock-select.

Cisco Employee

Back to Back T1 PRI Call Failure Issue!!!

Hi,

Paolo is correct you need to have one side set as the network-side and configure the clock rate.  Also be sure to have incoming and outgoing  call legs for the dial peers, with incoming Voip destination-patterns going to the IP of CME, in your case session target ipv4 10.10.200.1.

Thanks,

Anthony

1549
Views
0
Helpful
2
Replies
CreatePlease to create content