Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Configuration of cisco 1760 with E&M connected with PBX

Dear All

i am very new to VOIP.

I have given the task to configure cisco 1760-V with 2E&M Cards ( 4

voice Ports) connected with PBX.

Below is my numbering scheme

my office Numering is 759-xxx ( where xxx is the extension number from

PBX)

Is this configuration is ok for recieving calls from other side??

When 757 is dialed from my site call will be forwarded to 172.16.68.9

When 756 is dialed from my site call will be forwarded to 172.16.70.9

and when any call started with number 8 is dialed it will be routed to

192.168.40.20

Please help me in solving this problem

!Configure pots dial-peer 1

dial-peer voice 1 pots

destination-pattern 759...

port 1/0

!Configure pots dial-peer 2

dial-peer voice 2 pots

destination-pattern 759...

Port 1/1

!Configure pots dial-peer 3

dial-peer voice 3 pots

destination-pattern 759...

Port 2/0

!Configure pots dial-peer 4

dial-peer voice 4 pots

destination-pattern 759...

Port 2/1

! Configure voip dial-peer 5

dial-peer voice 5 voip

destination-pattern 757

session target ipv4:172.16.68.9

Configure voip dial-peer 5

dial-peer voice 5 voip

destination-pattern 756

session target ipv4:172.16.70.9

!Configure voip dial-peer 6

dial-peer voice 6 voip

destination-pattern 8T

session target ipv4: 192.168.40.20

  • Video Over IP
5 REPLIES

Re: Configuration of cisco 1760 with E&M connected with PBX

Hi

I feel this configuration should work btw are you facing any kinda problems with this config ?

if yes do post out wht kinda of probs you are facing with the same..

regds

New Member

Re: Configuration of cisco 1760 with E&M connected with PBX

No i have not tried yet this configuration i Just planned.

Could you also advise me on QOS

Below is the whole configuration.

My link capacity is only 64 Kbps and i want only one call can establish at the same time ( other words data traffic will be on priority) please advise me if i need to change any configuraqqtion parameter.

Class-map match-all VOIP

match access-group 100

!

policy-map LLQ

class VOIP

priority 12

set ip precedence 5

class class-default

fair-queue

!

interface FastEthernet0/0

ip address 172.16.73.1 255.255.255.0

no proxy-arp

speed auto

!

Intererface Multilink1

ip address 192.168.234.58 255.255.255.252

ip tcp header-compression iphc-format

ppp multilink

ppp multilink fragment delay 10

ppp multilink interleave

ppp multilink group 1

service-policy output LLQ

ip rtp header-compression iphc-format

interface Serial0/0

bandwidth 64

no ip address

no ip proxy-arp

encapsulation ppp

no ip route-cache cef

no ip route-cache

no fair-queue

ppp multilink

ppp multilink group 1

!

access-list 100 permit udp any host 172.16.70.9

access-list 100 permit tcp any host 172.16.70.9

access-list 100 permit udp any host 172.16.68.9

access-list 100 permit tcp any host 172.16.68.9

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.234.57

!

!Configure pots dial-peer 1

dial-peer voice 1 pots

destination-pattern 759...

port 1/0

!Configure pots dial-peer 2

dial-peer voice 2 pots

destination-pattern 759...

Port 1/1

!Configure pots dial-peer 3

dial-peer voice 3 pots

destination-pattern 759...

Port 2/0

!Configure pots dial-peer 4

dial-peer voice 4 pots

destination-pattern 759...

Port 2/1

! Configure voip dial-peer 5

dial-peer voice 5 voip

destination-pattern 757

session target ipv4:172.16.68.9

Configure voip dial-peer 5

dial-peer voice 5 voip

destination-pattern 756

session target ipv4:172.16.70.9

!Configure voip dial-peer 6

dial-peer voice 6 voip

destination-pattern 8T

session target ipv4: 192.168.40.20

!

Voice-port 1/0

Playout-delay maximum 320

Playout-delay nominal 240

Input gain -5

Output attenuation 5

!

Voice-port 1/1

Playout-delay maximum 320

Playout-delay nominal 240

Input gain -5

Output attenuation 5

!

Voice-port 2/0

Playout-delay maximum 320

Playout-delay nominal 240

Input gain -5

Output attenuation 5

!

Voice-port 2/1

Playout-delay maximum 320

Playout-delay nominal 240

Input gain -5

Output attenuation 5

!

Signal loop-start

!

Ring frequency 25

!

Looking for help from experts

Thanks

Re: Configuration of cisco 1760 with E&M connected with PBX

Hi

From your config i see that your are having LFI,TCP,RTP header compression as well with LLQ for the VOIP traffic.

i would like to insist some tuning with respect to the ACL which you have created for the whole UDP packet transactions with the remote peer.

can u pls try out the following ACLs instead of the one you have already done with ??

access-list 101 permit udp any any range 16384 32767

access-list 101 permit tcp any any eq 1720

These ACLs basically matches the ports being used by voip traffic.

regds

New Member

Re: Configuration of cisco 1760 with E&M connected with PBX

You should enable rtp compression under the policy-map command and not on the interface.

Compress header ip rtp

New Member

Re: Configuration of cisco 1760 with E&M connected with PBX

Hi,

As you have mentioned that you are new to Voip, i am not sure how much you are aware of E&M signalling.

Well whenever a E&M integration with PBX i have done, i have never got it right at first go, solely because its a two way street. It is important to know what is being configured on the PBX end.

It would be a great idea to read on the 3 types of E&M signalling also there is a good link on CCO which talks about various pinouts.

http://www.cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a0080093f61.shtml

As far as dialpeers are concerned, they look good.So if signalling works out well, then i think you should be good to go.

In regards to qos, Well as Prem has mentioned, its a good idea to match on access list for UDP packets.

We know that "Cisco voice " uses port range of 16384 to 32767. So if you are matching those port then you can be rest assured that voice will be given priority.

In regards to QoS, it would be good idea to read the below link, to get a fair understanding on how LFI/LLQ works.

http://www.cisco.com/en/US/tech/tk652/tk698/technologies_tech_note09186a0080094660.shtml

Feel free to post if you have any doubts.

Regards

Venky

331
Views
0
Helpful
5
Replies