Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Connecting 2 Hicom PBX through a VoIP link with TCCS

Hi everybody,

I'm trying to connect two Hicom PBX by means of link VoIP made, on a 2 Mb leased line, by two cisco routers 2620XM with E1 Interfaces configured in TCCS.

For the configuration I used this two cisco document "Configuring and Troubleshooting Transparent CCS" and "Transparent Common Channel Signaling".

The proposed configuration does not work, voice ports don't make the trunk correctly, on one side I can see all the voice port in trunk status and in Up Operation, but the voice port which should transport the signaling stay in dorm Operation.

On the other side the status of the voice port that should transport the signaling behave in the same way, and all the other don't make the trunk at all.

With the command "sh voice DSP" I can not see the codec clear-ch on the dsp used for the voice port that should transport the signaling.

DSP DSP DSPWARE CURR BOOT

TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS

==== === == ======== ======= ===== ======= === == ========= ==

C549 012 00 {medium} 3.6.18 IDLE idle 0 0 1/0:0 16

Can anybody halp me understandig where the problem could be??

Thank you in advance

5 REPLIES
New Member

Re: Connecting 2 Hicom PBX through a VoIP link with TCCS

If you can post relevent configs we might be able to help you.

New Member

Re: Connecting 2 Hicom PBX through a VoIP link with TCCS

Hi,

the situation is a little bit canghed now, I found an error in my TCCS configuration, and now I can see all the trunk up, and also the Codec are correct. But the phone calls do not work. Here are the configuration I used.

The Simens PBX in "Chieri" (see hostname) is slave and the Siemens PBX in Riva is the marster.

************************************************************************

*********************** ""Chieri"" ***********************************

************************************************************************

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Chieri

!

logging buffered 4096 debugging

!

voice-card 1

!

ip subnet-zero

!

!

no ip domain-lookup

!

!

class-map match-all VoIP

match access-group 100

!

!

policy-map Link_Voip

class VoIP

priority percent 40

class class-default

fair-queue

!

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

controller E1 1/0

clock source internal

ds0-group 0 timeslots 16 type ext-sig

ds0-group 1 timeslots 1 type ext-sig

ds0-group 2 timeslots 2 type ext-sig

ds0-group 3 timeslots 3 type ext-sig

ds0-group 4 timeslots 4 type ext-sig

ds0-group 5 timeslots 5 type ext-sig

ds0-group 6 timeslots 6 type ext-sig

ds0-group 7 timeslots 7 type ext-sig

ds0-group 8 timeslots 8 type ext-sig

!

!

!

!

interface FastEthernet0/0

ip address 172.24.0.1 255.255.0.0

no keepalive

duplex auto

speed auto

!

interface Serial0/0

ip address 10.10.10.1 255.255.255.252

encapsulation ppp

service-policy output Link_Voip

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.2

ip http server

ip pim bidir-enable

!

!

access-list 100 permit udp any any precedence critical

access-list 100 permit udp any any dscp cs5

access-list 100 permit udp any any range 16384 32767

access-list 100 permit tcp any any eq 1720

!

call rsvp-sync

!

voice-port 1/0:0

timeouts call-disconnect 3

connection trunk 3000

!

voice-port 1/0:1

timeouts call-disconnect 3

connection trunk 4001

!

voice-port 1/0:2

timeouts call-disconnect 3

connection trunk 4002

!

voice-port 1/0:3

timeouts call-disconnect 3

connection trunk 4003

!

voice-port 1/0:4

timeouts call-disconnect 3

connection trunk 4004

!

voice-port 1/0:5

timeouts call-disconnect 3

connection trunk 4005

!

voice-port 1/0:6

timeouts call-disconnect 3

connection trunk 4006

!

voice-port 1/0:7

timeouts call-disconnect 3

connection trunk 4007

!

voice-port 1/0:8

timeouts call-disconnect 3

connection trunk 4008

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 3000 voip

destination-pattern 3000

session target ipv4:10.10.10.2

codec clear-channel

ip qos dscp cs5 media

ip qos dscp cs5 signaling

!

dial-peer voice 4000 voip

destination-pattern 40..

session target ipv4:10.10.10.2

ip qos dscp cs5 media

ip qos dscp cs5 signaling

!

dial-peer voice 1000 pots

destination-pattern 1000

port 1/0:0

!

dial-peer voice 2001 pots

destination-pattern 2001

port 1/0:1

!

dial-peer voice 2002 pots

destination-pattern 2002

port 1/0:2

!

dial-peer voice 2003 pots

destination-pattern 2003

port 1/0:3

!

dial-peer voice 2004 pots

destination-pattern 2004

port 1/0:4

!

dial-peer voice 2005 pots

destination-pattern 2005

port 1/0:5

!

dial-peer voice 2006 pots

destination-pattern 2006

port 1/0:6

!

dial-peer voice 2007 pots

destination-pattern 2007

port 1/0:7

!

dial-peer voice 2008 pots

destination-pattern 2008

port 1/0:8

!

!

line con 0

line aux 0

line vty 0 4

!

end

************************************************************************

*********************** ""Riva"" ***********************************

************************************************************************

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Riva

!

logging buffered 4096 debugging

!

voice-card 1

!

ip subnet-zero

!

!

no ip domain-lookup

!

!

class-map match-all VoIP

match access-group 100

!

!

policy-map Link_Voip

class VoIP

priority percent 40

class class-default

fair-queue

!

!

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

controller E1 1/0

ds0-group 0 timeslots 16 type ext-sig

ds0-group 1 timeslots 1 type ext-sig

ds0-group 2 timeslots 2 type ext-sig

ds0-group 3 timeslots 3 type ext-sig

ds0-group 4 timeslots 4 type ext-sig

ds0-group 5 timeslots 5 type ext-sig

ds0-group 6 timeslots 6 type ext-sig

ds0-group 7 timeslots 7 type ext-sig

ds0-group 8 timeslots 8 type ext-sig

!

!

!

!

interface FastEthernet0/0

ip address 172.18.0.5 255.255.0.0

duplex auto

speed auto

!

interface Serial0/0

ip address 10.10.10.2 255.255.255.252

encapsulation ppp

service-policy output Link_Voip

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.18.0.1

ip route 172.24.0.0 255.255.0.0 10.10.10.1

ip http server

ip pim bidir-enable

!

!

access-list 100 permit udp any any precedence critical

access-list 100 permit udp any any dscp cs5

access-list 100 permit udp any any range 16384 32767

access-list 100 permit tcp any any eq 1720

!

call rsvp-sync

!

voice-port 1/0:0

timeouts call-disconnect 3

connection trunk 1000 answer-mode

!

voice-port 1/0:1

timeouts call-disconnect 3

connection trunk 2001 answer-mode

!

voice-port 1/0:2

timeouts call-disconnect 3

connection trunk 2002 answer-mode

!

voice-port 1/0:3

timeouts call-disconnect 3

connection trunk 2003 answer-mode

!

voice-port 1/0:4

timeouts call-disconnect 3

connection trunk 2004 answer-mode

!

voice-port 1/0:5

timeouts call-disconnect 3

connection trunk 2005 answer-mode

!

voice-port 1/0:6

timeouts call-disconnect 3

connection trunk 2006 answer-mode

!

voice-port 1/0:7

timeouts call-disconnect 3

connection trunk 2007 answer-mode

!

voice-port 1/0:8

timeouts call-disconnect 3

connection trunk 2008 answer-mode

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 1000 voip

destination-pattern 3000

session target ipv4:10.10.10.1

codec clear-channel

ip qos dscp cs5 media

ip qos dscp cs5 signaling

!

dial-peer voice 2000 voip

destination-pattern 20..

session target ipv4:10.10.10.1

ip qos dscp cs5 media

ip qos dscp cs5 signaling

!

dial-peer voice 3000 pots

destination-pattern 3000

port 1/0:0

!

dial-peer voice 4001 pots

destination-pattern 4001

port 1/0:1

!

dial-peer voice 4002 pots

destination-pattern 4002

port 1/0:2

!

dial-peer voice 4003 pots

destination-pattern 4003

port 1/0:3

!

dial-peer voice 4004 pots

destination-pattern 4004

port 1/0:4

!

dial-peer voice 4005 pots

destination-pattern 4005

port 1/0:5

!

dial-peer voice 4006 pots

destination-pattern 4006

port 1/0:6

!

dial-peer voice 4007 pots

destination-pattern 4007

port 1/0:7

!

dial-peer voice 4008 pots

destination-pattern 4008

port 1/0:8

!

!

line con 0

line aux 0

line vty 0 4

!

!

end

New Member

Re: Connecting 2 Hicom PBX through a VoIP link with TCCS

Now that it has been a year, did you ever find an answer? I'm up against EXACTLY the same issue right now on a 3745 with NM-HDV-2T1-48 and 12.3(7)T . The good thing is your config above helped validate what I've already built -- the bad news is you posted it because it DIDN'T WORK. Was there a fix?

Thanks!

Mike

New Member

Re: Connecting 2 Hicom PBX through a VoIP link with TCCS

Something new about that? Is there any way to made it working!?

New Member

Re: Connecting 2 Hicom PBX through a VoIP link with TCCS

Hi,

I have configured TCCS on a customer and works as i should, but first i have tested in lab with frame relay becouse the debug tccs signalling only worked with frame relay, and with this debug you will see packets

08:55:47: 282 tccs packets received from the port.

08:55:47: 282 tccs packets received from the nework.

08:55:47: RX from Serial3/0:0:

08:55:47: tccs_db−>vcd = 105, tccs_db−>cid = 254

08:55:47: pak−>datagramsize=20

BE C0 C0 00 FF 03 C0 21 09 48 00 0C 01 49 F3 69 00 0C 42 00

08:55:47: 282 tccs packets received from the port.

08:55:47: 283 tccs packets received from the nework.

08:55:47: RX from Serial1/0: dlci=105, cid=254, payld−type =0,

payld−length=188, cid_type=424

08:55:47: datagramsize=20

BE C0 C0 00 FF 03 C0 21 0A 48 00 0C 03 EA DF 0D 00 0C 42 00

Here is the configs tha i have deployed

252
Views
9
Helpful
5
Replies
CreatePlease login to create content