Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP for Voice and Data VLAN's

We are configuring a Cat4500 to support voice and data on the same switch port. The 4500 must provide separate dhcp pools for the voice and data vlans:

ip dhcp pool Data

network 192.168.101.0 255.255.255.0

default-router 192.168.101.1

!

ip dhcp pool Nortel-IP-Phones

network 192.168.120.0 255.255.255.0

default-router 192.168.120.1

!

int vlan101

ip address 192.168.101.0 255.255.255.0

!

int vlan120

ip address 192.168.120.0 255.255.255.0

Would the following port configuration allow the IP phones, and the workstations attached to them, to pick up an IP address from the correct DHCP pool?

interface fas4/1

switchport mode trunk

switchport trunk encapsulation dot1q

switchport nonegotiate

switchport voice vlan 120

spanning-tree portfast

spanning-tree bpduguard enable

Thanks in advance

1 REPLY

Re: DHCP for Voice and Data VLAN's

Hello,

this depends on the configuration of your telephones. in case they are trunking for VLANs 101 and 120 it should work.

Just one more thing: the ip addresses on the VLANs 101 and 120 should be .1 and not .0, but I assume this is a typo in the post.

Hope this helps

Martin

497
Views
0
Helpful
1
Replies
CreatePlease login to create content