Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

How to apply LLQ QoS to traffic generate by router?

There is a voice gateway at the remote site, the voice card connect to the local pstn, for qos, the router must prioritize the voice traffic which is generated locally.

So is there any idea?

6 REPLIES

Re: How to apply LLQ QoS to traffic generate by router?

Hello,

you can use "R(config)#ip local policy route-map LocTraffic" to mark packets generated locally and use the a "normal" policy-map outbound on an interface to handle the traffic.

The route-map would look something like this:

route-map LocTraffic permit 10

match ip address 100

access-list 100 permit tcp any eq telnet any

This is also very useful in case you need to access the router under heavy load of the WAN interface. Just prioritize Telnet, etc., and you are done.

For a voice gateway the other choice is f.e. to configure the dial-peers with IP precedence values to be used. This will be possible through

dial-peer voice 100 voip

ip precedence 5

Hope this helps! Please rate all posts.

Regards, Martin

Community Member

Re: How to apply LLQ QoS to traffic generate by router?

I have tried you method, please see following:

R2#sh ip local policy

Local policy routing is enabled, using route map QoS

route-map QoS, permit, sequence 10

Match clauses:

ip address (access-lists): IP_QOS_5

Set clauses:

Policy routing matches: 318 packets, 27984 bytes

It indeed matched by this local policy, but I'm not sure whether it priorities by outbound queue CBWFQ?

From the config I can't sess any relationship between LLQ on outbound interface and the Local policy.

So how to prove traffic is indeed priorities by outbound queuing.

Blue

Re: How to apply LLQ QoS to traffic generate by router?

Place a call through the router.

show policy-map interface sX/X

It is helpful to set the interface load-interval 30 so the result is more real time.

Please rate helpful posts.

Community Member

Re: How to apply LLQ QoS to traffic generate by router?

This a voice related QoS question, but if my QoS is built to include the source address of the router I am using for my voice packets, I should not need to do anything additional for those packets to match, right?

--Jon

Community Member

Re: How to apply LLQ QoS to traffic generate by router?

No, it doesn't work. please see below:

R2#sh ip local policy

Local policy routing is enabled, using route map QoS

route-map QoS, permit, sequence 10

Match clauses:

ip address (access-lists): IP_QOS_5

Set clauses:

Policy routing matches: 11060 packets, 950804 bytes

Local Policy match many packet of IP prcendence 5 or RTP traffic. But... CBWFQ only match a little RTP packet...

Class-map: Voice (match-any)

5 packets, 458 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: protocol rtp

5 packets, 458 bytes

30 second rate 0 bps

Queueing

Strict Priority

Output Queue: Conversation 136

Bandwidth 70 (%)

Bandwidth 358 (kbps) Burst 8950 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Community Member

Re: How to apply LLQ QoS to traffic generate by router?

This is my config:

class-map match-any Voice

match protocol rtp

policy-map CBWFQ

class Voice

priority percent 70

interface Tunnel0

qos pre-classify

tunnel source Dialer0

ip nbar protocol-discovery

interface Dialer0

ip nbar protocol-discovery

ip route-cache flow

load-interval 30

service-policy output CBWFQ

ip local policy route-map QoS

ip access-list extended IP_QOS_5

permit ip any any precedence critical

route-map QoS permit 10

match ip address IP_QOS_5

mgcp

mgcp call-agent 192.168.80.3 service-type mgcp version 0.1

mgcp bind control source-interface Loopback0

mgcp bind media source-interface Loopback0

dial-peer voice 1 pots

service mgcpapp

port 1/0/0

382
Views
0
Helpful
6
Replies
CreatePlease to create content