Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Mgcp voice gateway receice call but not forward local DN number

Hello Everyone,

I want to configure mgcp gateway with Cisco 2921,  I hear one time calling voice and it drop, We have a 5 DID number, and all port assign to DN

Thanks For help,

My config is below,

redundancy

!

!

controller E1 0/0/0

pri-group timeslots 1-31 service mgcp

!

controller E1 0/0/1

shutdown

framing NO-CRC4

clock source internal

!

ip ftp username ftpdestekhiz

ip ftp password 7 01425F570C1F14

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 192.168.5.201 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn bchan-number-order ascending

isdn sending-complete

no cdp enable

!

interface BRI0/1/0

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn bind-l3 ccm-manager service mgcp

!

interface BRI0/1/1

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

!

ip default-gateway 192.168.5.254

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 192.168.5.254

ip route 10.10.10.0 255.255.255.0 192.168.1.253

!

!

!

!

control-plane

!

!

voice-port 0/0/0:15

echo-cancel coverage 64

cptone TR

!

voice-port 1/0/1

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar opx 4061

description TT_Line

caller-id enable

!

voice-port 1/0/2

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar opx 4061

description TT_Line

caller-id enable

!

voice-port 1/0/3

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar opx 4061

description TT_Line

caller-id enable

!

voice-port 1/1/0

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar opx 4061

description TT_Line

caller-id enable

!

voice-port 1/1/1

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar opx 4061

description TT_Line

caller-id enable

!

voice-port 1/1/2

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar opx 4061

description TT_Line

caller-id enable

!

voice-port 1/1/3

supervisory disconnect anytone

echo-cancel coverage 64

no vad

cptone TR

timeouts call-disconnect 5

timeouts wait-release 1

timing hookflash-out 50

timing sup-disconnect 1000

connection plar opx 4061

description TT_Line

caller-id enable

!

!

!

!

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 192.168.5.200

ccm-manager config

!

mgcp

mgcp call-agent 192.168.5.200 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp playout fixed 80

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

no mgcp explicit hookstate

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface GigabitEthernet0/0

!

mgcp profile default

!

!

dial-peer voice 999020 pots

service mgcpapp

port 0/2/0

!

dial-peer voice 999022 pots

service mgcpapp

port 0/2/2

!

dial-peer voice 999021 pots

service mgcpapp

port 0/2/1

!

dial-peer voice 999030 pots

service mgcpapp

port 0/3/0

!

dial-peer voice 999031 pots

service mgcpapp

port 0/3/1

!

dial-peer voice 999032 pots

service mgcpapp

port 0/3/2

!

dial-peer voice 999033 pots

service mgcpapp

port 0/3/3

!

dial-peer voice 999023 pots

service mgcpapp

port 0/2/3

!

dial-peer voice 999100 pots

service mgcpapp

port 1/0/0

!

dial-peer voice 999101 pots

service mgcpapp

port 1/0/1

!

dial-peer voice 999102 pots

service mgcpapp

port 1/0/2

!

dial-peer voice 999103 pots

service mgcpapp

port 1/0/3

!

dial-peer voice 999110 pots

service mgcpapp

port 1/1/0

!

dial-peer voice 999111 pots

service mgcpapp

port 1/1/1

!

dial-peer voice 999112 pots

service mgcpapp

port 1/1/2

!

dial-peer voice 999113 pots

service mgcpapp

port 1/1/3

!

dial-peer voice 1 pots

service mgcpapp

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 2 voip

destination-pattern 4...

session protocol sipv2

session target ipv4:192.168.1.230

dtmf-relay sip-notify h245-alphanumeric

codec g711ulaw

!

!

!

!

gatekeeper

shutdown

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

login local

transport input all

!

scheduler allocate 20000 1000

!

1 REPLY
Cisco Employee

Mgcp voice gateway receice call but not forward local DN number

Is this related to video??? I ask because you're posting this in the Video over IP section.

If not, then please move this to the appropriate area and make sure you post in the right area.

Exactly on which interface are you receiving the calls you talk about??

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
788
Views
0
Helpful
1
Replies
CreatePlease to create content