Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Prioritizing Voice Traffic

I am working on prioritizing my voice traffic from one VOIP server to the other. here is the setup:

phone---serverA--routerA--fiberlink--rouerB--serverB---ciscogateway----pstn

This is the config from the routerA:

ServerA

class-map match-any voip-priority

match ip dscp ef

class-map match-any voip-tag

match access-group name voip-tag

!

!

policy-map voip-priority

class voip-priority

bandwidth 7500

class class-default

fair-queue

queue-limit 5

policy-map voip-traffic

class voip-tag

set ip dscp ef

class class-default

set ip dscp default

!

!

interface FastEthernet0/0

service-policy output voip-priority

!

interface FastEthernet0/0.7

encapsulation dot1Q 7

ip address 7.6.x.x.255.255.252

!

interface FastEthernet0/1

ip address 10.7.7.9 255.255.255.0

service-policy input voip-traffic

!

ip access-list extended voip-tag

permit tcp any host 7.7.1.19 eq 1720

permit tcp any host 7.7.1.19 range 49152 49252

permit tcp any host 7.7.1.19 range 30040 30042

permit tcp any host 7.7.1.19 eq 10032

permit udp any host 7.7.1.19 range 1718 1719

permit udp any host 7.7.1.19 range 49152 49252

permit udp any host 7.7.1.19 range 2222 2242

permit udp any host 7.7.1.19 range 30000 30001

permit ip host 10.7.7.19 host 7.7.1.19

!

This is the config from the routerB:

ServerB

class-map match-any voip-priority

match ip dscp ef

class-map match-any voip-tag

match access-group name voip-tag

!

!

policy-map voip-priority

class voip-priority

bandwidth 7500

class class-default

fair-queue

queue-limit 5

policy-map voip-traffic

class voip-tag

set ip dscp ef

class class-default

set ip dscp default

!

interface FastEthernet0/0/0

switchport access vlan 7

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/1/2

switchport access vlan 222

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface Vlan7

ip address 7.6.x.x.255.255.252

service-policy output voip-priority

!

interface Vlan222

ip address 7.7.x.x.255.255.0

service-policy input voip-traffic

!

ip access-list extended voip-tag

permit tcp any host 10.7.7.19 eq 1720

permit tcp any host 10.7.7.19 range 49152 49252

permit tcp any host 10.7.7.19 range 30040 30042

permit tcp any host 10.7.7.19 eq 10032

permit udp any host 10.7.7.19 range 1718 1719

permit udp any host 10.7.7.19 range 49152 49252

permit udp any host 10.7.7.19 range 2222 2242

permit udp any host 10.7.7.19 range 30000 30001

permit ip host 7.7.1.19 host 10.7.7.19

!

Any ideas on whether i am missing anything? Should this be all i need?

5 REPLIES
Blue

Re: Prioritizing Voice Traffic

Your voice media packets should be strict priority queued, and the signalling packets should be in a separate class with bandwidth assigned. Media packet marking of EF is correct, and signalling is IP precedence 3 (cs3), though AF31 is still used by older code versions.

What brand of phones and servers are you using? Cisco gear will mark the packets correctly, so you can bypass the ingress policy map, and just match on DSCP for your egress map. If your equipment does not mark then you are on the right track, but just need to separate media and signalling, as well as defining a strict priority queue.

Something like this for your egress policy map:

policy-map voip-priority

class voip-priority

priority 7500

class voip-signal

bandwidth 512

class class-default

fair-queue

Please rate helpful posts.

Community Member

Re: Prioritizing Voice Traffic

Unfortunatly my phone system is not Cisco, but I should check to see if it marks the packets. We use an Altigen system.

With regards to your example....On our fiber link I described we have a 1.5mb connection, so should I go larger than 512? Also the priority 7500, is that sort of like 75% of the link?

As you can tell I am kind of winging this whole QOS thing, but learning allong the way.

Thanks again!

Blue

Re: Prioritizing Voice Traffic

Dave,

I did a quick browse to the Altigen web site, but didn't turn up any QOS info. After you determine the markings Altigen uses you can then set up the appropriate class maps to match on the DSCP or IP Precedence used. One for the media (voice)packets, and one for signalling (call setup).

Priority 7500 is kb/s, or 7.5mb/s. How much of the 1.5mb are you planning on using for voice? You need about 100 kb per call for G711 uncompressed calls. If you want to allow 8 calls use priority 800, and the signal class should be about 32.

Will there also be data traffic? Hopefully there is some Call Admission Control that will limit the number of calls that can be placed. They may also support RSVP which is another way of approaching QOS. RSVP is supported by Cisco, but requires different configuration.

Please use the pulldown menu to rate useful posts.

Dave

Community Member

Re: Prioritizing Voice Traffic

Also, what should my class voip-signal look like, and what should the access-list match on?

Community Member

Re: Prioritizing Voice Traffic

Dave, you are missing the priority command in your class voip-priority. Just putting the bandwidth statement will not create/use a priority queue. Use:

class voip-priority

priority

That should help.

1335
Views
8
Helpful
5
Replies
CreatePlease to create content