Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

QOS Issue on Catalyst C2950

Hi all,

I'm experiencing an issue in my lab when testing my QOS configuration.

For test purposes I connected two C2950G ( running IOS c2950-i6k2l2q4-mz.121-22.EA9.bin) linked by a 10Mb connection.

This link is congestionned by packet generator.

On one side I've got a video server which stream a video. On the other side I've got the client which watch the video.

When I only run a policy on the port of the video server which mark the packet in CS5, the video stream is well optimized and is not deteriorated.

The video is fluid through the congestionned link.

My policy is set to the switch port where is connected the server and seems like that:

interface FastEthernet0/23

service-policy input jemarque

policy-map jemarque
  class video-lan
    set ip dscp 40

class-map match-all video-lan
  match access-group name video-lan

ip access-list extended video-lan
permit udp host 10.4.20.111 any eq 5004
permit udp host 10.4.20.111 any eq 5005

After that, I wanted to activated the expided Queue on the two switchs. When I activate the following commands on the switchs, nothing works anymore and my video was completely horrible:

Global commands

wrr-queue bandwidth 20 1 80 0

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

Command on the Trunk port:

mls qos trust dscp

The only way to rollback is to erase the config and put a new one without the previous command.

I don't understand the mistake in my config. I cannot turn off the QOS.

Thanks by advance for your helps

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: QOS Issue on Catalyst C2950

Look I am a novice at QOS, so don't expect any great help here but this is my 2 cents. At least I am tring! LOL

It is my understanding that "dscp" is ment over a layer 3 link. Do you have these switches connected via a layer 3 link?

Also, I understand that you need to put the command "mls qos" to enable QOS, to turn it off, enter the "no mls qos" command.

I really do wish I could be of more help.

Travis

6 REPLIES
New Member

Re: QOS Issue on Catalyst C2950

Look I am a novice at QOS, so don't expect any great help here but this is my 2 cents. At least I am tring! LOL

It is my understanding that "dscp" is ment over a layer 3 link. Do you have these switches connected via a layer 3 link?

Also, I understand that you need to put the command "mls qos" to enable QOS, to turn it off, enter the "no mls qos" command.

I really do wish I could be of more help.

Travis

New Member

Re: QOS Issue on Catalyst C2950

HI,

Can you post your

show mls qos maps dscp-cos

Thanks

Chris

New Member

Re: QOS Issue on Catalyst C2950

HEllo Chris,

Thanks for your interest. Here is the result of the command:


C2950G-110#sh mls qos maps dscp-cos

   Dscp-cos map:
       dscp:   0  8 10 16 18 24 26 32 34 40 46 48 56
     -----------------------------------------------
        cos:   0  1  1  2  2  3  3  4  4  5  5  6  7

New Member

Re: QOS Issue on Catalyst C2950

Hi,

I can't see any problem with the configuration your have posted - we have similar configuration working in our environment.

What happens if you change the ACL to a standard one permitting the IP of the video server - just want to verify that the traffic is being marked.

Thanks

Chris

New Member

Re: QOS Issue on Catalyst C2950

Hi,

The Acl works fine because when I capture the input traffic on the destination machine, I can see that all the packets are marked in CS5.

But for test I put the the client in the same vlan of the server and now it works.

So, I think that I've got a mistake in the configuration of my layer 3 switchs. I'll test it today and let you know a feedback.

Thanks

Gildas

New Member

Re: QOS Issue on Catalyst C2950

Hi,

I solved my problem. The issue was located on the layer 3 switches.

In fact my QOS was working fine when the traffic was located in the same vlan. The issue occured when the traffic should be processed by the layer 3 switches.

So, i put the following commands on all my trunk links:

mls qos trust dscp

And the the layer 3 switches I put the following configuration:

mls qos

And I kept the service-policy on the layer 2 switches, the closest  to the source.

Thanks for your help

Gildas

1149
Views
0
Helpful
6
Replies
CreatePlease to create content