Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

vg 224 fax receive intermittant smudged lines

We have a vg 224 configured as sccp to connnect to fax machine and the incoming PRI was controlled by Cucm 8.5 via MGCP. And tried all combinations, the RICOH machine still gets smudged lines intermittantly. Here is the configuration of vg224. Please help:

Building configuration...


Current configuration : 4727 bytes
!
! Last configuration change at 22:17:44 est Tue Jan 31 2012 by cdi-admin
! NVRAM config last updated at 22:17:45 est Tue Jan 31 2012 by cdi-admin
!
version 12.4
no service pad
service timestamps debug datetime localtime show-timezone year
service timestamps log datetime localtime show-timezone year
service password-encryption
!
hostname VG-ANALOG04
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 4096
no logging console
enable secret 5 $1$..wF$

!
no aaa new-model
clock timezone est -5
clock summer-time edt recurring
ip source-route
ip cef
no ip domain lookup
!
!
no ipv6 cef
!
!
!
!
!
!
!
voice service voip
fax protocol pass-through g711ulaw
modem passthrough nse codec g711ulaw
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
username cdi-admin password 7 1326333B462C0027222A
archive
log config
  hidekeys
!
!
!
!
!

interface FastEthernet0/0
ip address 10.100.205.84 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.100.205.1
ip http server
!
ip sla responder
!
!
control-plane
!
!
!
voice-port 2/0

no vad
timeouts ringing infinity
!
voice-port 2/1
no vad
timeouts ringing infinity
!
voice-port 2/2
no vad
timeouts ringing infinity
!
voice-port 2/3

no vad
timeouts ringing infinity
!
voice-port 2/4

no vad
timeouts ringing infinity
!
voice-port 2/5

no vad
timeouts ringing infinity
!
voice-port 2/6
no vad

timeouts ringing infinity
!
voice-port 2/7
!
voice-port 2/8
!
voice-port 2/9
!
voice-port 2/10
!
voice-port 2/11
!
voice-port 2/12
!
voice-port 2/13
!
voice-port 2/14
!
voice-port 2/15
!
voice-port 2/16
!
voice-port 2/17
!
voice-port 2/18
!
voice-port 2/19
!
voice-port 2/20
!
voice-port 2/21
!
voice-port 2/22
!
voice-port 2/23
!
!
no mgcp timer receive-rtcp
!
sccp local FastEthernet0/0
sccp ccm 10.100.205.10 identifier 3 version 7.0
sccp ccm 10.100.205.11 identifier 2 version 7.0
sccp ccm 10.100.205.12 identifier 1 version 7.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate ccm 2 priority 2
associate ccm 3 priority 3
switchback method graceful
!
!
dial-peer voice 200 pots
service stcapp

fax rate disable
port 2/0
!
dial-peer voice 201 pots
service stcapp
fax rate disable
port 2/1
!
dial-peer voice 202 pots
service stcapp

fax rate disable
port 2/2
!
dial-peer voice 203 pots
service stcapp

fax rate disable
port 2/3
!
dial-peer voice 204 pots
service stcapp

fax rate disable
port 2/4
!
dial-peer voice 205 pots
service stcapp
fax rate disable

port 2/5
!
dial-peer voice 206 pots
service stcapp

fax rate disable
port 2/6
!
dial-peer voice 207 pots
service stcapp
shutdown
port 2/7
!
dial-peer voice 208 pots
service stcapp
shutdown
port 2/8
!
dial-peer voice 209 pots
service stcapp
shutdown
port 2/9
!
dial-peer voice 210 pots
service stcapp
shutdown
port 2/10
!
dial-peer voice 211 pots
service stcapp
shutdown
port 2/11
!
dial-peer voice 212 pots
service stcapp
shutdown
port 2/12
!
dial-peer voice 213 pots
service stcapp
shutdown
port 2/13
!
dial-peer voice 214 pots
service stcapp
shutdown
port 2/14
!
dial-peer voice 215 pots
service stcapp
shutdown
port 2/15
!
dial-peer voice 216 pots
service stcapp
shutdown
port 2/16
!
dial-peer voice 217 pots
service stcapp
shutdown
port 2/17
!
dial-peer voice 218 pots
service stcapp
shutdown
port 2/18
!
dial-peer voice 219 pots
service stcapp
shutdown
port 2/19
!
dial-peer voice 220 pots
service stcapp
shutdown
port 2/20
!
dial-peer voice 221 pots
service stcapp
shutdown
port 2/21
!
dial-peer voice 222 pots
service stcapp
shutdown
port 2/22
!
dial-peer voice 223 pots
service stcapp
shutdown
port 2/23
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
password 7 050A0A03285F590C1509
login local
transport input all
!
ntp server 192.5.41.40 prefer
end

3 REPLIES
Hall of Fame Super Gold

vg 224 fax receive intermittant smudged lines

Take "show controllers T1" onf the PRI router.

Note the most robust solution for fax is using H.323 (or SIP) with T.38, not SCCP.

New Member

vg 224 fax receive intermittant smudged lines

Paolo,

    Thank you for your reply.

here is the PRI setup


Current configuration : 4713 bytes
!
!
version 15.1
service timestamps debug datetime localtime show-timezone year
service timestamps log datetime localtime show-timezone year
service password-encryption
service sequence-numbers
!
hostname XXXXXX
!
boot-start-marker
boot-end-marker
!
!
card type t1 0 0
card type t1 0 1
logging buffered 2500000
no logging rate-limit
no logging console
enable secret 5 $1$..wF$krGZQpcpPZa6xLyTY0
!
no aaa new-model
clock timezone EST -5 0
clock summer-time EST recurring
clock calendar-valid
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 T1 0/1/0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
no ip domain lookup
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-4ess
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-4191480364
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4191480364
revocation-check none
!
!
crypto pki certificate chain TP-self-signed-4191480364
certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 34313931 34383033 3634301E 170D3132 30323031 31323034
  32335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 31393134
  38303336 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C8AC 23369B3A 104D7D1D 50889B56 6FAFC0FC 679B1E8B FD127B9B 4A864E18
  C735C30C 1EC275CE AB0A461E CAC485BC 9225797F 4F02B8F6 4D1DD74B 97186BB7
  ED5C5069 4570C67E D092B24D E8DFE7F8 6E88E427 A352CA22 788226D9 79163767
  8095234E 91431356 FB065855 64070AAA 525C426D 406F9378 159D1695 16AEEF0D
  5DC10203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 14800A1E 7753AD8D C4D17569 2A7F98A8 B9CD89B2 B5301D06
  03551D0E 04160414 800A1E77 53AD8DC4 D175692A 7F98A8B9 CD89B2B5 300D0609
  2A864886 F70D0101 04050003 8181009C 54D470DD F3B6A8F3 B23C896B 3302631C
  24677CA3 35A2AD93 C6BE0C35 B621480F 9005D468 894F0B32 69CBBC7C 85F933AB
  33AC2811 3868E409 5127CC8A DA01B6BF 724945A2 FAF521C7 95799F41 D706EFBD
  DC4DD9AC D9D70C70 3A1D7E89 9DA17124 CFF9ECD9 86A0D5C8 FB2FEA90 21D488E3
  130F7C8A 2A28ED14 4F04A4AF 117F67
        quit
voice-card 0
!
!
!
voice service voip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
!
!
!
!
!
license udi pid CISCO2901/K9 sn FTX151300FK
hw-module pvdm 0/0
!
!
!
username admin password 7 1326333B462C0027222A
!
redundancy
!
!
controller T1 0/0/0
shutdown
cablelength long 0db
!
controller T1 0/0/1
shutdown
cablelength long 0db
!
controller T1 0/1/0
cablelength long 0db
pri-group timeslots 1-24 service mgcp
!
controller T1 0/1/1
shutdown
cablelength long 0db
!
!
!
!
!
interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
ip address 10.100.105.86 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 10.100.105.1
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
!
control-plane
!
!
voice-port 0/1/0:23
echo-cancel coverage 64
!
ccm-manager redundant-host 10.100.105.12
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 10.100.105.11
ccm-manager config
!
mgcp
mgcp call-agent 10.100.105.11 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode cisco
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
mgcp package-capability fm-package
mgcp default-package fxr-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
!
mgcp profile default
!
!
!
!
!
gatekeeper
shutdown
!
!
!
line con 0
login local
line aux 0
line vty 0 4
exec-timeout 60 0
privilege level 15
password 7 050A0A0F590C1509
login local
transport input all
line vty 5 15
exec-timeout 60 0
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp server 192.5.41.40
end

Hall of Fame Super Gold

vg 224 fax receive intermittant smudged lines

I would use a protocol that allows fax relay, e.g., H.323 or SIP directly between PRI and FXS VGs.

Or you can search if there is some options for better fax with the way you're setup, thing that personaly I don't know.

447
Views
0
Helpful
3
Replies