Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VOIP Codec problem with Modem-passthrough

Hi All,

The client runs VOIP and experience problems connecting two modems over the VOIP network. The call is made with G711 and after a few seconds the codecs change back to G729 and the modem connection is disconnected. Attached is more info regarding the config , the IOS and output of some debugs. We suspect a problem with the IOS but are not sure. Also , this config was working in the past and nothing changed. Does anyone have some ideas on why the codecs are changing ?

the connection is as follow:

?

PC(modem) -> PABX--E1-- ->?Router ---{CORE? Network}---->Router-->E1-->PABX-->PSTN

?

I hope this makes sense...

Here is the problem stated by the client.

A call is initiated? from the RBG router to the CTN router. The codec used is the default(g729r8). When the modem answers then? the codec changes to g711alaw, which is part of the dialpeer configuration for?modem passthrough. However whilst the modems are still training then the codec reverts back to g729r8, which result in a modem connection attempt.

All your input will be highly appreciated

3 REPLIES
Silver

Re: VOIP Codec problem with Modem-passthrough

To configure Modem Passthrough over VoIP for a specific dial peer, use the modem passthrough dial-peer configuration command. To use the global default for a specific dial peer, use the modem passthrough system command. To disable modem passthrough for a specific dial peer, use the no modem passthrough command.

modem passthrough {system | nse [payload-type number] codec {g711ulaw | g711alaw} [redundancy]}

no modem passthrough

http://www.cisco.com/en/US/products/sw/iosswrel/ps1834/products_feature_guide09186a008008024f.html#1024913

New Member

Re: VOIP Codec problem with Modem-passthrough

I did check the config and even simulated it in a lab enviroment and it works. We even added the "codec g711ulaw" command on the specific dial-peer but without any success. The modem connects to the remote site with G711 and falls back to G729 after about a minute or so.

Here is some output:

CRBGVOIP#sho voice call stat

CallID CID ccVdb Port DSP/Ch Called # Codec Dial-peers

0xB5A4E 325D 0x639DB5A0 1/0:15.21 5/4 721008608 g711alaw 101/21

0xB5A50 3260 0x639DB5A0 1/0:15.20 5/3 721008601 g711alaw 101/16

2 active calls found

CRBGVOIP#sho voice call stat

CallID CID ccVdb Port DSP/Ch Called # Codec Dial-peers

0xB5A4E 325D 0x639DB5A0 1/0:15.21 5/4 721008608 g711alaw 101/21

0xB5A50 3260 0x639DB5A0 1/0:15.20 5/3 721008601 g711alaw 101/16

2 active calls found

CRBGVOIP#sho voice call stat

CallID CID ccVdb Port DSP/Ch Called # Codec Dial-peers

0xB5A4E 325D 0x639DB5A0 1/0:15.21 5/4 721008608 g711alaw 101/21

0xB5A50 3260 0x639DB5A0 1/0:15.20 5/3 721008601 g711alaw 101/16

2 active calls found

CRBGVOIP#sho voice call stat

CallID CID ccVdb Port DSP/Ch Called # Codec Dial-peers

0xB5A4E 325D 0x639DB5A0 1/0:15.21 5/4 721008608 g711alaw 101/21

0xB5A50 3260 0x639DB5A0 1/0:15.20 5/3 721008601 g711alaw 101/16

2 active calls found

CRBGVOIP#sho voice call stat

CallID CID ccVdb Port DSP/Ch Called # Codec Dial-peers

0xB5A4E 325D 0x639DB5A0 1/0:15.21 5/4 721008608 g711alaw 101/21

0xB5A50 3260 0x639DB5A0 1/0:15.20 5/3 721008601 g729r8 101/16

0xB5A52 3263 0x639DB5A0 1/0:15.19 5/2 0113713601 g729r8 101/7

3 active calls found

CRBGVOIP#sho voice call stat

CallID CID ccVdb Port DSP/Ch Called # Codec Dial-peers

0xB5A4E 325D 0x639DB5A0 1/0:15.21 5/4 721008608 g711alaw 101/21

0xB5A50 3260 0x639DB5A0 1/0:15.20 5/3 721008601 g729r8 101/16

0xB5A52 3263 0x639DB5A0 1/0:15.19 5/2 0113713601 g729r8 101/7

3 active calls found

CRBGVOIP#sho voice call stat

CallID CID ccVdb Port DSP/Ch Called # Codec Dial-peers

0xB5A4E 325D 0x639DB5A0 1/0:15.21 5/4 721008608 g711alaw 101/21

0xB5A50 3260 0x639DB5A0 1/0:15.20 5/3 721008601 g729r8 101/16

0xB5A52 3263 0x639DB5A0 1/0:15.19 5/2 0113713601 g729r8 101/7

3 active calls found

The dail-peers used is 16 and 101

To see the config , have a look at the sho tech-support and debugs.zip

Jaco

Re: VOIP Codec problem with Modem-passthrough

Hi,

Try adding the following command for proper clocking

network-clock-participate wic 1

network-clock-select 1 E1 0/1/0

should point your ISDN E1 interface.

Also

voice service voip

modem passthrough nse codec g711alaw

should be used to specify the codec you'll use.

Try adding these to your fax dial-peer

modem passthrough nse codec g711alaw

session target ipv4:X.X.X.X

dtmf-relay h245-signal h245-alphanumeric

fax-relay ecm disable

fax rate disable

Are you using an ATA?

346
Views
0
Helpful
3
Replies
CreatePlease to create content