Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3725 + CME + SIP Provider = Frustration

I am a telecom tech trying to learn about more about the Cisco world. I have been trying to get CME registered to a SIP provider (Broadvoice) for a few weeks now with no luck.  Can anyone look at this and let me know if there are any blatent problems?  I am including some of a DEBUG MESSAGES below as well.

*********************************************************************************************************

*********************************************************************************************************

*************************************3725 CONFIG****************************************************

*********************************************************************************************************

*********************************************************************************************************

!
! Last configuration change at 18:05:07 cst Thu Feb 28 2002
! NVRAM config last updated at 18:06:54 cst Thu Feb 28 2002
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME3725
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
clock timezone cst -6
ip cef
!
!
!
!
ip host sip.broadvoice.com 147.135.8.128
ip host proxy.nyc.broadvoice.com 147.135.20.221
!
multilink bundle-name authenticated
!
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to sip
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
h323
  call service stop
sip
  bind control source-interface FastEthernet0/0
  bind media source-interface FastEthernet0/0
  registrar server expires max 3600 min 3600
   localhost dns:sip.broadvoice.com
  no update-callerid
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
!
!
!
!
!
!
!
!
!
!
voice register global
mode cme
source-address 192.168.1.201 port 5060
max-dn 2
max-pool 1
authenticate register
tftp-path flash:
create profile sync 0011343535014052
!
voice register dn  1
number 21443XXXXX
allow watch
name cisco
shared-line
label 1005
mwi
!
voice register pool  1
id mac 0000.0000.0000
number 1 dn 1
dtmf-relay rtp-nte
username 1005 password 1005
codec g711alaw
!
!
voice source-group SIP-Trunks
access-list 50
!
voice source-group SIP_Trunks
!
voice translation-rule 1
rule 1 /^.*/ /21443XXXXX/
!
voice translation-rule 2
rule 1 /21443XXXXX/ /1005/
!
voice translation-rule 3
rule 1 /^214(.*)/ /\1/
rule 2 /\(..........\)/ /1\1/
!
!
voice translation-profile Broadvoice_IN
translate calling 3
translate called 2
!
voice translation-profile Broadvoice_OUT
translate calling 1
!
!
!
!
!
!
username cisco privilege 15 secret 5 $1$MB2M$RtpE/ooDpcXUIfij1GCJ0.
username 1005 password 0 1005
archive
log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.201 255.255.255.0
speed auto
half-duplex
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.254
!
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
dial-peer voice 1 voip
description ** Outgoing Broadvoice 10-digit **
translation-profile outgoing Bradvoice_OUT
preference 2
destination-pattern 1..........
voice-class codec 1
session protocol sipv2
session target ipv4:147.135.20.221
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 43XXXXX voip
description ** Incoming Broadvoice **
translation-profile incoming Broadvoice_IN
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target sip-server
incoming called-number 21443XXXXX
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 86 voip
description ** Outgoing Broadvoice Voice-Mail **
destination-pattern *86
voice-class codec 1
session protocol sipv2
session target ipv4:147.135.20.221
dtmf-relay rtp-nte
ip qos dscp cs5 media
no vad
!
!
sip-ua
authentication username 21443XXXXX password 7 143F21XXXXXXXXXXXXXXXXX realm BroadWorks
no remote-party-id
retry register 3
retry options 1
timers connect 100
mwi-server ipv4:147.135.20.221 expires 3600 port 5060 transport udp unsolicited
registrar ipv4:147.135.20.221 expires 3600
sip-server ipv4:147.135.20.221
  host-registrar
!
!
!
telephony-service
load 7921 CP7921G-1.0.1/CP7921G-1.0.1.
max-ephones 5
max-dn 5
ip source-address 192.168.1.201 port 2000
max-conferences 4 gain -6
dn-webedit
transfer-system full-consult
!
!
ephone-dn  1
number 1003 no-reg primary
name The Fishers
!
!
ephone-dn  2
number 1002 no-reg primary
name Other Phones
!
!
ephone  1
device-security-mode none
mac-address 0023.5E67.74EA
type 7921
button  1:1
!
!
!
ephone  2
device-security-mode none
mac-address 0023.5E67.758C
type 7921
button  1:2
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
ntp clock-period 17180118
ntp master
ntp server 129.6.15.28
!
end

*********************************************************************************************************

*********************************************************************************************************

********************************************DEBUG****************************************************

*********************************************************************************************************

*********************************************************************************************************

Aug  8 01:34:16.316: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:92145XXXXXX@192.168.1.201 SIP/2.0
Via: SIP/2.0/UDP 192.168.1.200:41812;branch=z9hG4bK-d87543-06266a34ed272f5b-1--d87543-;rport
Max-Forwards: 70
Contact: <sip:21443XXXXX@192.168.1.200:41812>
To: "92145XXXXXX"<sip:92145XXXXXX@192.168.1.201>
From: "MY NAME HERE"<sip:21443XXXXX@192.168.1.201>;tag=5f37a274
Call-ID: 6220fa11bb1c6c46ODhkYmEwYzRlMmFmNzY0NDdkZjQzZDFlMzEzMzFhM2Q.
CSeq: 1 INVITE
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, NOTIFY, MESSAGE, SUBSCRIBE, INFO
Content-Type: application/sdp
User-Agent: X-Lite release 1002tx stamp 29712
Content-Length: 485

v=0
o=- 5 2 IN IP4 192.168.1.200
s=<CounterPath eyeBeam 1.5>
c=IN IP4 192.168.1.200
t=0 0
m=audio 26344 RTP/AVP 107 119 0 98 8 3 101
a=alt:1 3 : orcMzWYQ jqWa9BMB 192.168.1.200 26344
a=alt:2 2 : S9KWsCq2 awpCGnJ0 192.168.1.76 26344
a=alt:3 1 : rMS6WAXp CvmP73Zj 192.168.1.100 26344
a=fmtp:101 0-15
a=rtpmap:107 BV32/16000
a=rtpmap:119 BV32-FEC/16000
a=rtpmap:98 iLBC/8000
a=rtpmap:101 telephone-event/8000
a=sendrecv
a=x-rtp-session-id:A8F366E8CB8B472F8215DFD332367F73

Aug  8 01:34:16.444: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.1.200:41812;branch=z9hG4bK-d87543-06266a34ed272f5b-1--d87543-;rport
From: "MY NAME HERE"<sip:21443XXXXX@192.168.1.201>;tag=5f37a274
To: "92145XXXXXX"<sip:92145XXXXXX@192.168.1.201>
Date: Sun, 08 Aug 2010 01:34:16 GMT
Call-ID: 6220fa11bb1c6c46ODhkYmEwYzRlMmFmNzY0NDdkZjQzZDFlMzEzMzFhM2Q.
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 1 INVITE
Allow-Events: telephone-event
Content-Length: 0

Aug  8 01:34:16.592: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:92145XXXXXX@147.135.20.221:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.1.201:5060;branch=z9hG4bK1A91C
From: "MY NAME HERE" <sip:21443XXXXX@147.135.20.221>;tag=2E67CC-894
To: <sip:92145XXXXXX@147.135.20.221>
Date: Sun, 08 Aug 2010 01:34:16 GMT
Call-ID: E44B61A7-A1C311DF-8040E36F-ACB3F77F@sip.broadvoice.com
Supported: 100rel,timer,resource-priority,replaces
Min-SE:  1800
Cisco-Guid: 3828225533-2713915871-2151408495-2897475455
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1281231256
Contact: <sip:21443XXXXX@192.168.1.201:5060>
Expires: 180
Allow-Events: telephone-event
Max-Forwards: 69
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 250

v=0
o=CiscoSystemsSIP-GW-UserAgent 3473 6602 IN IP4 192.168.1.201
s=SIP Call
c=IN IP4 192.168.1.201
t=0 0
m=audio 16398 RTP/AVP 8 101
c=IN IP4 192.168.1.201
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=ptime:20

Aug  8 01:34:16.752: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 100 Trying
Call-ID: E44B61A7-A1C311DF-8040E36F-ACB3F77F@sip.broadvoice.com
CSeq: 101 INVITE
From: "MY NAME HERE" <sip:21443XXXXX@147.135.20.221>;tag=2E67CC-894
To: <sip:92145XXXXXX@147.135.20.221>
Via: SIP/2.0/UDP 192.168.1.201:5060;branch=z9hG4bK1A91C
Content-Length:    0

Aug  8 01:34:16.792: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 403 Forbidden
Call-ID: E44B61A7-A1C311DF-8040E36F-ACB3F77F@sip.broadvoice.com
CSeq: 101 INVITE
From: "MY NAME HERE" <sip:21443XXXXX@147.135.20.221>;tag=2E67CC-894
To: <sip:92145XXXXXX@147.135.20.221>;tag=vwxy
Via: SIP/2.0/UDP 192.168.1.201:5060;branch=z9hG4bK1A91C
Allow-Events: telephone-event
User-Agent: Cisco-SIPGateway/IOS-12.x
Content-Length:  187
Content-Type: application/sdp

v=0
o=1664745546 3473 6602 IN IP4 99.53.0.78
s=-
c=IN IP4 99.53.0.78
t=0 0
m=audio 16398 RTP/AVP 8 101
c=IN IP4 99.53.0.78
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000

Aug  8 01:34:16.900: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
ACK sip:92145XXXXXX@147.135.20.221:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.1.201:5060;branch=z9hG4bK1A91C
From: "MY NAME HERE" <sip:21443XXXXX@147.135.20.221>;tag=2E67CC-894
To: <sip:92145XXXXXX@147.135.20.221>;tag=vwxy
Date: Sun, 08 Aug 2010 01:34:16 GMT
Call-ID: E44B61A7-A1C311DF-8040E36F-ACB3F77F@sip.broadvoice.com
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: telephone-event
Content-Length: 0

Aug  8 01:34:16.912: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 192.168.1.200:41812;branch=z9hG4bK-d87543-06266a34ed272f5b-1--d87543-;rport
From: "MY NAME HERE"<sip:21443XXXXX@192.168.1.201>;tag=5f37a274
To: "92145XXXXXX"<sip:92145XXXXXX@192.168.1.201>;tag=2E6920-1C05
Date: Sun, 08 Aug 2010 01:34:16 GMT
Call-ID: 6220fa11bb1c6c46ODhkYmEwYzRlMmFmNzY0NDdkZjQzZDFlMzEzMzFhM2Q.
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 1 INVITE
Allow-Events: telephone-event
Reason: Q.850;cause=57
Content-Length: 0

Aug  8 01:34:16.984: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:92145XXXXXX@192.168.1.201 SIP/2.0
Via: SIP/2.0/UDP 192.168.1.200:41812;branch=z9hG4bK-d87543-06266a34ed272f5b-1--d87543-;rport
To: "92145XXXXXX"<sip:92145XXXXXX@192.168.1.201>;tag=2E6920-1C05
From: "MY NAME HERE"<sip:21443XXXXX@192.168.1.201>;tag=5f37a274
Call-ID: 6220fa11bb1c6c46ODhkYmEwYzRlMmFmNzY0NDdkZjQzZDFlMzEzMzFhM2Q.
CSeq: 1 ACK
Content-Length: 0

*********************************************************************************************************

*********************************************************************************************************

************************************SIP REG STATUS************************************************

*********************************************************************************************************

CME3725#SHO SIP REG STATUS
Line          peer           expires(sec)  registered
============  =============  ============  ===========
CME3725#

*********************************************************************************************************

1 REPLY
Cisco Employee

Re: 3725 + CME + SIP Provider = Frustration

Two things appear to be occurring:

a) You don't have a registration with your provider.  Maybe they don't require that.  But if they do, no numbers are trying to be registered.

b) The inbound call is not matching an internal extension, and as a result is matching a pattern and routing back out to your ITSP.

You can take care of both of these with:

ephone-dn  1
number 1003 secondary no-reg primary
name The Fishers


Now, make a call to that number you used for the secondary number.  Assuming a phone is assigned to DN 1 and registered, it will ring that phone.

-Steve

1009
Views
0
Helpful
1
Replies
CreatePlease to create content